Download it now!
Bug 79287 - Selecting columns causes horizontal scrolling keeps going and can not be stopped
Summary: Selecting columns causes horizontal scrolling keeps going and can not be stopped
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.4.2 release
Hardware: x86 (IA32) Windows (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-27 03:36 UTC by Kevin Suo
Modified: 2017-11-10 11:07 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Suo 2014-05-27 03:36:07 UTC
Description:
When I was trying to select some columns in Calc, calc start to scroll to the right and can not be stopped, untill the last column (AMJ).

Simple steps to reproduce:
1. New spreadsheet;
2. A1 = "1", then "fill series" row 1 (so we have 1,2,3,...,1024 in row 1);
3. Try to select some columns from left to right, for example on my screen Column P is the last visible column, so I was trying to select N:...

Please note: sometimes this is hard to reproduce, as the speed of your selection action is important. (you should not be too slow or too fast).

Current behaviour:
Calc keeps scrolling to the right, even you release the mouse click. Hit ESC or any key do not stop it scrolling.

Expected:
Calc stops scrolling as soon as you stop the selection / release the mouse click.

OS: Windows XP SP3
LO Version: 4.4.2
Also reproducible in 4.3.0 beta 1.
Comment 1 m.a.riosv 2014-05-27 22:10:56 UTC
With 
WinXP Sp3 / Win7x64
Version: 4.2.4.2 Build ID: 63150712c6d317d27ce2db16eb94c2f3d7b699f8
Win7x64
Version: 4.3.0.0.beta1 Build ID: 2e39c7e59c8fc8b16a54c3d981dceef27fb0c07f

I can't reproduce de non stop scrolling issue.

I can stop but after four or five columns have been selected.
No possible for me select only one more column from the last column in the window.
I am not able to resolve it playing with mouse options in the system.
Comment 2 Kevin Suo 2014-05-28 06:30:26 UTC
I have made a screen video to show the steps. Try to download the SWF file from here:

http://t1.dfs.kuaipan.cn/cdlsched/getdl?fid=2595367132601450&acc_params=entryid:2595367132601450,pickupCode:

If you can not visit the above link, you can also get it here (but may be too slow):

http://suokunlong.cn/tmp/scolling4.swf
Comment 3 Yousuf Philips (jay) (retired) 2014-05-28 08:10:33 UTC
Tried on Windows XP SP3 and no luck, even after watching the video, and following the below instructions from IRC

<suokunlong> to reproduce, you have to be slow when selecting columns,
<suokunlong> and pause for 1 or 2 seconds before release your mouse
Comment 4 Kevin Suo 2014-06-09 04:03:13 UTC
I am not sure what info is needed, so I set this back to UNCONFIRMED.

@Jay Philips, if you can not reproduce this, then let others to confirm, so it should stay the status UNCONFIRMED.
Comment 5 Yousuf Philips (jay) (retired) 2014-06-09 13:45:37 UTC
(In reply to comment #4)
> I am not sure what info is needed, so I set this back to UNCONFIRMED.
> 

Well i guess i set it to needinfo, so that you may supply us with any additional information that may think of that may help us to reproduce the issue.
Comment 6 Yousuf Philips (jay) (retired) 2014-06-24 10:31:04 UTC
Hey Suo,

Have you been able to reproduce this issue on any other operating system?
Comment 7 Kevin Suo 2014-06-25 01:56:47 UTC
(In reply to comment #6)
> Have you been able to reproduce this issue on any other operating system?
I do not reproduce in Ubuntu 14.04, only reproduce in Windows XP at this moment. Not tried with Windows 7, will do later if I have access to the win7 machine.
Comment 8 Kevin Suo 2014-07-18 04:09:43 UTC
I do not reproduce this issue with the latest versions,
so I set this as WORKSFORME.
Comment 9 Dominik 2014-07-19 09:25:50 UTC
i can reproduce on win7 / LO 4.3.0.3

open a document, select 1 cell, drag the "fill cube" to the right, so that it starts scrolling, release mouse button.

LO immediately gets unresponsive an just stops when reaching the rightmost column (AMJ)
Comment 10 cj 2014-07-23 14:36:35 UTC
I'll drop in and say that I have the same problem. 
But for me it's scrolling vertically.
It has just reached line 20000 and I can't stop it w/o closing the program and possible loosing the non saved information....
Comment 11 Joel Madero 2014-08-04 16:01:41 UTC
REOPENED is reserved for a bug that:

1. a developer has marked as FIXED;
2. a developer is assigned to the bug that is marked as FIXED;

In this case the bug report was never independently confirmed so correct status is UNCONFIRMED. Thanks!
Comment 12 Kevin Suo 2014-08-04 17:32:16 UTC
This was REOPENED because comment 9 and comment 10 all confirm this.
Set to NEW.
Comment 13 Kevin Suo 2015-02-19 15:02:43 UTC
do not reproduce with most recent version. closed as WORKSFORME.