Bug Hunting Session
Bug 79288 - LibreOffice Calc / Spreadsheet .ods format very slow when saving
Summary: LibreOffice Calc / Spreadsheet .ods format very slow when saving
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.4.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-27 03:41 UTC by Francewhoa
Modified: 2014-06-02 21:27 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
The test file I have tried in Windows XP (144.19 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-05-27 05:45 UTC, Kevin Suo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Francewhoa 2014-05-27 03:41:12 UTC
Issue: LibreOffice Calc/Spreadsheet is very slow when saving to ".ods" file type. It takes 10 to 40 seconds on each save. Depending on the size of the spreadsheet. The amount of text in the cell is directly correlated to the length of time required to save the spreadsheet.

Steps to reproduce
1. Create a fresh new calc document
2. Type in any plain text in cells, at least 512 characters
3. Copy then paste that cell at least 50 times into new cells. For a total of 50+ cells.
4. Copy that sheet at least 10 times into new sheets. For a total of 11+ sheets.
5. Click on "Save" button. Select ".ods" file type. It takes 10 to 40 seconds to save depending on spreadsheet size.
6. Make a small change like changing only one character inside one cell. Click on "Save" button. It takes 10 to 40 seconds on each save.
7. I usually work with 30+ spreadsheets open at once, frequently making small changes and frequently saving. LibreOffice 4.1.4 is painfully slow when saving to ".ods" file type. Expected result is improve performance on saves. Loading a document is very fast though. 


Using:
* LibreOffice 4.1.4, 64 bit
* Debian 7.5 (wheezy) 64-bit
* Kernel Linux 3.2.0-4-amd64
* GNOME 3.4.2
* Memory: 16 GB
* Processor: Intel Core i7-3770S, 3.10 GHZ, 8 CPU activated
* Storage: Solid State Disk (SSD)
* Notes
** Fresh new computer install
** All hardware are 2013 or 2014
** LibreOffice is the only software open
** Calc document contains only plain text, nothing else, no graphic, no text formatting, no color, no nothing else than plain text
** LibreOffice was install from the Official Debian repository: "libreoffice-gnome-1:4.1.4-2~bpo70+1 (64-bit)", maintainer: Debian LibreOffice Maintainers <debian-openoffice@lists.debian.org>

Things I tried but with same slow save result
* Using other computers
* Re-installing LibreOffice
* Increase memory to maximum allowed by LibreOffice. Under "Options > Load/Save > General"
* Save spreadsheet in other LibreOffice formats, such as ".fods"

Thing I tried that resulted in huge performance improvement
* Save in Microsoft format ".xlsx". Very fast performance, down from 40 seconds to 1 second or less. But this is just a temporary workaround. I would prefer using ".ods" format because: it's the default format for LibreOffice; it's open source; and own by a community not own by a corporation.
Comment 1 Kevin Suo 2014-05-27 05:43:56 UTC
(In reply to comment #0)

I do not reproduce follow these steps, in LibreOffice 4.2.4.2:

> Steps to reproduce
> 1. Create a fresh new calc document
> 2. Type in any plain text in cells, at least 512 characters

I typed "abcdefghijklmnopqrstuvwxyz..." with the lenth of 546, in A1;

> 3. Copy then paste that cell at least 50 times into new cells. For a total
> of 50+ cells.

I copied the above cell into A2:A110. (for the fisrt some cells I select each cell then paste; for the rest I select a range and paste);

> 4. Copy that sheet at least 10 times into new sheets. For a total of 11+
> sheets.

I copied Sheet1 10 times (in the same spreadsheet) and get "Sheet1_1,Sheet1_2,Sheet1_3...";

> 5. Click on "Save" button. Select ".ods" file type. It takes 10 to 40
> seconds to save depending on spreadsheet size.

I click the save button, the file was saved with no time delay (within 1 second);

> 6. Make a small change like changing only one character inside one cell.
> Click on "Save" button. It takes 10 to 40 seconds on each save.

I changed the first char in A1 "a" to "b", then click save, the file was saved within 1 second.

@Francewhoa, have you tried version 4.2.4.2? is it also reproducible in the newer versions? Do you reproduce the same issue on Windows?
Comment 2 Kevin Suo 2014-05-27 05:45:28 UTC
Created attachment 99917 [details]
The test file I have tried in Windows XP
Comment 3 Kevin Suo 2014-05-27 05:47:02 UTC
(In reply to comment #1)

Sorry I did not mention, these steps are done in Windows XP SP3, LibreOffice 4.2.4.2.
Comment 4 Francewhoa 2014-05-27 06:17:39 UTC
suokunlong, thx for testing :)

I have not tried 4.2.4.2. I would love to, but it is not yet available in the Debian repository at https://packages.debian.org/wheezy-backports/libreoffice-gnome

I considered installing 4.2.4.2 or the latest version from the .deb package available at http://www.libreoffice.org/download/libreoffice-fresh/ but its readme file says my system does not have the minimum requirements. My system is:
* Debian 7.5 (wheezy) 64-bit
* Kernel Linux 3.2.0-4-amd64
* GNOME 3.4.2

I have not tried on Windows. I use Debian Linux. I'm not interested in using Windows.

I'm able to test various OS and LO versions using Virtualbox though, I might try that and post result here
Comment 5 Kevin Suo 2014-05-27 07:49:33 UTC
(In reply to comment #4)

From here:
http://www.libreoffice.org/get-help/system-requirements/#Linux

The software and hardware prerequisites for installing on Linux are as follows:
    Linux kernel version 2.6.18 or higher;
    glibc2 version 2.5 or higher;
    gtk version 2.10.4 or higher;
    Pentium-compatible PC (Pentium III, Athlon or more-recent system recommended);
    256Mb RAM (512Mb RAM recommended);
    Up to 1.55Gb available hard disk space;
    X Server with 1024x768 resolution (higher resolution recommended), with at least 256 colors;
    Gnome 2.16 or higher, with the gail 1.8.6 and at-spi 1.7 packages (required for support for assistive technology [AT] tools), or another compatible GUI (such as KDE, among others).

So your system is higher than the minimum.

To install the TDF build of LibreOffice in debian, I guess you should do the follow:

* Uninstall the debian build of libreoffice by "sudo apt-get purge libreoffice*"
* "sudo apt-get install /DEB dir/*.deb
Comment 6 Kevin Suo 2014-05-27 07:50:49 UTC
(In reply to comment #5)

> * "sudo apt-get install /DEB dir/*.deb
Sorry, should be: "sudo dpkg -i /DEB dir/*.deb"
Comment 7 Francewhoa 2014-05-27 16:39:46 UTC
suokunlong, you're right my system is higher than the minimum requirements. I missread the readme file.

I'll try to test the latest version and post result here
Comment 8 Francewhoa 2014-06-02 21:26:49 UTC
All, done I tried version 4.2.4.2. Confirming that issue is fixed in LibreOffice (LO) 4.2.4.2.

BTW starting today LO 4.2.4.2 is available in the Debian repository for automated update

With LO 4.2.4.2 the ".ods" file type seems a little bit faster than ".xlsx", yay :)