Bug 79319 - RTF: horizontal rule imported as very large rectangle shape
Summary: RTF: horizontal rule imported as very large rectangle shape
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: Other Windows (All)
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: BSA target:4.4.0 target:4.3.1
Keywords: filter:rtf, regression
: 81355 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-05-27 14:47 UTC by Helmut Leininger
Modified: 2017-09-18 17:47 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot of wrong output (186.80 KB, image/jpeg)
2014-05-27 14:47 UTC, Helmut Leininger
Details
Document showing the error (60.44 KB, application/msword)
2014-05-27 14:49 UTC, Helmut Leininger
Details
how the vertical bar shows in 4.0 vs 4.3 (393.79 KB, image/png)
2014-05-28 05:37 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Helmut Leininger 2014-05-27 14:47:46 UTC
Created attachment 99956 [details]
screenshot of wrong output

Problem description: 
Wrong rendering of RTF document. There is a colored vertical bar at the left that hides some content of the page. This bar appears also when printing this document.

There is no problem with MS-Word.              
Operating System: Windows 8
Version: 4.2.4.2 release
Comment 1 Helmut Leininger 2014-05-27 14:49:29 UTC
Created attachment 99957 [details]
Document showing the error
Comment 2 Yousuf Philips (jay) (retired) 2014-05-28 05:32:44 UTC
Confirmed in Linux Mint in the latest releases from 3.6 to 4.2 and 4.3 beta, though 3.6 and 4.0 doesnt overlap the table contents with the veritical bar.

I was able to delete the vertical bar by clicking on it in the header and footer and pressing delete.
Comment 3 Yousuf Philips (jay) (retired) 2014-05-28 05:37:48 UTC
Created attachment 99999 [details]
how the vertical bar shows in 4.0 vs 4.3
Comment 4 Michael Stahl (CIB) 2014-07-07 20:36:30 UTC
this bug looks quite similar to bug 76633 ...

except that the rectangle is visible since version 3.5.0,
and the fix for bug 76633 did not remove the rectangle in
this document.

actually the document crashes in current libreoffice-4-3.
Comment 5 Michael Stahl (CIB) 2014-07-18 10:51:00 UTC
crashes because of ba9b63d8101197d3fd8612193b1ca188271dfc1a

fixed that.

the rectangle is really a "horizontal rule" that should be
in the header and footer; LO didn't support the special
properties for that yet; fixed.

the horizontal rule shapes look right now, they are just
wrongly positioned, sometimes even outside the page
so not visible; but that is a separate bug and not
a regression and is not fixed yet.
Comment 6 Commit Notification 2014-07-18 10:51:59 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2b9e782497cb962d9ca74a851a1389b0e29df49c

(related: fdo#79319) writerfilter: RTF import: fix crash on "fake" pict



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2014-07-18 10:52:14 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=589ca2a5e88a976bb10e60fcb1e3e75f4aa2504e

fdo#79319: writerfilter: RTF import: support horizontal rule



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2014-07-18 10:52:28 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9aa80fcb291083dc2a396db3d1be756eb4a0e54b

(related: fdo#79319): writerfilter: RTF imoprt: don't lose shapes in header



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2014-07-25 09:30:48 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=44828af6a2526ff63b28074ea58a12b8b8bb1257&h=libreoffice-4-3

(related: fdo#79319) writerfilter: RTF import: fix crash on "fake" pict


It will be available in LibreOffice 4.3.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2014-07-25 09:32:34 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2ed95c9f8507d711f46360317e546683c7f0b8c2&h=libreoffice-4-3

fdo#79319: writerfilter: RTF import: support horizontal rule


It will be available in LibreOffice 4.3.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2014-07-25 09:32:49 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ca88a0ea6ed7277e8522d83458e3cfb975fcfb7d&h=libreoffice-4-3

(related: fdo#79319): writerfilter: RTF import: don't lose shapes in header


It will be available in LibreOffice 4.3.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 12 Miklos Vajna 2014-08-02 11:50:52 UTC
*** Bug 81355 has been marked as a duplicate of this bug. ***
Comment 13 Robinson Tryon (qubit) 2015-12-17 12:38:26 UTC Comment hidden (obsolete)