Bug Hunting Session
Bug 79334 - Image scaling looks better in 4.1 than in 4.2 and above
Summary: Image scaling looks better in 4.1 than in 4.2 and above
Status: RESOLVED DUPLICATE of bug 123372
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Writer-Images GraphicPrimitive2D-regressions
  Show dependency treegraph
 
Reported: 2014-05-27 19:37 UTC by Yousuf Philips (jay) (retired)
Modified: 2019-04-12 23:08 UTC (History)
12 users (show)

See Also:
Crash report or crash signature:


Attachments
shows the image scaling in LibO 4.1 vs 4.3 beta (192.45 KB, image/png)
2014-05-27 19:37 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-05-27 19:37:04 UTC
Created attachment 99980 [details]
shows the image scaling in LibO 4.1 vs 4.3 beta

While reviewing attachment 97273 [details] in bug 77374, i noticed an image in the file which in LibO 4.2 and above doesnt scale as well as in 4.1 and below.
Comment 1 Michael Stahl (CIB) 2014-05-30 13:23:30 UTC
there are 2 visible differences in the document.

1. the images are colored in 4.1.6, grayscale in 4.2

2. if you look closely e.g. on the bears the
   lines are a little smoother in 4.1.6 than in 4.2

this bug is about 2.; the grayscale (1.) is actually *correct*,
i.e. a new feature in the DOCX import.
Comment 2 Michael Stahl (CIB) 2014-05-30 13:35:25 UTC
another one caused by commit 2e5167528f7566dd9b000e50fc1610b7bf99132a
Comment 3 Yousuf Philips (jay) (retired) 2014-05-31 01:29:37 UTC
Yes you are correct. It seems to be due to the grayscaling function running on the image which is causing the issue.
Comment 4 Michael Meeks 2014-11-04 14:02:20 UTC
So... I imagine this was turning off the high quality interpolation on images which was causing significant slow-downs (?) Either way - in the brave new OpenGL world, we get high quality scaling nearly for free so ... hopefully we can put this one to bed then & get quality and performance =)
Comment 5 Michael Stahl (CIB) 2014-11-04 14:33:08 UTC
(In reply to Michael Meeks from comment #4)
> So... I imagine this was turning off the high quality interpolation on
> images which was causing significant slow-downs (?) Either way - in the

no, that was for bug 80498 which was fixed months after this one
was reported; more likely the drawing-layer based rendering
used in Writer since 4.2 doesn't do the same interpolation
as the old GraphicManager based rendering.
Comment 6 Robinson Tryon (qubit) 2015-12-13 11:09:29 UTC Comment hidden (obsolete)
Comment 7 Xisco Faulí 2016-09-26 15:03:14 UTC
Adding Cc: to Armin Le Grand
Comment 8 Xisco Faulí 2017-09-29 08:48:39 UTC Comment hidden (obsolete)
Comment 9 Yousuf Philips (jay) (retired) 2017-09-30 21:16:06 UTC
Still present though doesnt look as bad as it used to.

Version: 6.0.0.0.alpha0+
Build ID: 13df3777e4b6ff7537692b396be67a5fd2b9b001
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 10 QA Administrators 2019-03-02 03:51:00 UTC Comment hidden (obsolete)
Comment 11 Luke 2019-03-18 15:47:34 UTC
Still reproducible in Version: 6.3.0.0.alpha0+ (x64)
Build ID: ad04121efa8dd513bc0564515b5f305bb1549109
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win;

If I disable OpenGL rendering, the images are properly smoothed out.
Comment 12 Luke 2019-03-22 22:44:23 UTC
After https://cgit.freedesktop.org/libreoffice/core/commit/?id=c4217f888a29,
Windows OpenGL render is now properly smoothing the lines.
Comment 13 Xisco Faulí 2019-03-23 11:36:35 UTC
(In reply to Luke from comment #12)
> After https://cgit.freedesktop.org/libreoffice/core/commit/?id=c4217f888a29,
> Windows OpenGL render is now properly smoothing the lines.

is it resolved fixed then? or dupe of bug 123372 ?
Comment 14 Telesto 2019-03-23 12:37:59 UTC
(In reply to Xisco Faulí from comment #13)
> (In reply to Luke from comment #12)
> > After https://cgit.freedesktop.org/libreoffice/core/commit/?id=c4217f888a29,
> > Windows OpenGL render is now properly smoothing the lines.
> 

-> is it resolved fixed then? 
* Yes, looks fine to me

-> Dupe of bug 123372
* Probably not. I created bug 123372 because it was about OpenGL. This was likely about GDI rendering.. probably already gone before bug 123372 got fixed
Comment 15 Xisco Faulí 2019-03-25 10:07:08 UTC
Hi Telesto,
Thanks for retesting.
Reading https://bugs.documentfoundation.org/show_bug.cgi?id=116109#c2, probably it got fixed by bug 123165
Probably other bugs from https://bugs.documentfoundation.org/show_bug.cgi?id=116109#c2 are fixed as well...
Comment 16 Luboš Luňák 2019-03-25 12:41:49 UTC
The bug description is unclear on what the actual problem was, but if this is about the dining bear on page 5, then that's exactly the image from bug #123372, so at least that part indeed is a duplicate.
Comment 17 Xisco Faulí 2019-04-12 10:20:13 UTC

*** This bug has been marked as a duplicate of bug 123372 ***
Comment 18 Aron Budea 2019-04-12 22:57:17 UTC
Is there a bug report about the missing colors? I don't see any referenced in this ticket.
Comment 19 Aron Budea 2019-04-12 23:08:38 UTC
Oh never mind, the images appear greyscale in Word as well.