Bug Hunting Session
Bug 79360 - Create new styles from sidebar do not work in Impress (not responding)
Summary: Create new styles from sidebar do not work in Impress (not responding)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.3.0.0.beta1
Hardware: All All
: medium critical
Assignee: Caolán McNamara
URL:
Whiteboard: target:4.4.0 target:4.3.0.0.beta2 tar...
Keywords:
: 72614 (view as bug list)
Depends on:
Blocks: mab4.3
  Show dependency treegraph
 
Reported: 2014-05-28 09:38 UTC by Kevin Suo
Modified: 2014-06-14 13:48 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Suo 2014-05-28 09:38:41 UTC
Description:
In Impress, when you start "Styles and Formatting" from sidebar and try to create a new style, the creating new style window is not popping up.

Steps:
1. Start Impress, enable sidebar;
2. Start "Styles and Formatting" by clicking the icon in sidebar;
3. Right click any of the "presentation styles", then "NEW"

Current behaviour:
No new style creation window is shown.

Expected: (I am not sure at this moment, please read more below)

More useful info:
When you start the "Styles and Formatting" window from the toolbar or by F11, there is no option to create "new" for "presentation styles".

More more info:
In 4.2.4.2, Impress crashes at step 3 above.

OS: Windows XP SP3,
Version: 4.3.0.0.beta1
Build ID: b7cfa1eab1cb1e94f71d6df6612b73f231d0bf92
Comment 1 famo 2014-05-28 10:37:41 UTC
@suokunlong:
I've read your comment at bug 77174. But what you describe here is actually "my" issue. Except that LO 4.2.4.2 hangs here instead of crashing.


Also from your description it is not clear, does LO hangs or the dialog is just not popping up, but you can actually continue working?


I tested this on Win7 and Linux, both 64-bit.


Adjusting Platform.
Also I believe a bug should always be filled against the first version found on (which would be 4.2.4 here), but I leave version on 4.3 beta for now.
Comment 2 famo 2014-05-28 10:45:08 UTC
Adding Caolán McNamara to CC.
Comment 3 Kevin Suo 2014-05-28 10:57:14 UTC
(In reply to comment #1)

hi,

LO does not hang, only the dialog is just not popping up. I can continue.

(It is not poppng up may because there is no such option to create such new styles, as it is on the F11 normal style window.
Comment 4 Caolán McNamara 2014-05-28 14:12:31 UTC
SfxApplication::GetCurrentTemplateCommon should find the docked panel styles & formatting window if the floating one is not visible. Easier said than done though
Comment 5 Commit Notification 2014-05-30 10:39:24 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7a211e834fc271d3f28d7f8c49197c925242d862

Resolves: fdo#79360 impress hangs on using sidebar new style



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2014-05-30 11:01:16 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3988f17d14ee28b4bb117ca9961708ad3a867fb1&h=libreoffice-4-3

Resolves: fdo#79360 impress hangs on using sidebar new style


It will be available in LibreOffice 4.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Caolán McNamara 2014-05-30 11:06:00 UTC
I'll backport this for 4-2 as well
Comment 8 famo 2014-05-30 11:30:43 UTC
@ Caolan:
Thanks for the quick fix.

As mentioned in comment 3, there is an inconsistency between the classic and the sidebar stylist. The classic one is missing the "New..." all together. Is this fixed now too, or shall I open a ticket for it?
Comment 9 Caolán McNamara 2014-05-30 12:50:50 UTC
There should be no "new" option on "presentation styles", that's sort of how they are designed. You can't create new ones. Now both are back in sync.
Comment 10 Matúš Kukan 2014-06-03 15:08:25 UTC
*** Bug 72614 has been marked as a duplicate of this bug. ***
Comment 11 Commit Notification 2014-06-10 12:48:44 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f2ba5e290b6b751995427b7610ef75d67e674d75&h=libreoffice-4-2

Resolves: fdo#79360 impress hangs on using sidebar new style


It will be available in LibreOffice 4.2.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.