Bug Hunting Session
Bug 79372 - Hyphenation bug in line break algorithm
Summary: Hyphenation bug in line break algorithm
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.4.2 release
Hardware: All All
: medium normal
Assignee: László Németh
URL:
Whiteboard: target:4.4.0 target:4.3.0.0.beta2 tar...
Keywords: regression
Depends on:
Blocks:
 
Reported: 2014-05-28 14:56 UTC by Karl Zeiler
Modified: 2015-02-24 23:43 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
LO 4.2.4_not hyphenated (24.73 KB, application/pdf)
2014-05-28 14:56 UTC, Karl Zeiler
Details
Example-file (18.67 KB, application/vnd.oasis.opendocument.text)
2014-05-28 15:02 UTC, Karl Zeiler
Details
LO 4.1.6_correctly hyphenated (24.91 KB, application/pdf)
2014-05-28 15:04 UTC, Karl Zeiler
Details
LO 4.2.4_not hyphenated (24.73 KB, application/pdf)
2014-05-28 15:06 UTC, Karl Zeiler
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Karl Zeiler 2014-05-28 14:56:25 UTC
Created attachment 100035 [details]
LO 4.2.4_not hyphenated

Description of the bug
All words marked in yellow in the example-file should be hyphenated automatically after the prefix. This means: vor-, ent-, ver-, er-. All versions of LO 3.3 – 4.1.6 demonstrate this correct behavior.
But in version LO 4.2.4.2 some punctuation marks (like comma, exclamation mark, question mark, semicolon, colon) following the word which should be hyphenated prevent its hyphenation. The same problem also in 4.3-beta1 under Windows 7.

Configuration of the hyphenation module (German LO)
Optionen > Linguistik und Absatzvorlage > Textfluss:
Silbentrennung: automatisch
Minimale Wortlänge für Silbentrennung: 4
Zeichen am Zeilenende: 2
Zeichen am Zeilenanfang: 2
Maximal aufeinander folgende Trennstellen: 0

The above mentioned problem occurs under Windows (tested Windows XP/7) and other operation systems. Compare also the following thread:
http://www.mail-archive.com/discuss@de.libreoffice.org/msg17402.html

How to reproduce this bug?
Open the example-file. If you delete the punctuation marks after the word marked in yellow you can see the word is suddenly hyphenated correctly. The space is great enough for hyphenation.

I think there is a connection between this new bug and another bug fixed in LO 4.2.4:
https://bugs.freedesktop.org/show_bug.cgi?id=56392

Please fix this new bug as soon as possible. In my opinion this bug is annoying because it implies unwanted changes for the layout of complex documents.

Regards
Karl
Comment 1 Karl Zeiler 2014-05-28 15:02:14 UTC
Created attachment 100036 [details]
Example-file
Comment 2 Karl Zeiler 2014-05-28 15:04:44 UTC
Created attachment 100037 [details]
LO 4.1.6_correctly hyphenated
Comment 3 Karl Zeiler 2014-05-28 15:06:39 UTC
Created attachment 100038 [details]
LO 4.2.4_not hyphenated
Comment 4 Dr. Matthias Weisser 2014-05-28 17:13:01 UTC
I can confirm this bug. I sent my text where those problems happen to Karl Zeiler. He had a look on this and built this example. 

I wrote a 740 page book using earlier versions of OO and then LO. Doing the last update the text went longer than before. I found this related to alterated hyphenation. To correct this I manually changed my text on several pages. Doing "soft hyphen" using "Einfügen weiches Trennzeichen" works.

I hope this helps solving this as soon as possible. Its very time consuming having a look at all my texts before using pdf export for my customers. It was ok before. Nothing changed - with except of the new LO version. Still WinXP, still the same laptop. 

Others also seem to be able to confirm. See discuss list "LO 4.2.4.2: Bug mit automatischer Silbentrennung". Robert Grosskopf confirmed, Michael Höhne, Volker Merschmann. I hope this helps.
Comment 5 manj_k 2014-05-28 18:15:08 UTC
Confirmed, marked as NEW.

Added László Németh to CC List.

BTW: You can force auto-hyphenation with WORD JOINER (U+2060) previous to the punctuation marks (see: https://bugs.freedesktop.org/show_bug.cgi?id=56392#c7).
Comment 6 László Németh 2014-05-29 06:47:28 UTC
This problem is caused by the fix for the Bug 56392. It will be fixed soon.
Comment 7 Commit Notification 2014-05-29 07:17:21 UTC
Laszlo Nemeth committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=259d3421d4cf7788d9099daa40fc181c661783ee

fdo#79372 fix hyphenation (remove fdo#56392 fix, except hard hyphen part)



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 László Németh 2014-05-29 07:24:54 UTC
Fixed in the master, and it will be fixed in the next bug fix release of LO 4.2, too. Many thanks for the detailed bug report!
Comment 9 Commit Notification 2014-05-29 07:42:48 UTC
Laszlo Nemeth committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=24e78bd5835ecbf2d3076fcdb97943dc0ba4998c&h=libreoffice-4-3

fdo#79372 fix hyphenation (remove fdo#56392 fix, except hard hyphen part)


It will be available in LibreOffice 4.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Karl Zeiler 2014-05-29 09:18:09 UTC
Special thanks to Manfred J. Krause und Laszlo Nemeth for the super-fast bugfixing.
Comment 11 Commit Notification 2014-05-29 10:08:16 UTC
Laszlo Nemeth committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ba076a9eeddf7e1b61faa6094fdd91e8a9b9bc1f&h=libreoffice-4-2

fdo#79372 fix hyphenation (remove fdo#56392 fix, except hard hyphen part)


It will be available in LibreOffice 4.2.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2014-05-30 13:21:37 UTC
Laszlo Nemeth committed a patch related to this issue.
It has been pushed to "libreoffice-4-2-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=577582d382a9b66b8f59ecb8cb6b070805a695e9&h=libreoffice-4-2-5

fdo#79372 fix hyphenation (remove fdo#56392 fix, except hard hyphen part)


It will be available already in LibreOffice 4.2.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2014-06-30 22:25:44 UTC
Laszlo Nemeth committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c78d948b6113e3c3b38d8a0b5206155c4c3a13e4

Revert "fdo#79372 fix hyphenation (remove fdo#56392 fix, except hard hyphen part)"



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2014-06-30 22:25:58 UTC
Laszlo Nemeth committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=712d60f03d4c7dfa1ec56e49f40036ab7eb25fde

fdo#79372, fdo#56392 fix hyphenation



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2014-07-01 15:34:13 UTC
Laszlo Nemeth committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5955e7d66d9b0e87f93fd9746a85bff132da9794&h=libreoffice-4-3

Revert "fdo#79372 fix hyphenation (remove fdo#56392 fix..."


It will be available in LibreOffice 4.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2014-07-01 15:35:55 UTC
Laszlo Nemeth committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=891652082c4d09cc069f1902ba19e4bd96e8c384&h=libreoffice-4-3

fdo#79372, fdo#56392 fix hyphenation


It will be available in LibreOffice 4.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.