Bug Hunting Session
Bug 79381 - Color of non-printable characters is hard-coded to a single value, should select dynamically from the DE with option to fix
Summary: Color of non-printable characters is hard-coded to a single value, should sel...
Status: RESOLVED DUPLICATE of bug 80054
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.3.0.0.beta1
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevEval
Depends on:
Blocks:
 
Reported: 2014-05-28 17:56 UTC by Stefan Knorr (astron)
Modified: 2017-02-24 15:20 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Knorr (astron) 2014-05-28 17:56:25 UTC
After a change during the 4.3 development cycle, non-printable characters are now displayed in a light blue (see bug 68071). This is a bit unfortunate for several reasons:

+ lacks desktop integration (e.g. Ubuntu usually uses orange or purple as
  accent colors, several other Linux desktops are rather grayish, not sure
  whether anyone even thought about high-contrast themes)

+ colour is hard to see for many people


Ideas:

+ Normal case: use desktop selection color with ~50-75% opacity (if the
  desktop already uses a half-transparent selection color, use that colour)

+ High-contrast user: use the default desktop selection colour, unless it is
  white/black, in which case use a dark blue.

+ For the people that find the default hard to see: offer a check box
  on the accessibility page that allows them to enable a mode where the
  selection colour is used at 100 percent opacity.

:/
Comment 1 Joel Madero 2014-05-28 18:18:12 UTC
You want a bibisect of this?
Comment 2 tommy27 2014-05-28 18:28:03 UTC
if I remember correctly the developer who coded that is Tomaz.
I added him to CC list.
Comment 3 Stefan Knorr (astron) 2014-05-28 18:33:23 UTC
@Joel, comment 1: no need for a bibisect. This was intended & came with http://cgit.freedesktop.org/libreoffice/core/commit/?id=fb99a6b9958815eb1ad27179d252a379ce8b79fd

@Tommy: correct.
Comment 4 Cor Nouws 2014-05-28 18:48:37 UTC
I think this qualifies perfectly for an easyhack

Another possibility is to add the color to Tools > Options > Writer > Appearance.
Comment 5 Pedro 2014-06-02 21:47:59 UTC Comment hidden (no-value)
Comment 6 V Stuart Foote 2014-06-15 17:59:09 UTC
This is clearly an enhancement request--setting it so. 

IMHO I find Mirek's suggested #6abed3 as implemented by Tomaž V. for resolving bug 68071 to be exactly the correction needed to make the NPC distinguishable against paragraph text on a white or black (hi-contrast) document background.  

Anything beyond that seems to be rather low priority polishing requiring non-trivial GUI work--both this idea for automated NPC coloring based on configuration, and Pedro's new bug 80054 to directly control it.

Seems there are other more substantive GUI issues that deserve development cycles, to the extent that I would even suggest that this and 80054 enhancements be set LOW or LOWEST priority.
Comment 7 Robinson Tryon (qubit) 2014-07-16 23:24:59 UTC
Removing comma from the whiteboard.
Changing CamelCase -> wimpyCaps.
Comment 8 Cor Nouws 2014-11-26 17:56:37 UTC
No idea what the importance should be low, in stead of medium..
Comment 9 Robinson Tryon (qubit) 2015-12-10 07:20:10 UTC Comment hidden (obsolete)
Comment 10 V Stuart Foote 2017-02-24 15:20:22 UTC

*** This bug has been marked as a duplicate of bug 80054 ***