Bug 79480 - VIEWING: Deleting rows from this sheet will result in Page breaks to be displayed
Summary: VIEWING: Deleting rows from this sheet will result in Page breaks to be displ...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.6.2 release
Hardware: Other All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Calc-Page-Break Cell-Add-Delete
  Show dependency treegraph
 
Reported: 2014-05-31 12:23 UTC by lore
Modified: 2022-02-23 07:35 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Test file (7.87 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-05-31 12:23 UTC, lore
Details

Note You need to log in before you can comment on or make changes to this bug.
Description lore 2014-05-31 12:23:28 UTC
Created attachment 100198 [details]
Test file

Dear all,
I have a big file for which every time I delete a row or a column I get the page breaks to appear. They eventually disappear if the file is closed and then reopened and appear back when I row/column is deleted. I'm attaching an empty sheet of that big file. With a new empty document that does not happen so I guess something is triggering this behavior here but I haven't been able to find what that is…

I remember that happening also with older versions…
  
Steps to reproduce:
1. Open the file attached
2. Select a row
3. Delete the row

Current behavior:
Page breaks are shown

Expected behavior:
Page breaks should be kept hidden 

              
Operating System: Mac OS X
Version: 4.2.4.2 release
Comment 1 ign_christian 2014-06-10 04:19:24 UTC
confirm with 4.0.6.2 - Win7 x86
Comment 2 QA Administrators 2015-07-18 17:43:06 UTC Comment hidden (obsolete)
Comment 3 Buovjaga 2015-10-17 12:59:06 UTC
Repro.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 186f32f63434e16ff5776251657f902d5808ed3d
TinderBox: Win-x86@39, Branch:master, Time: 2015-10-16_09:42:47
Locale: en-US (fi_FI)
Comment 4 QA Administrators 2016-11-08 11:21:41 UTC Comment hidden (obsolete)
Comment 5 QA Administrators 2020-02-23 02:47:58 UTC Comment hidden (obsolete)
Comment 6 QA Administrators 2022-02-23 03:44:16 UTC Comment hidden (obsolete)
Comment 7 lore 2022-02-23 07:25:23 UTC
Seems to be ok with 7.3.0.3
Comment 8 Buovjaga 2022-02-23 07:35:16 UTC
Yep

Arch Linux 64-bit
Version: 7.3.0.3 / LibreOffice Community
Build ID: 30(Build:3)
CPU threads: 8; OS: Linux 5.16; UI render: default; VCL: kf5 (cairo+xcb)
Locale: fi-FI (fi_FI.UTF-8); UI: en-US
7.3.0-4
Calc: threaded