Download it now!
Bug 79489 - Expert Configuration - default window frame of configuration table is too large, unable to resize
Summary: Expert Configuration - default window frame of configuration table is too lar...
Status: RESOLVED DUPLICATE of bug 73806
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-31 18:20 UTC by V Stuart Foote
Modified: 2014-07-03 12:26 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
working correctly on win7 64-bit version 4.2.4.2 (124.05 KB, image/png)
2014-06-01 21:07 UTC, Efe Gürkan YALAMAN
Details

Note You need to log in before you can comment on or make changes to this bug.
Description V Stuart Foote 2014-05-31 18:20:42 UTC
On Windows 7 sp1, 64-bit with
Version: 4.4.0.0.alpha0+
Build ID: 55070972b32e719e4855855797263d6342a3625f
TinderBox: Win-x86@39, Branch:master, Time: 2014-05-31_01:18:26

When the Tools -> Options -> Advanced: Expert Configuration button is run, the resulting table expands beyond size of primary monitor.

Unable to resize it from the window's frame, or using OS GUI. The table does have horizontal and vertical scroll bars, but they can not be reached without resize of the frame.

Also, can not reach the action buttons at the bottom of the frame: Edit|Reset|OK|Cancel|Help -- so have to use the Window frame X button to close without any configuration actions.
Comment 1 V Stuart Foote 2014-05-31 19:51:54 UTC
Looking at this on Fedora 20 with
Version: 4.2.4.2
Build ID: 63150712c6d317d27ce2db16eb94c2f3d7b699f8

The window holding the Expert Configuration table is reasonably sized on launch, with scroll bars and buttons accessible.  So believe this is Windows specific.

Still need to check with a more recent Linux build. But, I'm having RPM packaging issues with current TB46 4.4.0 and TDF 4.3.0 beta1 build of master has RPM packaging issues.
Comment 2 V Stuart Foote 2014-06-01 16:05:14 UTC
Stumbling around in the code. Is there some reason that the CuiAboutConfigTabPage would not honor the (1024,800) size on Windows OS builds? 

ref:  http://opengrok.libreoffice.org/xref/core/cui/source/options/optaboutconfig.cxx#127

An issue in its UI--optadvancedpage.ui--description?

The size seems to be honored under Linux.
Comment 3 Efe Gürkan YALAMAN 2014-06-01 21:07:05 UTC
Created attachment 100253 [details]
working correctly on win7 64-bit version 4.2.4.2

Looking this on Windows 7 64-bit
Version: 4.2.4.2
Build ID: 63150712c6d317d27ce2db16eb94c2f3d7b699f8

It seems OK with this version. Downloading test builds for checking if i can confirm this.
Comment 4 V Stuart Foote 2014-06-02 00:53:14 UTC
Efe, *,

I am also on Windows 7 sp1, 64-bit with
Version: 4.2.4.2
Build ID: 63150712c6d317d27ce2db16eb94c2f3d7b699f8

Working dual headed, with an NVIDIA GeForce GTX 260 (GT200 GPU) and 1792MB of GDDR3 video RAM. Primary monitor is 1920x1080 with work resolution of 1920x1052;
Secondary monitor is 1080x 1920.

LO running at about 800x600, but it makes no difference maximizing LO to full screen, or moving it to secondary monitor--the Expert Configuration comes up on primary monitor but oversize by about 200 x 200 pixels.

Checked again with a 4.2.4.2 (Build ID: 63150712c6d317d27ce2db16eb94c2f3d7b699f8) on a Fedora 20, 64-bit Linux VM (sized 1280x768) the Expert Configuration dialog is useable, sized at 1165x601--so guess maybe the 1024x800 size really is not in play for the dialog.

Ideas as to why the frame would be so oversize for Windows, but fit fine in Linux? Will check tomorrow what happens with OS X on a 1920 x 1200 monitor.
Comment 5 V Stuart Foote 2014-07-03 12:26:24 UTC

*** This bug has been marked as a duplicate of bug 73806 ***