Bug Hunting Session
Bug 79493 - UI: Refresh Tables option fails with Firebird
Summary: UI: Refresh Tables option fails with Firebird
Status: RESOLVED DUPLICATE of bug 72827
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: Other All
: medium normal
Assignee: Julien Nabet
URL:
Whiteboard: BSA target:4.4.0 target:4.3.0.0.beta2...
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-31 22:18 UTC by Julien Nabet
Modified: 2014-06-03 01:43 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
bt with symbols when clicking "Refresh tables" with embedded HSQLDB (6.32 KB, text/plain)
2014-05-31 22:33 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Julien Nabet 2014-05-31 22:18:23 UTC
Problem description: 
Refresh Tables option makes LO display no tables at all on UI.

Prerequisites: 
Experimental features must be enabled (Tools/Options, Advanced part, click "Enable experimental features" and restart LO if this wasn't checked)

Steps to reproduce:
1. Download odb file at https://bugs.freedesktop.org/attachment.cgi?id=92726
2. Launch LO Base
3. Open odb file
3. Click Tables on left pane and see there's "Exchange" Table
4. Select View/Refresh Tables

Current behavior:
"Exchange" table no longer appears

Expected behavior:
"Exchange" table should still appear

              
Operating System: All
Version: 4.2.0.4 release
Comment 1 Commit Notification 2014-05-31 22:25:50 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d7dd4bbf0a54cc780002052a370f835572035f51

Resolves: fdo#79493 Refresh Tables option fails with Firebird



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 2 Julien Nabet 2014-05-31 22:33:15 UTC
Created attachment 100222 [details]
bt with symbols when clicking "Refresh tables" with embedded HSQLDB

Here's the bt I used to understand why "refreshTables" method wasn't called with Firebird compared to HSQLDB.
Comment 3 Julien Nabet 2014-06-01 07:17:21 UTC

*** This bug has been marked as a duplicate of bug 72827 ***
Comment 4 Commit Notification 2014-06-03 01:38:56 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ee38fa4ff5234b6b2342b330b39f5f456ee4a68c&h=libreoffice-4-3

Resolves: fdo#79493 Refresh Tables option fails with Firebird


It will be available in LibreOffice 4.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2014-06-03 01:43:37 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f03c2bb813d87bc3c89af78f7f01c587db4c59de&h=libreoffice-4-2

Resolves: fdo#79493 Refresh Tables option fails with Firebird


It will be available in LibreOffice 4.2.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.