Bug 79593 - PDF: hyperlinks lost in PDF when hiding slide
Summary: PDF: hyperlinks lost in PDF when hiding slide
Status: RESOLVED DUPLICATE of bug 61274
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.0.6.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 78984 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-06-03 14:45 UTC by bozo629
Modified: 2015-02-23 07:25 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
test document (10.00 KB, application/vnd.oasis.opendocument.presentation)
2014-06-12 10:40 UTC, bozo629
Details
PDF from test document (15.03 KB, application/pdf)
2014-06-12 10:41 UTC, bozo629
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bozo629 2014-06-03 14:45:15 UTC
Problem description: 

Steps to reproduce:
1. create a presentation with several slides
2. put a hyperlink on the second slide
3. hide the first slide
4. export to PDF

Current behavior:
hyperlink in PDF does not work

Expected behavior:
hyperlink should work in PDF

Deleting the first slide instead of hiding it makes the hyperlink work in the PDF.
              
Operating System: Ubuntu
Version: 4.1.3.2 release
Comment 1 bozo629 2014-06-04 11:07:12 UTC
bug also present in LibreOffice version 4.2.3.3 (Build ID 420m0(Build:3))
Comment 2 Jean-Baptiste Faure 2014-06-09 19:28:51 UTC
What kind of hyperlink do you mean? What is the target of the hyperlink? Internal or toward an external file?

Please, could you attach a test-file (odp file) showing the problem?

Set status to NEEDINFO. Please set it back to UNCONFIRMED when you will have provided the requested informations.

Best regard. JBF
Comment 3 bozo629 2014-06-12 10:40:36 UTC
Created attachment 100912 [details]
test document
Comment 4 bozo629 2014-06-12 10:41:20 UTC
Created attachment 100913 [details]
PDF from test document
Comment 5 bozo629 2014-06-12 10:43:41 UTC
I attached a test document (created with 4.2.3.3). The hyperlink is a "web hyperlink." Also attached is the PDF created from the test document (with the first slide hidden) and the link doesn't work.
Comment 6 Jean-Baptiste Faure 2014-06-12 17:29:44 UTC
Reproducible for me (Ubuntu 14.04 x86-64) since at least LO 4.0.6.
Works in the following cases:
1/ if you choose to export hidden slides.
2/ if you move the hidden slide after the slide containing the hyperlink

Best regards. JBF
Comment 7 tommy27 2014-06-13 09:28:57 UTC
*** Bug 78984 has been marked as a duplicate of this bug. ***
Comment 8 tommy27 2014-06-13 09:31:53 UTC
please take a look at Bug 61274 which seems related to this issue.
are those duplicates or not?
Comment 9 Zabelle 2014-06-13 10:24:33 UTC
yes it is.

Apologies

Zabelle
Le 13/06/2014 11:31, bugzilla-daemon@freedesktop.org a écrit :
>
> *Comment # 8 <https://bugs.freedesktop.org/show_bug.cgi?id=79593#c8> 
> on bug 79593 <https://bugs.freedesktop.org/show_bug.cgi?id=79593> from 
> tommy27 <mailto:barta@quipo.it> *
> please take a look atBug 61274  <show_bug.cgi?id=61274>  which seems related to this issue.
> are those duplicates or not?
> ------------------------------------------------------------------------
> You are receiving this mail because:
>
>   * You are on the CC list for the bug.
>
Comment 10 Jean-Baptiste Faure 2014-06-13 10:53:03 UTC
duplicate of bug 61274

Best regards. JBF

*** This bug has been marked as a duplicate of bug 61274 ***
Comment 11 tommy27 2014-06-13 11:42:59 UTC
(In reply to comment #9)
> yes it is.
> 
> Apologies
> 
> Zabelle
> Le 13/06/2014 11:31, bugzilla-daemon@freedesktop.org a écrit :


please tell us the O/S where you reproduce the bug.
is it Linux or Windows or Mac?
Comment 12 Zabelle 2014-06-14 20:13:02 UTC
Linux Ubuntu 12.04 LST

Le 13/06/14 13:42, bugzilla-daemon@freedesktop.org a écrit :
>
> *Comment # 11 <https://bugs.freedesktop.org/show_bug.cgi?id=79593#c11> 
> on bug 79593 <https://bugs.freedesktop.org/show_bug.cgi?id=79593> from 
> tommy27 <mailto:barta@quipo.it> *
> (In reply tocomment #9  <show_bug.cgi?id=79593#c9>)
> > yes it is.
> >
> > Apologies
> >
> > Zabelle
> > Le 13/06/2014 11:31,bugzilla-daemon@freedesktop.org  <mailto:bugzilla-daemon@freedesktop.org>  a écrit :
>
>
> please tell us the O/S where you reproduce the bug.
> is it Linux or Windows or Mac?
> ------------------------------------------------------------------------
> You are receiving this mail because:
>
>   * You are on the CC list for the bug.
>