Bug Hunting Session
Bug 79641 (mab4.4) - LibreOffice 4.4 most annoying bugs
Summary: LibreOffice 4.4 most annoying bugs
Status: CLOSED MOVED
Alias: mab4.4
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: All All
: highest critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on: 60910 72007 76825 79301 80448 80955 81058 81147 81496 81517 81756 82661 82777 83174 83379 83633 83798 84617 84854 85076 85806 86159 86552 86572 86578 86624 86636 86984 87119 87373 87663 87845 87872 87876 88056 88111 88194 88295 88398 88786 88792 88935 88941 89039 89245 89780 90010 90155 90757 90809 91242 91293
Blocks:
  Show dependency treegraph
 
Reported: 2014-06-04 15:53 UTC by tommy27
Modified: 2019-06-05 10:16 UTC (History)
21 users (show)

See Also:
Crash report or crash signature:


Attachments
Outline numbering gets restarted every time doc is opened (4.89 KB, application/oowriter)
2015-06-28 11:45 UTC, meneerjansen00
Details
Two documets made w/ LO in OOXML format and re-saved as... (34.61 KB, application/x-rar)
2015-06-28 20:22 UTC, meneerjansen00
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tommy27 2014-06-04 15:53:45 UTC
This is a meta issue to track the most annoying bugs in LibreOffice 4.4.x releases. It helps developers to focus on bugs that are most critical for users. Also it helps users to be aware of potential problems.

If anyone wants to raise a bug as “most annoying” for the release, please add the ID of that bug to the field “Depends on”, leave a short description of the bug, and explain in few words why that bug should get privileged, for example:

Add bug #XXXXX: Writer ignores page size setting. The default size is Letter. The document format is often broken when printing on A4 paper in Europe.

For details, criteria and further instructions, please see
  http://wiki.documentfoundation.org/Most_Annoying_Bugs
Comment 1 tommy27 2014-06-07 04:24:48 UTC
adding Bug 79301 - crash in extension manager deleting an extension after upgrading it
Comment 2 tommy27 2014-07-12 05:30:29 UTC
I add Bug 79761 - autocorrect slow-down got worse

working with large autocorrect lists in 4.4 master causes long freezes while you type.
Comment 3 tommy27 2014-07-19 06:28:46 UTC
I add Bug 81517 - FILEOPEN: pictures in .xls spreadsheets no longer displayed
very evident regression. may affect lot of users and files.
Comment 4 Jorendc 2014-07-30 21:19:12 UTC
Hereby I nominate "Bug 81756 - Crasher in Format:Page... menu item". Mac OSX only so far.
Comment 5 Eike Rathke 2014-08-22 12:09:55 UTC
Adding bug 81496 "Crash in Format Page"
Comment 6 jmg74 2014-08-23 14:54:52 UTC
Should add Bug 54342 : seems not to be frequent, but it is awfull when one lose many formulaes in a text without any solution !
Comment 7 tommy27 2014-08-23 15:44:05 UTC
@jmg74
this list is reserved to bugs that are specific to the 4.4.x branch
the bug you added is already present in older branches so it does not belong to this list and I'll remove it.

if you think that it qualifies as a MAB you should file it to the proper list which is currently mab4.2 (see the link under See Also)
Comment 8 Joel Madero 2014-09-02 16:57:51 UTC
Added bug 83379 - regression
Data corruption with relatively simple draw objects
Comment 9 Joel Madero 2014-09-04 13:11:59 UTC
Added bug 83174 - regression + crasher
Something is going on with the interaction with sections and the table of contents where if an entry in the TOC is removed and then you try to export as PDF you get a crash. Native ODF file
Comment 10 Terrence Enger 2014-09-09 20:39:00 UTC
Adding bug 83633 "FILESAVE: Crash when save in ODF 1.0/1.1".  It is aa
crash and a regression (introduced around 2014-07-02).
Comment 11 tommy27 2014-10-05 07:30:00 UTC
added Bug 84678 - FILEOPEN: .DOCX textbox margins incorrectly set in 4.4.x

interoperability regression in 4.4.x (works fine in 4.3.2.2)
Comment 12 Joel Madero 2014-10-10 17:31:06 UTC
Added bug 84854 - critical regression.

Spreadsheet is not drawing correctly when it loads - resulting in massive black areas on the sheet and inability to use it at all. So far only confirmed with:
TinderBox: Win-x86@42.

Does not affect: TinderBox: Win-x86@39
Comment 13 tommy27 2014-10-16 01:45:28 UTC
I add Bug 85076 - F11 "Styles and Formatting" not working when sidebar hidden

probably a side effect of sidebar incorporation of that floating panel in 4.4.x
see: https://wiki.documentfoundation.org/ReleaseNotes/4.4#Sidebar_changes
Comment 14 Cor Nouws 2014-11-04 19:07:29 UTC
adding Bug 83798 - Chapter numbers (Outline numbering) not included in Table of Contents (TOC)
Comment 15 Robinson Tryon (qubit) 2014-11-23 12:17:50 UTC
Adding Bug 86552 - Segmentation fault when I press Ctrl-Z

Regression introduced between 4.4.0.0 alpha2 -> beta1 that causes a crash in Draw, Writer, and probably other components if you try to undo changes w/Ctrl-Z when editing macros.
Comment 16 vlb 2014-11-25 17:59:05 UTC
Add bug 86572: Critical regression automatic recalculation formulas and graphics
Comment 17 V Stuart Foote 2014-11-26 06:26:52 UTC
Nominating bug 86578 for loss of formatting style--area fill and transparency--of coincident image frames and text frames occurring when an .ODT document is saved and reopened. Causes image in an image frame visible during a Writer edit session to become invisible on reopen.
Comment 18 Shunesburg69 2014-11-28 21:00:22 UTC
This bug is present in 4.2, 4.3 and 4.4 versions ( https://www.libreoffice.org/bugzilla/show_bug.cgi?id=79641 )
Comment 19 V Stuart Foote 2014-11-28 22:47:53 UTC
@shunesburg69, *,
(In reply to shunesburg69 from comment #18)
> This bug is present in 4.2, 4.3 and 4.4 versions (
> https://www.libreoffice.org/bugzilla/show_bug.cgi?id=79641 )

Assume you are referring to bug 81876 -- FORMATTING: Fontwork-formatted text is duplicated. That has been added to mab4.3 (bug 75025). Won't be listed in both mab lists.
Comment 20 Joel Madero 2014-12-01 17:33:17 UTC
Added bug 86904 - crasher regression in calc.
Insert -> Diagram results in crash.
Comment 21 Joel Madero 2014-12-02 02:22:51 UTC
Added bug 85806 - regression
Looks like Hebrew language is completely broken on master - might affect other RTL languages as well.
Comment 22 tommy27 2014-12-07 12:25:20 UTC
I add Bug 86678 - TOOLBAR: Underlined letters in new drop downs not working

affects new 4.4.x toolbar drop downs like the new color picker, line spacing, and insert table
Comment 23 Joel Madero 2014-12-09 04:53:40 UTC
Added bug 87119. Bibisected + Regression + Apparent Data Loss

Complex sheet shows empty with 4.4 but shows appropriate data in 4.3. Bibisected
Comment 24 Cor Nouws 2014-12-21 11:37:31 UTC
adding Bug 86984 - UI:Line Numbering. Include header or footer not preserved and has no effect on counting
Comment 25 Joel Madero 2014-12-30 19:02:53 UTC
Added bug 87872 - regression

Inability to save basic .doc as odt, worked fine in 4.3, broken on 4.4.
Comment 26 Cor Nouws 2015-01-05 16:37:27 UTC
Adding Bug 88056 - [FILE OPEN/SAVE] field Insert ▸ Field ▸ Page Title not saved / reloaded
Comment 27 Cor Nouws 2015-01-05 20:19:17 UTC
Adding Bug 87663 - CRASH when attempting to add ToC to document
Comment 28 Laurent BP 2015-01-06 16:45:50 UTC
Promote bug 88111
Math object cannot be seen during slide show
Comment 29 Joel Madero 2015-01-08 17:21:36 UTC
Added bug 88194 - regression + crash

Pasting a cell that has a comment into a lot of other cells causes a hard freeze. Works fine in 4.3.5, broken in 4.4 beta 2 (and master).
Comment 30 Joel Madero 2015-01-09 18:05:46 UTC
Added bug 86636

Some users are experiencing completely black menus in 4.4
Comment 31 tommy27 2015-01-11 18:28:47 UTC
adding Bug 88295 - FILEOPEN: White Background Appears in Impress Text Boxes

very nasty Impress regression IMHO.
Comment 32 Cor Nouws 2015-01-12 09:20:36 UTC
adding Bug 88276 - Please add UI for new LO 4.4. feature "Text Background Color in Draw"
(for now, I think best is to change the feature info on the wiki..)
Comment 33 Eike Rathke 2015-01-15 10:56:38 UTC
grouped formulas lose listeners when split, recalculation broken
Comment 34 Philipp Weissenbacher 2015-01-15 13:00:08 UTC
Add bug #76825: The style drop-down in Writer is too narrow, causing the edit style button to overlap the style text. This has been introduced in 4.0.
Comment 35 Adolfo Jayme 2015-01-17 14:12:38 UTC
Adding bug 86159: “TOOLBAR: drop downs not having sufficient space on the right and bottom”. It looks horrible under Windows!
Comment 36 m.a.riosv 2015-01-25 13:13:26 UTC
Added https://bugs.documentfoundation.org/show_bug.cgi?id=88786

Sign result with a rest between a number and an array is changed.
Comment 37 Eike Rathke 2015-01-29 23:51:29 UTC
Adding bug 88792 Calc crashes when applying subtotals
Comment 38 Adolfo Jayme 2015-01-30 01:08:55 UTC
Adding bug 87876: the View page in Settings is crushed because of an overly long checkbox label related to OpenGL, which doesn’t wrap in multiple lines.
Comment 39 m.a.riosv 2015-02-01 22:30:38 UTC
Added https://bugs.documentfoundation.org/show_bug.cgi?id=89012

LibreOffice hangs "Create Report in Design View" in base.
Comment 40 Julehti 2015-02-02 14:30:27 UTC
When opening on Mac OS X the Finnish version of LibreOffice 4.4., in it's eneral section of Preferences the fourth part "User Interface" and "Graphic Output" collapse partially. In English version these are OK.
Comment 41 V Stuart Foote 2015-02-02 14:47:35 UTC
(In reply to Julehti from comment #40)
> When opening on Mac OS X the Finnish version of LibreOffice 4.4., in it's
> eneral section of Preferences the fourth part "User Interface" and "Graphic
> Output" collapse partially. In English version these are OK.

That is bug 87876 already on this MAB listing.
Comment 42 V Stuart Foote 2015-02-02 14:58:59 UTC
Added bug 88935 - linked images read error, flickering, freeze

Evident to some degree in all OS, various hardware.
Comment 43 Laurent BP 2015-02-06 20:43:56 UTC
Promote bug 86624
Position of legend is lost in chart if it is manually placed
Comment 44 Cor Nouws 2015-02-10 10:37:45 UTC
adding (reopened) Bug 60910 FILESAVE loses Fontwork/shape objects
Comment 45 Jean-Baptiste Faure 2015-02-11 08:24:25 UTC
I nominate bug 82661 because this regression makes paragraphs with background looking very ugly.

Best regards. JBF
Comment 46 jun meguro 2015-02-22 17:58:19 UTC
Added bug 63230
"Calc: Date decreased by 1 depending on Timezone"

Same bug  recurrence in 4.4.0.
And this bug has been fixed in the master.
Please adopt this fix in the next release.
Comment 47 Ben DeCamp 2015-02-22 23:59:51 UTC
Added bug #83159: Textboxes in charts are not preserving their font size when file is reopened after inital creation. This issue can be worked around by changing the font size and then restoring it back to 12, But very annoying having to do this each time I make a chart for my physics lab reports.
Comment 48 V Stuart Foote 2015-02-26 14:12:52 UTC
Nominated  bug 72007 -- Sidebar: incorrect conflicting widget attachment causing graphic artifacts when the sidebar is docked on the left.

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8965bfda9753568a038303d9935f7a451282a857 seems somehow incomplete.
Comment 49 Cor Nouws 2015-03-07 10:18:16 UTC
adding Bug 89780 - Any text placed on a slide is NOT shown when starting the slideshow from that slide
Embarrassing problem for people running presentations on Windows
Comment 50 Joel Madero 2015-03-18 14:10:33 UTC
Added bug 90010 - regression + bisected

Images embedded in password protected document are lost on save
Comment 51 Jean-Baptiste Faure 2015-03-24 13:24:03 UTC
I nominate bug 88941 which breaks PDF export on MacOS-X.

Best regards. JBF
Comment 52 Matthew Francis 2015-04-04 15:13:09 UTC
Adding bug 89245 - FORMATTING, FILESAVE: Header and footer background images are not saved

There have been multiple duplicates of this, so clearly it's causing some pain
Comment 53 sunweb 2015-04-19 08:22:29 UTC
Adding https://bugs.documentfoundation.org/show_bug.cgi?id=37223 Target for paste cells from column in Calc into TABLE will be single cell instead of column
As its a usual operation that people shouldn't put much thought into and works in MSO (https://youtu.be/4zMfuzoWLv8?t=108).

Note that MSO also has more user friendly options to paste from Excel to Word that enables on right click and gives features like this extension does http://extensions.services.openoffice.org/en/project/pasteasvalue (thankfully an extension works so far even though it can be slow and its been out ages ago) only in more appealing way with preview of what will happen once you choose a paste method. But those are additions currently a bug fix that will enable an easy way to paste from Calc to Writer's table will do way more that those UI changes you're making.
Comment 54 Iandol 2015-04-22 17:40:09 UTC
Add BUG #87373: This bug causes significant readability issues due to broken kerning depending on window size introduced in 4.4 for OS X users.
Comment 55 Joel Madero 2015-04-29 15:44:57 UTC
Apparently our window management of color dialogs doesn't play nice with Elementary OS - already a few dupes marked.

Developer from i3 posted some findings that seem on point in comment 3
Comment 56 Joel Madero 2015-04-29 19:52:06 UTC
Added bug 90809 - crasher with simple Thai document. Regression, gtbtrace log attached and bibisected.
Comment 57 Joel Madero 2015-04-29 19:54:20 UTC
Added bug 90808 - crasher, regression, simple highlight/copy causes crash. Bisected
Comment 58 Joel Madero 2015-04-29 19:54:42 UTC
Added bug 90757 - crasher on sort. Regression in 4.4. Bisected
Comment 59 meneerjansen00 2015-05-12 17:53:53 UTC
Outline numbering bug in Word docs after re-opening the doc: bug #76817

This bug is very, very, very, very, very, very, very, annoying because chapter numbering is one of the most used features of a Word Processor. And the .doc(x) format is one of the most used in the world. Basically you can NOT use LibO to edit a Word doc in which the chapters are automatically numbered, which is EVERY document ever produced by mankind. Please fix asap if you can.
Comment 60 Cor Nouws 2015-05-12 18:57:18 UTC
(In reply to meneerjansen00 from comment #59)
> Basically you can
> NOT use LibO to edit a Word doc in which the chapters are automatically
> numbered, 

Did you do some good tests, before writing that? I cannot confirm the problem as a general issue. (Would have been unlikely, that such an issue would have gone unnoticed for years.)
Comment 61 V Stuart Foote 2015-05-12 19:22:19 UTC
(In reply to meneerjansen00 from comment #59)
removed bug 76817 from mab4.4 -- assigned to bug 88137
Comment 62 Cor Nouws 2015-05-12 19:23:07 UTC
Adding Bug 91242 - Saving as .docx adds the outline number, which is not applied, before the header after reopening
Comment 63 V Stuart Foote 2015-05-12 19:31:20 UTC
(In reply to V Stuart Foote from comment #61)
> (In reply to meneerjansen00 from comment #59)
> removed bug 76817 from mab4.4 -- assigned to bug 88137

s/ bug 88137/ bug 88173/
Comment 64 Joel Madero 2015-05-14 20:24:41 UTC
Added bug 91293 - regression + bibisected

Saving a presentation file as pptx strips all hyperlinks from the presentation. It's been around for awhile but seems pretty nasty.
Comment 65 Travis 2015-05-16 01:01:41 UTC
Bug #57989: formulas in Writer do not update when adding/deleting last row

See comment 12 for succinct description.
Comment 66 Cor Nouws 2015-05-19 08:54:23 UTC
adding Bug 86675 - Bad-quality antialiasing for PNG images, looks terribly ugly ..
Comment 67 meneerjansen00 2015-06-28 11:45:18 UTC
Created attachment 116892 [details]
Outline numbering gets restarted every time doc is opened

Outline numbering gets restarted every time doc is opened
Comment 68 meneerjansen00 2015-06-28 11:49:05 UTC
(In reply to Cor Nouws from comment #60)
> (In reply to meneerjansen00 from comment #59)
> > Basically you can
> > NOT use LibO to edit a Word doc in which the chapters are automatically
> > numbered, 
> 
> Did you do some good tests, before writing that? I cannot confirm the
> problem as a general issue. (Would have been unlikely, that such an issue
> would have gone unnoticed for years.)
Yes this is a general issue. 

See bug 50774 (https://bugs.documentfoundation.org/show_bug.cgi?id=50774). That bug report was opened 2012-06-06. In comment number 8 there the user named Rainer Bielefeld Retired says: "Same effect with AOOo 3.4.1, so seems inherited from OOo.". He also said: "If this is a general problem that is very serious [...]".

Reproduce this bug by making a fresh Writer document. Apply outline numbering to Heading 1. Save as .doc or .docx, exit. Reopen. Apply Heading 1 to some text in the middle of doc. Added chapter gets no outline number. After reapplying outline numbering to 'Heading 1' numbering is wrong (i.e. the headings formatted in this "session" get numbers starting from 1). See uploaded example doc.
Comment 69 meneerjansen00 2015-06-28 12:04:28 UTC
Comment on attachment 116892 [details]
Outline numbering gets restarted every time doc is opened

Attached file contains a doc w/ outline numbering applied to Heading 1. Every time the doc is reopened (which I call a "session") and style 'Heading 1' is applied to some text in the middle of the doc, then that heading gets no number. If one reapplies outline numbering to 'Heading 1' then the outline numbering of the text to which 'Heading 1' was applied in this session restarts at 1.
Comment 70 V Stuart Foote 2015-06-28 14:07:07 UTC
(In reply to meneerjansen00 from comment #69)
> Comment on attachment 116892 [details]
> Outline numbering gets restarted every time doc is opened

bug 76817 -- "Outline Numbering for DOCX not working when new headings inserted in between", and related bug 50774 -- "FILEOPEN DOC/DOCX: automatic numbering in numbered lists different from Word numbering" are both long present import/export filter issues.

Native ODF format of outline numbers are not affected when kept in that format, so while annoying the bugs are not really new nor are they MAB candidates.

Also, no need to attach issue specific files to the Metabugs--attachements belong with the individual issues.
Comment 71 meneerjansen00 2015-06-28 14:20:51 UTC
(In reply to V Stuart Foote from comment #70)
> (In reply to meneerjansen00 from comment #69)
> > Comment on attachment 116892 [details]
> > Outline numbering gets restarted every time doc is opened
> 
> bug 76817 -- "Outline Numbering for DOCX not working when new headings
> inserted in between", and related bug 50774 -- "FILEOPEN DOC/DOCX: automatic
> numbering in numbered lists different from Word numbering" are both long
> present import/export filter issues.
> 
> Native ODF format of outline numbers are not affected when kept in that
> format, so while annoying the bugs are not really new nor are they MAB
> candidates.
> 
> Also, no need to attach issue specific files to the Metabugs--attachements
> belong with the individual issues.

I take it then that we do not have to count on (work starting on) a fix for this bug to come anytime soon? That will be quite disappointing for a lot of LO users I'm afraid...
Comment 72 V Stuart Foote 2015-06-28 15:23:46 UTC
(In reply to meneerjansen00 from comment #71)
> I take it then that we do not have to count on (work starting on) a fix for
> this bug to come anytime soon? That will be quite disappointing for a lot of
> LO users I'm afraid...

Not at all, work on the WW8 import/export filters is continual. For example, if you follow the samples and discussion of bug 50774 there has been noted improvement. 

Otherwise, concise test cases with annotated comparisons in the XML of OOXML and ODF rendering of the sample documents will provide needed incentive to devs for correcting the filters. That as opposed to general statements that it is "not working".

In general, differences in XML structure--in describing styles and direct formatting--is what goes awry with the filter conversion process. Microsoft handles things "differently" in OOXML to the XML LO composes in ODF.  The filters have to resolve the difference--an ongoing development task.  The MS .DOC formats are more robust (and less dynamic), but do also have round trip filter issues--just fewer of them.

Filing useful bug reports aside, a user can put the onus back on Microsoft and export from there as ODF (e.g. .odt), rather than OOXML (e.g. .docx). Or in a more parochial sense work only in LibreOffice rendered ODF--that is what LibreOffice as a project is obliged to support.
Comment 73 meneerjansen00 2015-06-28 15:37:25 UTC
(In reply to V Stuart Foote from comment #72)
> (In reply to meneerjansen00 from comment #71)
> > I take it then that we do not have to count on (work starting on) a fix for
> > this bug to come anytime soon? That will be quite disappointing for a lot of
> > LO users I'm afraid...
> 
> Not at all, work on the WW8 import/export filters is continual. For example,
> if you follow the samples and discussion of bug 50774 there has been noted
> improvement. 
> 
I'm afraid I do not see a lot of improvement in that bub. I do see some discussions. But no patch or suggested solution. I'm sorry

> Otherwise, concise test cases with annotated comparisons in the XML of OOXML
> and ODF rendering of the sample documents will provide needed incentive to
> devs for correcting the filters. That as opposed to general statements that
> it is "not working".
> 
I'm afraid you lost me there. I'm willing to do anything youy want me to. But I do not understand what y'all would like me to give. Is the example doc not good enough? Can you not reproduce the bug? Please help me to provide you with the proper testing documents. On a side note, the description in bug 76817 comment #3 is crystal clear to me. And very reproducable. I'm afraid I do not know waht the devs would like more. If I would, I'd provide y'all with what you want in the bug report you want. I'd like to help or provide input, but I really do not know how anymore. Bug 76817 commnent #3 is so clear already...


> Filing useful bug reports aside, a user can put the onus back on Microsoft
> and export from there as ODF (e.g. .odt), rather than OOXML (e.g. .docx). Or
> in a more parochial sense work only in LibreOffice rendered ODF--that is
> what LibreOffice as a project is obliged to support.

In this hard dog eat dog worl I'm afraid the smaller fish has to accept that the bigger fish is boss. Same thing goed for LaTeX (www.latex-project.org) and  any other way to produce documents.

Best regards, Jansen
Comment 74 meneerjansen00 2015-06-28 18:37:08 UTC
@V Stuart Foote 

I'm gonna have to read up on the Office Open XML (OOXML) format/file type (which, confusingly to me, is called .docx in LO), the native Word 2007 (and higher Word versions) file format (also called .docx) and ye 'ol .doc format. This is not to be confused w/ the 'open document file' (ODF) format which, I believe, has been used by Libre- and OpenOffice since a long time. Documents in the ODT format have the extension .odT (with the T from Text, not the D for document) which is also confusing to me (I thought that native LO and 'ye 'ol OOo documents ndend in .odF).  

I found a nice article about this: https://brattahlid.wordpress.com/2012/05/08/is-docx-really-an-open-standard/

Sorry for all this off topic stuff by me that really belongs in a chat or support forum. I'm getting old. Back in the days there was only M$ Word (i.e. .doc) and OpenOffice (which I thought saved in the .odf extension).

As for now, what I did to create a document that my Word loving friends can read, edit and save is:
 
1. Open Libre Office.
2. Create new Writer document.
3. Write some text.
4. Choose: File > Save as > Microsoft Word 97/2000/XP/2003 (.doc).
   FYI: I used to choose .doc because I thought that .docx was less 
   well supported in OOo/LO... 
5. Or I choose: File > Save as > Microsoft Word 2007/2010/2013 XML (.docx)

I never even noticed that in LO there's also an option way down at the bottom called "Office Open XML (.docx)". Until today I've never heard of this format. Until today I really couldn't give a rats *ss 'bout M$'s fiddling w/ .doc and .docx format. I just don't care. If people want to use proprietary software and 
operating systems that's their problem, not mine. Boy was I wrong! 

I'll try to create an .docx LO (that is Office Open XML, not Microsoft .docx!) document and I'll test if the outline numbering probelm is also there.

As for me the question remains how MS Word 2007+ handles OOXML .docx files that were created by LO. Does it leave LO's .docx format intact or not? And how does LO handle M$ created .docx files, does the outline numbering bug appear of doesn't it? 

To be continued. Hope y'all will forgive me all the confusion I might have created and the overly long comments that posted here. One is never to old to learn. :-)
Comment 75 meneerjansen00 2015-06-28 20:08:42 UTC
1. Reading the blog that I mentioned earlier is highly recommended for all people who have ever used MS Office '97 to 2003! See: https://brattahlid.wordpress.com/2012/05/08/is-docx-really-an-open-standard
It clarifies why there are two ways of saving a document as .docX!

2. Tried to reproduce the bug by making a document in LO and saving it in Office Open OOXML format (i.e. NOT MS's version of OOXML/docX!).

3. Bug still there.

4. When one saves the document in LO's native open document format (ODF, confusingly ending in .odT) bug is not there.

Conclusion: the bug does not have anything to do with Microsoft's crappy implementation of the OOXML standard. The bug has to do w/ the way Libre Office generates a document in the the OPEN document standard OOXML (confusingly also called .docx, not LO's fault, see aforementioned blog).

This bug, strangely enough, probably has nothing to do w/. Microsoft!
Comment 76 meneerjansen00 2015-06-28 20:22:55 UTC
Created attachment 116900 [details]
Two documets made w/ LO in OOXML format and re-saved as...

Two test documents. Both made in LO. One is saved as OOXML (LO's version of OOXML, not MS's version!). The other was made in LO, saved as OOXML (it had the bug) and after that saved as .odT which only made the bug disappear after reapplying ALL outline numbered styles. So using .odt as an intermediate when ou receice a Word doc will not work.
Comment 77 V Stuart Foote 2015-06-28 20:25:24 UTC
(In reply to meneerjansen00 from comment #74)

> To be continued. Hope y'all will forgive me all the confusion I might have
> created and the overly long comments that posted here. One is never to old
> to learn. :-)

No worries, only request is that comments be moved to the affected bug 76817, or bug 50774, and not continue on this meta issue tracker :)

Its just noise here...
Comment 78 meneerjansen00 2015-06-28 20:27:14 UTC
Darn it! Posted my last few comments in this MAB instead of the bug report itself! Sorry, sorry, sorry!
Comment 79 meneerjansen00 2015-06-28 20:36:44 UTC
(In reply to V Stuart Foote from comment #77)
> (In reply to meneerjansen00 from comment #74)
> 
> > To be continued. Hope y'all will forgive me all the confusion I might have
> > created and the overly long comments that posted here. One is never to old
> > to learn. :-)
> 
> No worries, only request is that comments be moved to the affected bug
> 76817, or bug 50774, and not continue on this meta issue tracker :)
> 
> Its just noise here...

Copied my last few comments to bug 76817. Awfully sorry for all the mixes up and the confusion. A moderator might delete my last few comments here, if possible...
Comment 80 Stefan 2015-09-10 23:53:14 UTC
Added Bug 89818 - Long image inserted at the end of page goes beyond margin and over footer

This bug effects NOT ONLY "long" images, but _all images_ embedded in paragraphs near the end of a page.

"Overlapping" images (over footers and/or below pagemargins) make LO completly useless if you plan to put some images in paragraphs. And using images is not an advanced way to style documents, right?!

(Sorry, added this @ MAB4.3 too :/)
Comment 81 tommy27 2015-10-18 02:59:33 UTC
Hi all,

The MAB docs on the wiki have been updated to reflect the new
Priority-based system for categorizing bugs:
https://wiki.documentfoundation.org/QA/Most_Annoying_Bugs

The old MAB tracker bugs (mab4.3, mab4.4, etc.) will remain in
Bugzilla for historical reference, but should be ignored for current
work. 

......................

FINAL mab4.4 STATS
......................

fixed bugs -> 52
open bugs  -> 7

......................

for the record, here is the list of the residual open bugs that I'm going to remove from the "Depends on" field: 

Bug 37223: Target for paste cells from column in Calc into TABLE will be single cell instead of column
Bug 57989: EDITING: Writer TABLE does not update sum when adding or deleting row
Bug 83159: DATALOSS: default font size not saved in chart textbox
Bug 84678: FILEOPEN: .DOCX textbox margins incorrectly set in 4.4.x
Bug 86675: Bad-quality antialiasing for PNG images, looks terribly ugly
Bug 86678: TOOLBAR: Underlined letters in new drop downs not working
Bug 88182: Sidebar: Undocked sidebar is an unusable size without resizing, doesn't expand automatically 

I set status to RESOLVED MOVED to reflect the new way to handle Most Annoying Bugs.