Bug 79933 - Insert Hyperlink shortcut is wrong in spanish UI
Summary: Insert Hyperlink shortcut is wrong in spanish UI
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86-64 (AMD64) Windows (All)
: lowest trivial
Assignee: Yousuf Philips (jay)
QA Contact:
URL:
Whiteboard: target:6.0.0 target:5.4.1
Keywords:
: 100485 108961 (view as bug list)
Depends on:
Blocks: Shortcuts-Locale
  Show dependency treegraph
 
Reported: 2014-06-12 07:03 UTC by Danixu
Modified: 2017-08-05 14:08 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Danixu 2014-06-12 07:03:56 UTC
Hi, the shortcut button to add a hiperlink is wrong (at least in spanish vesion), because it said ctrl+k and that is "set italic" shortcut.

Is not a big bug, but i think it's easy to fix ;)
Comment 1 tommy27 2014-06-12 18:31:18 UTC
not confirming it in 4.2.4.2 italian UI and 4.4master english UI.
insert hyperlink has "Ctrl+K" shortcut in  both versions
Comment 2 Danixu 2014-06-12 19:03:02 UTC
I noticed that italic shortcut is ctrl+i, but i've tried again and both shortcuts toggle italic state..

Here's a video:
http://youtu.be/l8Slf4i9fio
Comment 3 Yousuf Philips (jay) 2014-06-12 21:55:40 UTC
Tested in on Windows 7 with 4.2.4 and 4.3 beta 2 and couldnt reproduce. What version of windows are you running and can you confirm again that your running 4.2.4 from the Help > About dialog?
Comment 4 Danixu 2014-06-12 22:03:58 UTC
I'm using Windows 7 SP1 x64 with LibreOffice 4.2.4.2
Compilation ID: 63150712c6d317d27ce2db16eb94c2f3d7b699f8
Comment 5 Danixu 2014-06-12 22:06:27 UTC
I forgot to say that i've tested both shortcuts in M$ Office (to discard mapped keys or similar) and both works like is expected.
Comment 6 Yousuf Philips (jay) 2014-06-12 22:23:23 UTC
Can you go into Tools > Options > Language Settings > Languages and let me know what is set in user interface and locale setting.
Comment 7 Danixu 2014-06-13 05:27:40 UTC
All is in default (Spanish (Spain) and EUR). Asiatic and CTL are unchecked.

I've tried to reinstall LO and i've noticed that the problem is Spanish UI. I've installed LO again clearing all data, and still having the same problem in Spanish UI but i've changed to English UI and all works fine.

Greetings
Comment 8 Danixu 2014-06-13 05:55:58 UTC
I think the problem is because Spanish UI changes the shortcut:
ctrl+n = Bold (Negrita)
ctrl+s = Underline (Subrayado)
ctrl+k = Italic (Cursiva because ctrl+c is used ^-^)
ctrl+u = New Document

while in english are:
ctrl+b = Bold
ctrl+u = Underline
ctrl+i = Italic
ctrl+n = New Document

Then the italic shortcuts are mixed (the others works fine).

PD: New Document in Spanish UI have the same shortcut text than in English, but the real shortcut is ctrl+u. Maybe it can be fixed at same time ;)
Comment 9 Julien Nabet 2014-06-13 22:52:14 UTC
On pc Debian x86-64 with master sources updated today, I could reproduce this.
(hyperlink with Ctrl H instead of Ctrl K, and 2 shortcuts for italic)
Comment 10 Danixu 2014-06-14 05:39:55 UTC
What version of LO you have?, because i've tried in my version and ctrl+H open "text replace" window. Same with alt+ctrl+b (real shortcut)...

I think that spanish UI needs a full check...
Comment 11 Julien Nabet 2014-06-14 07:37:18 UTC
(In reply to comment #10)
> What version of LO you have?, because i've tried in my version and ctrl+H
> open "text replace" window. Same with alt+ctrl+b (real shortcut)...
> 
> I think that spanish UI needs a full check...

"master sources" means current dev version, so it corresponds to future 4.4.0
Comment 12 QA Administrators 2015-07-18 17:43:17 UTC Comment hidden (obsolete)
Comment 13 Danixu 2016-03-26 22:51:15 UTC
Hi, i did not see the reply to this bug.

I've noticed that the LO 5.1.1.3 still having both bugs.

I've tested the LO 3.3.0.4 (older of downloads section), and have both bugs too. Hyperlink is not notizable because the CTRL+K shortcut text don't exist on english version of LO 3.3 and ctrl+h dont exists, but on spanish version the behaviuor is the same (both ctrl+k and ctrl+i toggle italic text style).

I think that the CTRL+K text of "Insert Hyperlink" should be changed to CTRL+H (like english version), and change the CTRL+H shortcut from Search and Replace to Insert Hyperlink. Search and Replace have it's own shortcut (CTRL+ALT+B).

Other thing to change is the CTRL+N text of "Archivo -> Nuevo" menu to CTRL+U (the same showed on New button tooltip).

Greetings and thanks.
Comment 14 Yousuf Philips (jay) 2016-03-27 15:19:09 UTC
Hi Danixu,

Yes i see that Ctrl+K is assigned in the spanish UI to italics in the accelerator file.

http://opengrok.libreoffice.org/xref/core/officecfg/registry/data/org/openoffice/Office/Accelerators.xcu#903

@sophi: Can you take this up with the spanish team so we can make a decision on what should be done.
Comment 15 sophie 2016-03-28 11:44:01 UTC
@Jay, ok, I'll send a mail. Sophie
Comment 16 Adolfo Jayme 2016-06-19 22:38:39 UTC
*** Bug 100485 has been marked as a duplicate of this bug. ***
Comment 17 Adolfo Jayme 2016-06-19 22:47:02 UTC
The Spanish shortcut for the Hyperlink dialog should be set to Ctrl+Alt+K, to match Word 2016.
Comment 18 Julien Nabet 2017-07-05 09:02:33 UTC
*** Bug 108961 has been marked as a duplicate of this bug. ***
Comment 19 Yousuf Philips (jay) 2017-07-06 18:15:14 UTC
Patch is in for Ctrl+Alt+K.

https://gerrit.libreoffice.org/39664
Comment 20 Commit Notification 2017-07-07 05:30:36 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7ab9f12b57b1cb25b8b29f8bcbf006968db6b679

tdf#79933 Set Ctrl+Alt+K for hyperlink in Spanish

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 21 kavalec74 2017-07-07 08:49:27 UTC
Would not be possible to impldment it in 5.4 final? As I think to know, is it the last version for XP? It is realy a stupid bug.

Is possible fix it by customizing shortcuts?
Comment 22 Julien Nabet 2017-07-07 08:56:33 UTC
(In reply to kavalec74 from comment #21)
> Would not be possible to impldment it in 5.4 final?
> ...

The patch for 5.4 branch is on gerrit waiting for review, see https://gerrit.libreoffice.org/#/c/39674/
Comment 23 kavalec74 2017-07-07 09:07:20 UTC
Great! Thank you. 

I fixed it by customizing :-)
Comment 24 Commit Notification 2017-08-05 14:08:16 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=46fe039ab6b2bfdde06a29e5af8f0ef3db6783b8&h=libreoffice-5-4

tdf#79933 Set Ctrl+Alt+K for hyperlink in Spanish

It will be available in 5.4.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.