Download it now!
Bug 79970 - FORMATTING: Incomplete document opening a docx
Summary: FORMATTING: Incomplete document opening a docx
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.6.2 release
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: bibisected, possibleRegression, regression
Depends on:
Blocks:
 
Reported: 2014-06-13 07:39 UTC by Gerhard T.
Modified: 2015-12-15 22:07 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
File to reproduce the problem (1.34 MB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-06-13 07:39 UTC, Gerhard T.
Details
Only first page visible in Print PreView. In Web View all data visible (72.32 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2015-08-06 16:29 UTC, Janckx
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerhard T. 2014-06-13 07:39:21 UTC
Created attachment 100963 [details]
File to reproduce the problem

Problem description: 

When opening attached docx file with LibreOffice 4.1.6 only the first page is shown in LibreOffice Writer.

Opening the file with LibreOffice 4.1.3 all the content is shown (6 pages) and it looks passably good.

Furthermore also the first page looks much better in LibreOffice 4.1.3 than in LibreOffice 4.1.6.
Operating System: Windows (other)
Version: 4.1.6.2 release
Last worked in: 4.1.3.2 release
Comment 1 Julien Nabet 2014-06-13 22:05:12 UTC
On pc Debian x86-64 with master sources updated today, I could reproduce this.

I noticed these console logs:
warn:legacy.osl:12621:1:oox/source/docprop/docprophandler.cxx:323: For now unexpected tags are ignored!
warn:legacy.osl:12621:1:oox/source/docprop/docprophandler.cxx:323: For now unexpected tags are ignored!
warn:legacy.osl:12621:1:oox/source/docprop/docprophandler.cxx:323: For now unexpected tags are ignored!
warn:legacy.osl:12621:1:oox/source/docprop/docprophandler.cxx:323: For now unexpected tags are ignored!
warn:legacy.osl:12621:1:oox/source/docprop/docprophandler.cxx:323: For now unexpected tags are ignored!
warn:legacy.osl:12621:1:oox/source/docprop/docprophandler.cxx:323: For now unexpected tags are ignored!
warn:legacy.osl:12621:1:oox/source/docprop/docprophandler.cxx:323: For now unexpected tags are ignored!
warn:legacy.osl:12621:1:oox/source/docprop/docprophandler.cxx:323: For now unexpected tags are ignored!
warn:legacy.osl:12621:1:oox/source/docprop/docprophandler.cxx:323: For now unexpected tags are ignored!
warn:legacy.osl:12621:1:oox/source/docprop/docprophandler.cxx:323: For now unexpected tags are ignored!
warn:svl:12621:1:svl/source/items/style.cxx:262: StyleSheet-Follow not found
warn:svl:12621:1:svl/source/items/style.cxx:262: StyleSheet-Follow not found
warn:oox:12621:1:oox/source/drawingml/shapecontext.cxx:128: ShapeContext::onCreateContext: unhandled element: 3942
warn:writerfilter:12621:1:writerfilter/source/dmapper/GraphicImport.cxx:1308: failed. Message :GraphicCrop
warn:writerfilter:12621:1:writerfilter/source/dmapper/SdtHelper.cxx:110: unhandled w:dateFormat value
warn:sw.uno:12621:1:sw/source/core/unocore/unotext.cxx:2266: Exception when setting property: TopBorder. Message: 
warn:sw.uno:12621:1:sw/source/core/unocore/unotext.cxx:2266: Exception when setting property: IsWidthRelative. Message: relative width cannot be switched on with this property
warn:oox:12621:1:oox/source/drawingml/shapecontext.cxx:128: ShapeContext::onCreateContext: unhandled element: 3942
warn:oox:12621:1:oox/source/drawingml/shapecontext.cxx:128: ShapeContext::onCreateContext: unhandled element: 3943
warn:writerfilter:12621:1:writerfilter/source/dmapper/GraphicImport.cxx:1308: failed. Message :GraphicCrop
warn:legacy.osl:12621:1:oox/source/helper/storagebase.cxx:72: StorageBase::StorageBase - missing base input stream
Comment 2 Julien Nabet 2014-06-13 22:05:33 UTC
Miklos: one for you?
Comment 3 Yousuf Philips (jay) (retired) 2014-06-13 23:16:35 UTC
Confirmed in Linux Mint in 4.1.6, 4.2.4, 4.3 beta 2, and 4.4 alpha. 

It works fine in 4.0.6. I think the issue maybe due to the 1st page having a different page size than the following 5 pages.
Comment 4 Gerhard T. 2014-11-10 13:43:32 UTC
It seems to me that the issue is triggered by the table in the footer section.
After removing the footer table the document looks quite good in LibreOffice 4.2.7.

Please have a look on it - this issue is really annoying for us.
Comment 5 Janckx 2015-08-06 16:29:24 UTC
Created attachment 117718 [details]
Only first page visible in Print PreView. In Web View all data visible

Only first page visible in Print PreView. In Web View all data visible. Saving to .odt or export to .pdf does not solve the problem.
Comment 6 Yousuf Philips (jay) (retired) 2015-08-06 17:34:50 UTC
(In reply to Janckx from comment #5)
> Created attachment 117718 [details]
> Only first page visible in Print PreView. In Web View all data visible

Hi Janckx,

Your attached document doesnt have the same problem that attachment 100963 [details] does, but it does remind me of bug 82452, so please do attach your document.
Comment 7 Michael Weghorn 2015-08-07 16:59:43 UTC
bibisect result (using the bibisect-43all repository):

There are only 'skip'ped commits left to test.
The first bad commit could be any of:
a043626b542eb8314218d7439534dce2fc325304
79ff8e93eb0ddcebca4f814fc6883da8e1485c9f
ae627c725e93b01ef68cf242574f40eb9885e3c9
91460ba3ce3a0efa5693f098c1072b058903a31c
We cannot bisect more!

---

$ git bisect log
# bad: [752769ad0d2179e17ea0a08cc9004df7b890305b] source-hash-60c64b437c6678dd1d3fa3a6fc2b7da0480890d4
# good: [2e0fa432485d1db6abd355dad8ccb06f0b97e4fb] source-hash-ce90f99a2d66c2b998ad3f9f028e2ea623a757f5
git bisect start 'last42onmaster' 'last40onmaster'
# good: [3b187f1cb396a02f99a3da44b8b1daa40d795749] source-hash-344d80ee1d3829b28c18135ac4f0500d4b69aedd
git bisect good 3b187f1cb396a02f99a3da44b8b1daa40d795749
# good: [7248c8d3ae94540ec2e94d6b760ef52708a71ebe] source-hash-33f6696f393363dc9c182dfc732f87465e5e53ea
git bisect good 7248c8d3ae94540ec2e94d6b760ef52708a71ebe
# bad: [1b204196f0fbb248722573341fab666b41038431] source-hash-03e9845525037a02dac320ad09fb6eed34e9f0da
git bisect bad 1b204196f0fbb248722573341fab666b41038431
# skip: [edd0c98bc8eba396299d252906dea0898436e42a] source-hash-6489f97fc428446c53c17f885963776cdcc21490
git bisect skip edd0c98bc8eba396299d252906dea0898436e42a
# bad: [5b0bc0b6253d7572470c6a3058d5fff68c93897f] source-hash-bdf2b506c38b38af531d8c8aa14dd51d89386899
git bisect bad 5b0bc0b6253d7572470c6a3058d5fff68c93897f
# skip: [8cb23b3181bfae3988e27d5621476e8fc74ab823] source-hash-132731f0704b5a9e996cb0d413c8e369efe8875f
git bisect skip 8cb23b3181bfae3988e27d5621476e8fc74ab823
# bad: [047d10291c5cd0615c992821829c9153e2f06b13] source-hash-43ccd83d2598256de2193348c0b3c7f85fb4870e
git bisect bad 047d10291c5cd0615c992821829c9153e2f06b13
# skip: [6b6b50cddd82bdfd45433bb7f8b31663211e2e13] source-hash-c3ef735fd5d8866c8ce28b89744150e733087427
git bisect skip 6b6b50cddd82bdfd45433bb7f8b31663211e2e13
# skip: [79ff8e93eb0ddcebca4f814fc6883da8e1485c9f] source-hash-0bca15197461f9e0c6f28ce301c2fed2ec4b38cb
git bisect skip 79ff8e93eb0ddcebca4f814fc6883da8e1485c9f
# skip: [a235cee7729b6eda7f2f6b1cf3347d8eb2a1a49c] source-hash-fa469b2e00d83459faebe4c1fcb3ea1aac5fb20d
git bisect skip a235cee7729b6eda7f2f6b1cf3347d8eb2a1a49c
# skip: [5fa28ce2931a35ae64ae08d3904cfb76d24459d8] source-hash-2304beaca33c63b94df99cb827716f00ce259f9a
git bisect skip 5fa28ce2931a35ae64ae08d3904cfb76d24459d8
# skip: [10fc65607493c257076c8af1b708839eb03d8d14] source-hash-1500aae993c0a8b4fa9a5bcec1bc6203f3bcff66
git bisect skip 10fc65607493c257076c8af1b708839eb03d8d14
# bad: [91460ba3ce3a0efa5693f098c1072b058903a31c] source-hash-69f61526cd4268a330be1e835e9e52f9b1dbde50
git bisect bad 91460ba3ce3a0efa5693f098c1072b058903a31c
# skip: [50f1f06ed2dd40d2e6f658524a5e160ba1a84807] source-hash-647fb29f528b891a1c92846640f7865f5c1fbe7f
git bisect skip 50f1f06ed2dd40d2e6f658524a5e160ba1a84807
# good: [9771d0c212cfa71b07742ff3dc5c05df22d600eb] source-hash-a9a0933ec67eab0ec31c8fadb60fb8e8e3e90485
git bisect good 9771d0c212cfa71b07742ff3dc5c05df22d600eb
# skip: [a043626b542eb8314218d7439534dce2fc325304] source-hash-9379a922c07df3cdb7d567cc88dfaaa39ead3681
git bisect skip a043626b542eb8314218d7439534dce2fc325304
# skip: [ae627c725e93b01ef68cf242574f40eb9885e3c9] source-hash-2ee4a04d61de32003d1895ac157ae97db7dd36c8
git bisect skip ae627c725e93b01ef68cf242574f40eb9885e3c9
# only skipped commits left to test
# possible first bad commit: [91460ba3ce3a0efa5693f098c1072b058903a31c] source-hash-69f61526cd4268a330be1e835e9e52f9b1dbde50
# possible first bad commit: [79ff8e93eb0ddcebca4f814fc6883da8e1485c9f] source-hash-0bca15197461f9e0c6f28ce301c2fed2ec4b38cb
# possible first bad commit: [a043626b542eb8314218d7439534dce2fc325304] source-hash-9379a922c07df3cdb7d567cc88dfaaa39ead3681
# possible first bad commit: [ae627c725e93b01ef68cf242574f40eb9885e3c9] source-hash-2ee4a04d61de32003d1895ac157ae97db7dd36c8

In the skipped commits, LibreOffice did not start.
Comment 8 Michael Weghorn 2015-08-07 17:00:42 UTC
I just tried to open the file with a recent master build (commit b6f9394f2d67b01d63aa5e1d9551ae4b4016a71e, source-hash-cd6c9aef7468120dd5ea5c747f35c98baf214613 of 2015-08-04). The file displays fine there.
Comment 9 Michael Weghorn 2015-08-07 17:04:53 UTC
(In reply to Michael Weghorn from comment #8)
> I just tried to open the file with a recent master build (commit
> b6f9394f2d67b01d63aa5e1d9551ae4b4016a71e,
> source-hash-cd6c9aef7468120dd5ea5c747f35c98baf214613 of 2015-08-04). The
> file displays fine there.

The version I used is from the lo-linux-dbgutil-daily bibisect repository.
Comment 10 Yousuf Philips (jay) (retired) 2015-08-07 18:52:36 UTC
Confirming that it is fixed in 5.0.

Version: 5.0.1.0.0+
Build ID: 5edd74d8983705900681163edfc315cfbee6c08e
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:libreoffice-5-0, Time: 2015-07-30_23:49:52
Comment 11 Jan Holesovsky 2015-08-12 08:05:41 UTC
Comment on attachment 117718 [details]
Only first page visible in Print PreView. In Web View all data visible

Update the mime type.
Comment 12 Robinson Tryon (qubit) 2015-12-15 22:07:11 UTC
Migrating Whiteboard tags to Keywords: ( possibleRegression bibisected)
[NinjaEdit]