Download it now!
Bug 79990 - EDITING: multiple graphic objects cannot be selected with 'shift'
Summary: EDITING: multiple graphic objects cannot be selected with 'shift'
Status: CLOSED DUPLICATE of bug 37960
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-06-13 15:27 UTC by Gleb
Modified: 2017-04-19 21:28 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
example of document with graphic objects and image (43.89 KB, application/vnd.oasis.opendocument.text)
2014-06-13 15:27 UTC, Gleb
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gleb 2014-06-13 15:27:08 UTC
Created attachment 100985 [details]
example of document with graphic objects and image

Problem description: 
When selecting multiple graphic objects with 'shift' pressed selection disappears.

Steps to reproduce:
1. Draw some graphic objects (squares, lines, etc)
2. Press 'Enter', 'Enter', 'Enter' ...
3. Insert an image from file under graphic objects
4. Try to select graphic object obe by one with 'shift' pressed.

Current behavior: when selecting drawn objects with 'shift' pressed an image selected unexpectedly.

Expected behavior: adding 2-nd, 3-rd objects to current selection.

              
Operating System: Windows 8
Version: 4.2.4.2 release
Comment 1 Yousuf Philips (jay) (retired) 2014-06-14 00:09:22 UTC
Confirmed in Linux Mint in 3.3.0, 4.2.4 and 4.3 beta. When attempting to click the second graphic object while holding on shift, the selection jumps to the image and deselect the first selection.
Comment 2 Norbert X 2014-11-21 20:48:39 UTC
I can confirm this bug on 
1. Version: 4.3.3.2
Build ID: 430m0(Build:2)
2. Version: 4.4.0.0.beta1
Build ID: 9af3d21234aa89dac653c0bd76648188cdeb683e
Locale: en_US
Comment 3 Andras Timar 2014-11-21 21:23:19 UTC
I cannot reproduce it in my own 4.3.5.0.0+ Windows build. Isn't it a duplicate of bug 37960?
Comment 4 Norbert X 2014-11-21 21:53:10 UTC
@Andras
No, this bug is different. It's about selecting Image(s) and Drawing(s) object(s) together.

So user is unable to select image(s) and drawing(s) with shift+click or Select tool rectangle for grouping or aligning.

You can try to draw something in MS Word 2003+, insert an image with Drawing Canvas and try to group these objects. MS Word allows user to select images and drawings together with mouse or <Shift>, but LibO does not.

If you can please fix this bug too.
Comment 5 Norbert X 2014-12-19 09:06:56 UTC
It seems that bug is not fixed in
Version: 4.3.5.2
Build ID: 430m0(Build:2)
on Ubuntu Precise Pangolin 12.04.5 with PPA:

apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:4.3.5~rc2-0ubuntu1~precise1
  Candidate: 1:4.3.5~rc2-0ubuntu1~precise1
  Version table:
 *** 1:4.3.5~rc2-0ubuntu1~precise1 0
        500 http://ppa.launchpad.net/libreoffice/ppa/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status
     1:3.5.7-0ubuntu7 0
        500 http://archive.ubuntu.com/ubuntu/ precise-updates/main amd64 Packages
        500 http://archive.ubuntu.com/ubuntu/ precise-security/main amd64 Packages
     1:3.5.2-2ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
Comment 6 Norbert X 2015-01-30 18:40:26 UTC
It seems that bug is not fixed in
Version: 4.4.0.3
Build ID: 40m0(Build:3)
on Ubuntu Precise Pangolin 12.04.5 with PPA:

apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:4.4.0~rc3-0ubuntu1~precise1
  Candidate: 1:4.4.0~rc3-0ubuntu1~precise1
  Version table:
 *** 1:4.4.0~rc3-0ubuntu1~precise1 0
        500 http://ppa.launchpad.net/libreoffice/ppa/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status
     1:3.5.7-0ubuntu7 0
        500 http://mirror.yandex.ru/ubuntu/ precise-updates/main amd64 Packages
        500 http://mirror.yandex.ru/ubuntu/ precise-security/main amd64 Packages
     1:3.5.2-2ubuntu1 0
        500 http://mirror.yandex.ru/ubuntu/ precise/main amd64 Packages
Comment 7 Dominik 2015-04-21 11:04:42 UTC
(In reply to Norbert X from comment #4)
> @Andras
> No, this bug is different. It's about selecting Image(s) and Drawing(s)
> object(s) together.
> 
> So user is unable to select image(s) and drawing(s) with shift+click or
> Select tool rectangle for grouping or aligning.

It's a more general thing: 
Multiple images can't be selected with shift+click (bug 34442) 
much less to be grouped (bug 34438)

Looking at Gleb's bug description, it seems indeed to be a duplicate of bug 37960.

*** This bug has been marked as a duplicate of bug 37960 ***
Comment 8 Regina Henschel 2017-04-19 21:28:59 UTC
Fixed.