Bug 80100 - Impress crashes when selecting "Line..." after selecting a graphic object
Summary: Impress crashes when selecting "Line..." after selecting a graphic object
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-06-16 17:06 UTC by jsc67
Modified: 2015-02-26 17:20 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Impress file which has bug behavior reliably (33.66 KB, application/vnd.oasis.opendocument.presentation)
2014-06-16 17:06 UTC, jsc67
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jsc67 2014-06-16 17:06:15 UTC
Created attachment 101185 [details]
Impress file which has bug behavior reliably

I copied some graphs with titles from Calc and did Paste Special to paste them as a GDI metafile.  These graphs did not have a border around them, and I wanted to add a line border.  So I selected it, right-clicked it to bring up the Line... menu (which works fine in Calc), and then it crashes.
Comment 1 Julien Nabet 2014-06-16 20:58:05 UTC
On pc Debian x86-64 with 4.2.4 LO Debian package, I could reproduce this.
However, I don't reproduce this with 4.2 sources updated some days ago.

For the test, could you give a try to 4.2.5RC2 (http://www.libreoffice.org/download/libreoffice-fresh/?version=4.2.5)?
Comment 2 jsc67 2014-06-29 20:29:48 UTC
Yes, it still crashes just the same with 4.2.5.2, tested on 2014-06-29, new Windows LibreOffice download.
-James

From: bugzilla-daemon@freedesktop.org
To: jsc67@hotmail.com
Subject: [Bug 80100] Impress crashes when selecting "Line..." after selecting a graphic object
Date: Mon, 16 Jun 2014 20:58:05 +0000


    
      
    
     Julien Nabet
 changed
              bug 80100
        

             
          
            What
            Removed
            Added
          

         
           Status
           UNCONFIRMED
           
           NEEDINFO
           
         

         
           CC
           
                
           
           serval2412@yahoo.fr
           
         

         
           Ever confirmed
           
                
           
           1
           
         
      
        

            Comment # 1
              on bug 80100
              from  Julien Nabet

        On pc Debian x86-64 with 4.2.4 LO Debian package, I could reproduce this.
However, I don't reproduce this with 4.2 sources updated some days ago.

For the test, could you give a try to 4.2.5RC2
(http://www.libreoffice.org/download/libreoffice-fresh/?version=4.2.5)?
        
      

      
      You are receiving this mail because:
      
      
          You reported the bug.
Comment 3 Julien Nabet 2014-06-30 06:18:03 UTC
James: thank you for your feedback.
For the test, could you rename your LO directory profile (see https://wiki.documentfoundation.org/UserProfile#Windows)
If you still reproduce this, would you have extra time to give a try to 4.2 daily build (see http://dev-builds.libreoffice.org/daily/libreoffice-4-2/Win-x86@42/current/)?
(please don't answer directly from your emailer but from this link:
https://bugs.freedesktop.org/show_bug.cgi?id=80100#)
Comment 4 QA Administrators 2015-01-10 18:06:43 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team

Message generated on: 10/01/2015
Comment 5 jsc67 2015-02-06 13:43:06 UTC
Thank-you for the reminder.  On 2015-02-03 I installed LibreOffice 4.4.0.3 and tested it with the same demo file which reliably produced the crash in 4.2.5.2, and it worked fine.  I won't bother trying with 4.3 at this point.  It seems fixed in 4.4 anyway.

James