Bug 80181 - FILEOPEN: bad display of .pptx background theme color
Summary: FILEOPEN: bad display of .pptx background theme color
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: filter:pptx
: 89156 (view as bug list)
Depends on:
Blocks: PPTX OOXML-Doc-Themes
  Show dependency treegraph
 
Reported: 2014-06-18 10:56 UTC by Yan Pas
Modified: 2019-02-15 18:14 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (681.20 KB, image/jpeg)
2014-06-18 10:56 UTC, Yan Pas
Details
Test presentation (56.61 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2014-06-19 09:38 UTC, Yan Pas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yan Pas 2014-06-18 10:56:57 UTC
Created attachment 101294 [details]
Screenshot

I've started making presentation in powerpoint, then opened it in LO - it looks awful. Well you see problem on a screenshot, I don't kbow reasons, but pptx compatibility is LOW.
Operating System: All
Version: 4.2.4.2 release
Comment 1 tommy27 2014-06-18 22:39:08 UTC Comment hidden (obsolete)
Comment 2 Yan Pas 2014-06-19 09:38:14 UTC
Created attachment 101351 [details]
Test presentation

That presentation file, which open incorrectly
Comment 3 tommy27 2014-06-19 10:44:08 UTC
tested under Win7x64

let's focus on the background color issue (I'll open later a separate report about text size and color)

file correctly shown in MS PowerPoint Viewer 2010

bad display of .pptx background color with same results as in your screenshot using LibO 4.2.4.2 and 4.4.0.0.alpha0+ (*) and bad results with old LibO releases 
up to 3.3.3 (I don't have older ones to test)

updated version and status fields
Comment 4 tommy27 2014-06-19 10:50:32 UTC
background color issue present in OOo 3.3.0 as well hence bug is inherited from OOo.

the text color issue has been already described in Bug 72567 - FILEOPEN: Impress doesn't import text gradient from .PPTX
Comment 5 QA Administrators 2015-07-18 17:44:42 UTC Comment hidden (obsolete)
Comment 6 Yan Pas 2015-07-18 18:55:17 UTC
Version 4.4.4, still exists
Comment 7 Xisco Faulí 2015-08-19 16:02:57 UTC
Problem still present in

Version: 5.0.0.5
Build ID: 1b1a90865e348b492231e1c451437d7a15bb262b
Locale: es-ES (es_ES)

on Windows 7 (64-bit)
Comment 8 Matus Uzak 2016-03-12 15:48:06 UTC
*** Bug 89156 has been marked as a duplicate of this bug. ***
Comment 9 Ofir 2016-08-17 09:44:02 UTC Comment hidden (obsolete)
Comment 10 Aron Budea 2016-11-05 20:49:50 UTC Comment hidden (obsolete)
Comment 11 Ofir 2017-11-10 00:05:32 UTC Comment hidden (obsolete)
Comment 12 Ofir 2018-03-03 22:40:32 UTC
Reproducible with:

Version: 6.1.0.0.alpha0+
Build ID: 44b4ad7d210097fdaed7dd94c5746b03f43592d3
CPU threads: 1; OS: Linux 4.13; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-03-02_23:38:12
Locale: en-US (en_US.UTF-8); Calc: group
Comment 13 Timur 2019-02-15 17:47:42 UTC
This is not simple background color issue but "text/background" theme color from slide master.
Probably duplicated.