Bug Hunting Session
Bug 80224 - FILESAVE: Custom text color changed to black on .PPTX export
Summary: FILESAVE: Custom text color changed to black on .PPTX export
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: Other All
: medium normal
Assignee: Heena Gupta
URL:
Whiteboard: BSA target:5.1.0 target:5.0.4
Keywords:
Depends on:
Blocks:
 
Reported: 2014-06-19 10:40 UTC by ravingdesi
Modified: 2016-10-25 19:17 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
test case (23.33 KB, application/vnd.oasis.opendocument.presentation)
2015-07-19 05:19 UTC, tommy27
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ravingdesi 2014-06-19 10:40:31 UTC
Problem description: 
When exporting, the color of text changes to black, when it was previously a customly created color

Steps to reproduce:
1. Download https://dl.dropboxusercontent.com/u/17406199/bugtmp/Bug7.odp
2. Save as pptx
For me this resulted in 
https://dl.dropboxusercontent.com/u/17406199/bugtmp/Bug7.pptx
3. Open again in impress or MS powerpoint

Current behavior:
Text color is changed to black
https://dl.dropboxusercontent.com/u/17406199/bugtmp/Bug7_2.png

Expected behavior:
Text color should be preserved
https://dl.dropboxusercontent.com/u/17406199/bugtmp/Bug7_1.png

Thank you very much for all your efforts.
              
Operating System: Ubuntu
Version: 4.2.4.2 release
Comment 1 ign_christian 2014-06-19 14:48:50 UTC
Confirm similar behavior in 4.0.6.2 (Win7 x86), text change to black colored Arial regular 18.

So 4.2.4.2 is much better
Comment 2 ign_christian 2014-06-20 15:21:14 UTC
Confirm with 4.2.5.2 - Ubuntu 12.04 x86, text change to Times New Roman.

Change Version to 4.0.6.2, Platform All
Comment 3 ravingdesi 2014-06-21 11:58:28 UTC
Thanks, didn't notice the font change, but font change here (ubuntu, LO 4.2.4.2) present as well. But unsure if the change to a windows standard font may actually be intended (?)

Anyways, color change is definitely not intended I believe.
Comment 4 Yogesh Bharate 2015-05-08 09:17:02 UTC
In original file, the font name is Liberation Serif after save as font name changed to Times New Roman this is another bug.
Comment 5 tommy27 2015-07-19 05:19:04 UTC
Created attachment 117321 [details]
test case

I add a simple test case.
see how the letter "A" color changes from purple to black after .odp to .pptx saving.

I can already reproduce this in LibO 3.3.3
issue persists in LibO 4.4.5.1 and recent 5.1.0.0 daily builds.

tested under Win8.1 x64
Comment 6 Commit Notification 2015-08-25 11:56:15 UTC
Mark Hung committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=43679f94b45f4d9e120c64a3fb5cc3ee77f12b11

Fix tdf#80224 Custom text color changed to black on .PPTX export

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2015-11-26 10:41:36 UTC
Mark Hung committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0b5e3885bc706ed02acac1c682c90171700b0cac&h=libreoffice-5-0

Fix tdf#80224 Custom text color changed to black on .PPTX export

It will be available in 5.0.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Timur 2016-03-14 13:43:16 UTC
I'd say it's fixed.