Bug 80312 - EDITING: Sort with references changes formula
Summary: EDITING: Sort with references changes formula
Status: RESOLVED DUPLICATE of bug 79441
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: Other Linux (All)
: high critical
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: possibleRegression
Depends on:
Blocks:
 
Reported: 2014-06-20 22:06 UTC by Nuno José Almeida
Modified: 2015-12-15 10:57 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample file (25.87 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-06-21 07:10 UTC, Nuno José Almeida
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nuno José Almeida 2014-06-20 22:06:09 UTC
Problem description: 

Steps to reproduce:
1. Chose list with references
2. Sort

Current behavior:Sorted list appear with formulas changes ie if a cell has the reference A1 and goes down a line, it becomes A2. Some other misbehaviour occur when sorting.

Expected behavior:

              
Operating System: Ubuntu
Version: 4.2.5.2 rc
Last worked in: 4.2.4.2 release
Comment 1 ign_christian 2014-06-21 05:22:17 UTC
Hi Nuno, please provide sample file for test case along with reproducible steps. And try again with fresh user profile.

Then change back status to UNCONFIRMED to let someone triage the problem
Comment 2 Nuno José Almeida 2014-06-21 07:10:31 UTC
Created attachment 101469 [details]
Sample file

If you try to sort the data on sheet "2" (with references and sum formulas) it simple does not sort. If you sort the sheet "1" it does the espected.
Comment 3 Nuno José Almeida 2014-06-21 07:23:30 UTC
Tried to delete user profile folder and the behaviour is still the same.
Comment 4 ign_christian 2014-06-21 07:32:09 UTC
(In reply to comment #0)
> Current behavior:Sorted list appear with formulas changes ie if a cell has
> the reference A1 and goes down a line, it becomes A2. Some other
> misbehaviour occur when sorting.

Strange...I can't do sorting at all with 4.2.5.2 under Ubuntu 12.04 x86.
Not happen in 4.0.6.2.

Raise the priority since it's very annoying & set status UNCONFIRMED to let experts check this.
Comment 5 ign_christian 2014-06-21 09:56:49 UTC
Looks similar / related to Bug 79441
Comment 6 Laurent BP 2014-06-21 13:28:40 UTC

*** This bug has been marked as a duplicate of bug 79441 ***
Comment 7 Robinson Tryon (qubit) 2015-12-15 10:57:57 UTC
Migrating Whiteboard tags to Keywords: (possibleRegression)
[NinjaEdit]