Download it now!
Bug 80339 - VIEWING: SVG imported image not displaying correctly
Summary: VIEWING: SVG imported image not displaying correctly
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 96322 (view as bug list)
Depends on:
Blocks: Draw-Images SVG-Open
  Show dependency treegraph
 
Reported: 2014-06-21 18:04 UTC by berff
Modified: 2018-06-20 17:03 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
This SVG image is rendered incorrectly (14.06 KB, image/svg+xml)
2014-06-21 18:04 UTC, berff
Details
LibO 4.4 VS image viewer (146.62 KB, image/png)
2014-06-21 18:30 UTC, Yousuf Philips (jay) (retired)
Details
Rendered SVG in LibreOffice Draw 6.0.2 (113.00 KB, image/png)
2018-04-02 08:11 UTC, berff
Details
status.svg in LO Draw 6.1 beta 2 (52.11 KB, image/png)
2018-06-18 20:21 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description berff 2014-06-21 18:04:12 UTC
Created attachment 101498 [details]
This SVG image is rendered incorrectly

Steps to reproduce:

1. Open attached document in LibreOffice Draw
2. Some Text is shifted to the right

Checked for 4.0.4.2 release as well as latest 4.3.0rc1
Comment 1 Yousuf Philips (jay) (retired) 2014-06-21 18:29:43 UTC
Confirmed on Linux Mint in 3.3.0, 4.2.5, 4.3 beta 2 and 4.4 alpha.
Comment 2 Yousuf Philips (jay) (retired) 2014-06-21 18:30:41 UTC
Created attachment 101504 [details]
LibO 4.4 VS image viewer
Comment 3 Jorendc 2014-07-22 17:16:12 UTC
Not a problem when using Insert > image > From file... (libreoffice is (sadly still) using different filters for opening and inserting svg images).
Comment 4 Xisco Faulí 2015-12-01 14:27:32 UTC
SVG looks worse in 

Version: 5.2.0.0.alpha0+
Build ID: f34b4844473d08c0c264ba4453a875e32f5c326b
Threads 4; Ver: Windows 6.1; Render: GL; 

I take this
Comment 5 Xisco Faulí 2015-12-09 12:04:19 UTC
*** Bug 96322 has been marked as a duplicate of this bug. ***
Comment 6 Robinson Tryon (qubit) 2015-12-09 18:52:39 UTC Comment hidden (obsolete)
Comment 7 QA Administrators 2018-02-08 03:36:18 UTC Comment hidden (obsolete)
Comment 8 berff 2018-04-02 08:10:54 UTC
Bug still reproduceable with LibreOffice Draw 6.0.2
Comment 9 berff 2018-04-02 08:11:41 UTC
Created attachment 141018 [details]
Rendered SVG in LibreOffice Draw 6.0.2
Comment 10 Roman Kuznetsov 2018-06-18 20:21:39 UTC
Created attachment 142885 [details]
status.svg in LO Draw 6.1 beta 2

looks fine in LO Draw 6.1 beta 2

Status -> WFM