Download it now!
Bug 80389 - PPT printed without text from text frames when grouped without OpenGL with HW acceleration (EMF metafile image?)
Summary: PPT printed without text from text frames when grouped without OpenGL with HW...
Status: RESOLVED DUPLICATE of bug 104252
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
4.0.5.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: EMF-WMF
  Show dependency treegraph
 
Reported: 2014-06-23 11:56 UTC by pavel.lastovicka
Modified: 2016-12-28 16:03 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Presentation that does not print correctly. (408.00 KB, application/vnd.ms-powerpoint)
2014-06-23 11:56 UTC, pavel.lastovicka
Details
Scan of printout (159.34 KB, application/pdf)
2014-06-23 12:01 UTC, pavel.lastovicka
Details
windows 7 pdf export from 4.3.1 (165.37 KB, application/pdf)
2014-07-27 21:39 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pavel.lastovicka 2014-06-23 11:56:25 UTC
Created attachment 101574 [details]
Presentation that does not print correctly.

I have got one PPT file that displays correctly in Impress but when printed in LibreOffice, some text in metafile image is missing.

I have tried a couple of LibreOffice and OpenOffice versions and they all had this problem. Only difference was how large part of the image was printed.
Comment 1 pavel.lastovicka 2014-06-23 12:01:11 UTC
Created attachment 101575 [details]
Scan of printout

Illustrates how the file should print and what LibreOffice actually printed.
Comment 2 sophie 2014-07-17 11:18:22 UTC
Hi, I do not reproduce with 4.3.0.2 Ubuntu 14.04, the content of the page printed is the same than in the scan of Office, all cells are complete. Could you try with the latest 4.3.0? Sophie
Comment 3 pavel.lastovicka 2014-07-17 11:52:17 UTC
Hello, problem happens with 4.3.0 too.

I have impression the bug occurs only on Windows, not Linux.
Comment 4 Yousuf Philips (jay) (retired) 2014-07-27 21:35:56 UTC
Confirmed on Windows 7 with LibO 4.3.1 that the WMF background image is shown in print dialog and exported in PDF without most of the black text found in the cells. This didnt happen on Linux Mint.
Comment 5 Yousuf Philips (jay) (retired) 2014-07-27 21:39:36 UTC
Created attachment 103561 [details]
windows 7 pdf export from 4.3.1
Comment 6 Timur 2014-11-24 12:18:40 UTC
From Bug 80508, we can also see that PDF export of  http://www.cgedd.fr/prix-immobilier-friggit.doc is incomplete, there are items missing in WMF or EMF (legend, caption). 
I don't know whether that's related to this bug, but I prefer to have a confirmation before opening a new bug.
Comment 7 QA Administrators 2015-12-20 16:12:13 UTC Comment hidden (obsolete)
Comment 8 Timur 2015-12-21 11:57:16 UTC Comment hidden (no-value)
Comment 9 pavel.lastovicka 2016-01-05 10:59:53 UTC
The bug is still present. LO 5.0.4, Windows 7 64-bit.
Comment 10 Timur 2016-11-14 10:09:06 UTC
Looks like resolved in 5.2.1 and later, per my test in Windows. 
But, as in Bug 77525 or Bug 103833, results may be different regarding OpenGL. 
Please test and if confirmed, mark as Resolved-WorksForMe.
Comment 11 pavel.lastovicka 2016-11-24 15:57:00 UTC Comment hidden (obsolete)
Comment 12 Timur 2016-11-28 15:29:25 UTC Comment hidden (obsolete)
Comment 13 pavel.lastovicka 2016-11-28 15:31:51 UTC
I performed a new test with LO 5.2.3 and the result was the same, the problem persists. Furthermore LO gets unresponsive for about ten seconds after selecting print command in the application. Generating print preview in the print dialog seems rather CPU intensive.
I tried to print the test presentation with Epson WorkForce Pro and Microsoft XPS Document Writer with the same results.
Comment 14 Timur 2016-11-28 15:37:26 UTC Comment hidden (obsolete)
Comment 15 pavel.lastovicka 2016-11-28 15:58:32 UTC
When I click on "Compress" in context menu of the metafile, nothing happens. I assume the application should display some dialog box instead.
Comment 16 Timur 2016-11-28 17:51:24 UTC
Well, I was reading the title with WMF and was wrong to assume this is a picture. It's actually a group. I don't know why the title says "WMF metafile image" but I'll set back to New. Looks related to Bug 77525, though.

I found 2 ways to print this properly: 
- turn on OpenGL in Tools-Options-LO-View, or
- without OpenGL, just break the group (via right-click)
Comment 17 Timur 2016-12-01 10:20:06 UTC
Per https://bugs.documentfoundation.org/show_bug.cgi?id=104252#c10 there's a 3rd way to print this: without HW acceleration. 
That bug looks like a duplicate, but since it was triaged and bibisected, this one could be marked duplicate if that one is solved.
Comment 18 pavel.lastovicka 2016-12-01 11:48:37 UTC
I can also confirm that turning off HW acceleration helps. Forcing OpenGL helps too.
Comment 19 V Stuart Foote 2016-12-01 14:10:16 UTC
Interesting side bar, when I export the .ppt through PowerPpint 2007 to OOXML .pptx and extract, the images are EMF.  But, LibreOffice open the .ppt and saves the images as WMF.

This is a duplicate of 104252, also the other EMF image in the .ppt/.pptx causes bug 104034 when opened with OpenGL enabled ;)
Comment 20 V Stuart Foote 2016-12-28 13:52:46 UTC
Going ahead and closing this as duplicate of bug 104252.

Also, original attachment to bug 77525 against 4.2.2.1 was the same issue, and as bibisected in 104252 to a commit for the 4.0.5.1 build that resulted in divergence between CPU only rendering and, hardware accelerated rendering.

OpenGL rendering handles WMF/EMF in a third method, where the black rectangles for PNG images noted in 77525 was sidebar of bug 89473 & bug 103833

Point is--for reliable rendering of embedded WMF/EMF on Windows systems, deselect Tools -> Options -> View: "Use hardware acceleration" and allow the CPU to render the WMF/EMF.

*** This bug has been marked as a duplicate of bug 104252 ***