Download it now!
Bug 80423 - UI: Missing "From top" label in Record Search dialog
Summary: UI: Missing "From top" label in Record Search dialog
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.3.0.1 rc
Hardware: Other Linux (All)
: high major
Assignee: Caolán McNamara
URL:
Whiteboard: target:4.4.0 target:4.3.0.2
Keywords: regression
Depends on:
Blocks:
 
Reported: 2014-06-23 19:39 UTC by Stanislav Horacek
Modified: 2014-06-25 11:49 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Record Search dialog in 4.2 (left) and 4.3 (right) (87.62 KB, image/png)
2014-06-23 19:39 UTC, Stanislav Horacek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stanislav Horacek 2014-06-23 19:39:59 UTC
Created attachment 101607 [details]
Record Search dialog in 4.2 (left) and 4.3 (right)

Steps to reproduce:
1. Open a database.
2. Double-click to a table to enter Table Data View.
3. Click on the Find Record icon (Ctrl+F). Record Search dialog appears.

Observed: There is a missing label for the checkbox below the "Search backwards" checkbox.

Expected: There should be "From top" label.

Everything is OK in 4.2 as shown in the attached screenshots.
Comment 1 Julien Nabet 2014-06-24 21:23:02 UTC
On pc Debian x86-64 with master sources updated today, I could reproduce this.
There are also missing positions

I increase the importance since it concerns UI + regression.

Caolán: one for you?
Comment 2 Commit Notification 2014-06-25 11:46:50 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b40145eb174396516ff60c2512064451182fb59d

Resolves: fdo#80423 string resources not built and included



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 3 Commit Notification 2014-06-25 11:48:32 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2ed062a9c4cfe6cfca67c1de7f481a78dfd67652&h=libreoffice-4-3

Resolves: fdo#80423 string resources not built and included


It will be available in LibreOffice 4.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.