Download it now!
Bug 80466 - No Quickstarter icon in systray (Windows 7)
Summary: No Quickstarter icon in systray (Windows 7)
Status: RESOLVED DUPLICATE of bug 80927
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: Other Windows (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
: 82375 83176 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-06-24 09:33 UTC by Leopoldo Saggin
Modified: 2016-05-10 00:25 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Leopoldo Saggin 2014-06-24 09:33:20 UTC
Problem description: 
In my hands the general part of this problem was present in every version of LibreOffice with Win XP and Win7. The specific part (to be described below) is only with LibreOffice 4.3.0.x

General part
Whenever I installed/updated/reinstalled a new version/subversion of LibreOffice since its initial version even if I checked the choice of "loading LibOffice at system startup" it did not work at the first launch.
Please note that I always performed the custom setup of LibreOffice; I never did the standad one.
To made it to work I needed to open Tools -> Options -> Memory and manually check the option "Load Libre Office during suytem startup" which was not checked.
This way, from the next launch I got the icon of Libre Office in the systray.

Specific part
Starting with the new version of LibreOffice 4.3.0.rc1 (but also in the previous version beta1 & beta2) in a Win7 64 bit environment and using the same techniques, I got the same behavior BUT no LibreOffice icon appears on the systray even if I checked manually the option "Load Libre Office during suytem startup" and this stays on.

Leopoldo Saggin aka Topoldo

Operating System: Windows 7
Version: 4.3.0.1 rc
Comment 1 ribotb 2014-07-03 09:42:29 UTC
Hi,

I confirm this problem : it's not possible to obtain icon in the systray.

Version: 4.3.0.1
Build ID: 67f5430184326974072b65403ef1d9d934fc4481

Win 7/x86

Bernard
Comment 2 retired 2014-07-05 22:00:08 UTC
NEW as of comment 1
Comment 3 Hans Immel 2014-07-29 13:34:02 UTC
I confirm this Problem! System Win 7 64-bit SP 1

Custom install not on c:\ but e:\programme\LibreOffice

I deinstalled LO 4.2.6 before a made an new install of LO 4.3.rc3

quickstart.exe icon does not appear in systray. I also does not appear when I start quickstart.exe manually.

Never had this problem with version older than 4.3

Hans
Comment 4 ign_christian 2014-07-29 17:05:21 UTC
Hi Topoldo, some users experience crash with quickstarter enabled : Bug 80927.

But you experience quite different behavior, please try resetting user profile : https://wiki.documentfoundation.org/UserProfile 

Anyway 4.3.0.4 has been released: http://www.libreoffice.org/download/libreoffice-fresh/?version=4.3.0
Comment 5 Adam 2014-07-30 10:54:18 UTC
On my laptop (Win 7) this problem still persists with the final release of 4.3. Quickstarter worked fine in 4.3 RC2 only but not RC1, RC3 or RC4. It just does not appear on the system tray and also when the office is closed, soffice is removed from memory so next time you start any application (writer, calc, etc.) the initial dialog box appears again and it takes longer to start. Unfortunately have to roll back to 4.2 until this is fixed.
Comment 6 Adam 2014-07-30 10:54:57 UTC
Also tried to reset the profile but it does not help.
Comment 7 Herbert Eisenbeis 2014-07-30 11:22:11 UTC
Operating System: Windows 7 SP1 64
Version: 4.3.0.4 (release)

"quickstart" does not work as Topoldo described in his original posting. I opt to assign a higher importance for this bug as "medium, normal" because this annoying problem persists in the released version and has the potential to prevent the update to 4.3.0 for many users.

Regards
Herbert Eisenbeis
Comment 8 Leopoldo Saggin 2014-07-30 12:16:14 UTC
I would like to stress something that I put at the beginning of this discussion and I don't know if it's more appropriate to leave here or move as a separate bug submission.
What I found, beside to not having the icon of the Quickstart in LibOffice 4.3.x, is that whenever I install/update/reinstall a new version/subversion of LibreOffice since it was released for the first time (version 3.3), even if I check the choice of "Loading LibreOffice at system startup" during the (re)installation of the program, this option does not work.
In fact going to Tools -> Options -> Memory after the first launch, the option "Load Libre Office during suytem startup" is not checked. I have to manually check this option during the first (or subsequent) run -> close the program -> restart it. This way it start to work. So IMHO it seems to be an useless option during installation steps.
Please note that I *ALWAYS* perform the "custom setup" of LibreOffice; I don't know if this option is ok using the standard setup.
My environment: Windows7 64bit. Further info: No MS Office installed.
Topoldo/Leopoldo
Comment 9 ign_christian 2014-07-30 13:57:01 UTC
(In reply to comment #8)
> Please note that I *ALWAYS* perform the "custom setup" of LibreOffice; I
> don't know if this option is ok using the standard setup.
We usually using default profile while triaging problem at first. So your cooperation will help dev to identify problem & make fix faster.
But it's ok since Adam has confirmed in comment 6.

Mark regression since many users confirm problem not exist in 4.2

Raising importance since it's a regression, affects many users, & core function

Updating summary to make it clearer

*) For other problems / request, please file new bug report (do searching first, perhaps someone has reported)
Comment 10 Tor Lillqvist 2014-07-30 14:02:10 UTC
I'll say it once again: The QuickStarter feature should be killed. I can't believe that people still are using it, and think that it is useful.
Comment 11 Adam 2014-07-30 14:15:53 UTC
(In reply to comment #10)
> I'll say it once again: The QuickStarter feature should be killed. I can't
> believe that people still are using it, and think that it is useful.

Not sure about Linux but in windows it is useful, i.e. allows you to start a new document quickly using right click on the system tray icon + it does speed up the startup significantly. I use it very frequently. Not sure why it is so hard to see why people use it? I think, it is good as an option which can be easily disabled.
Comment 12 Michael Stahl (CIB) 2014-07-30 14:22:19 UTC
IIRC the quick starter does not provide any performance benefit
over the built-in caching (SuperFetch) in Windows Vista and later
anyway, so only Windows XP users see a speed up from it; perhaps
given the lack of vendor support and declining market share
of Windows XP we should just remove the Windows quick starter?
Comment 13 Adam 2014-07-30 15:04:59 UTC
From user experience (mine at least) starting a new document using the right click on quickstart icon is the fastest and most convenient way to start a new document... and it does start faster on my computer. We are talking 0.5s against something like 1.5s-2s but there is a definite difference. Again this is only my experience not a proof against SuperFetch... even though you can find reports of this not always working in Win7 (which I use).
I would definitely miss a quickstart icon if it was to be removed but I cannot argue with programmers who seem to know better what is supposed to be useful and what not. I am sticking to 4.2 for the time being though. If an alternative can be provided which does the same thing (icon with menu on the system tray) I'll be happy to move on.
Comment 14 Dave Barton 2014-07-30 15:58:19 UTC
Personally I do not care if the "Quickstarter" option is removed or not, but since the "tray" icon is currently advertised and documented as a "feature" of the software, it should be made to function "as advertised".

Using Version: 4.3.0.4 Build ID: 62ad5818884a2fc2e5780dd45466868d41009ec0 on Windows 7 Ultimate x64 I have tested with both "modify" and "repair" for an existing installation and a new clean install. In all cases the "Start -> All Programs -> Startup" group includes "C:\Program Files (x86)\LibreOffice 4\program\quickstart.exe" and "Task Manager" shows "soffice.bin" and "soffice.exe" are running, but no "Quickstarter" icon ever appears in the "System Tray". In my "Control Panel -> Notification Area" LibreOffice is not listed as one of the options.

While I see this as either a bug/regression that needs to be fixed or a "feature" that needs to be removed, I question if it qualifies for MAB Bug 75025.
Comment 15 ign_christian 2014-07-30 17:13:46 UTC
(In reply to comment #14)
> While I see this as either a bug/regression that needs to be fixed or a
> "feature" that needs to be removed, I question if it qualifies for MAB Bug
> 75025.
You're right Dave. This issue still debatable, while personally at present I never use quickstarter either in Win7 or Ubuntu (just relied on launcher). Sorry..should not be in MAB.
Comment 16 Scott 2014-07-30 20:44:01 UTC
Confirmed on Win 7 x86 & x64

I think this ties in with Bug 80927
Comment 17 Massimo 2014-08-02 12:11:40 UTC
Confirmed on Win7 32 and 64 bit - 4.3.0.4. Every time I start LO the splash screen is shown.
See also https://bugs.freedesktop.org/show_bug.cgi?id=75767 : until 4.2, this bug affected only the first launch of LO. Now it affects every launch.
Comment 18 Julien Nabet 2014-08-09 05:01:23 UTC
*** Bug 82375 has been marked as a duplicate of this bug. ***
Comment 19 Richard 2014-08-10 14:58:19 UTC
I can confirm that this bug exists and is a regression.

I use the quickstarter everyday to launch my templates.

Will revert back to 4.2 until this is fixed.

O/S: W7 Ultimate
LO Version Version: 4.3.0.4
Comment 20 bugzilla2 2014-09-29 11:15:31 UTC
Quickstarter is disabled in current 4.3 builds due to a bug that leads to crashes. See Bug 80927 - Win: crash with Quickstarter enabled.

In 4.2 series the quickstarter works perfectly. Just enable it in preferences. The option in the installer only creates a shortcut in the system-autostart-folder, thus only generating a quickstart-icon when you log on to the system (which in most cases is enough, but if you want it immediately, you need to relog or enable it in preferences).
Comment 21 Andras Timar 2014-10-09 08:33:47 UTC

*** This bug has been marked as a duplicate of bug 80927 ***
Comment 22 Christian Lohmaier 2016-05-10 00:25:54 UTC
*** Bug 83176 has been marked as a duplicate of this bug. ***