Bug Hunting Session
Bug 80501 - Row Coloumn Indexes WRONG after: Select , Move - Undo by CRTL - Z
Summary: Row Coloumn Indexes WRONG after: Select , Move - Undo by CRTL - Z
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.0.0.beta1
Hardware: Other All
: high critical
Assignee: Kohei Yoshida
URL:
Whiteboard: target:4.4.0 target:4.3.1 target:4.2.7
Keywords: bibisected, regression
Depends on:
Blocks: mab4.2
  Show dependency treegraph
 
Reported: 2014-06-24 21:22 UTC by Karl
Modified: 2015-12-17 08:24 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
file to confirm big (61.53 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-06-24 21:22 UTC, Karl
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Karl 2014-06-24 21:22:34 UTC
Created attachment 101699 [details]
file to confirm big

The BUG occurs in Version 

LO 4.2.5.2
LO 4.3.0.1

THE BUG DOES NOT occur in OPEN OFFICE 3.4.1 (if for interest)

A simple spreadsheet is attached.

BEVOR repeat the "doin" read "Steps" to do. ( Simple orders, some Screenshots )
--sorry for my english--

regards 
jk
Comment 1 Faisal Menawer 2014-06-25 07:30:37 UTC
Confirmed with LibreOffice 4.2.5.2
But can't reproduce it with 4.2.4
Comment 2 ign_christian 2014-06-25 10:35:02 UTC
Also confirm same behavior with 4.2.5.2 - Ubuntu 12.04 x86

Not occured with 4.1.6.2

Step to reproduce:
1. Open attachment & see that cell M5 =G5-J5-K5
2. Move J5:J9 to J4:J8
3. Undo (Ctrl-Z)
4. See that cell M5 change to =G5-J6-K5

Raising importance since its regression in same 4.2 branch (confirmed by Faisal Menawer in previous comment) and dataloss.
Comment 3 ign_christian 2014-06-25 16:42:12 UTC
Perhaps related to fix in Bug 77944
Comment 4 Karl 2014-06-25 21:27:34 UTC
I might have to say:
Windows 7 x67 version ...

regards

thanx to them, that prooves my state.

to them at all, that corrects them.

for sure !
Comment 5 ign_christian 2014-06-30 15:07:23 UTC
(In reply to comment #2)
> 2. Move J5:J9 to J4:J8

Strange.. Bug can't be reproduced if J5:J9 move to left (I5:I9) or moved down (J6:J10)

Only reproduced if we moved above original cells (eg. J1:J5 or J4:J8)
Comment 6 Karl 2014-06-30 19:50:51 UTC
Yes,
I can commit this.

I tried to move to left or right too
the effect is even , if done "my way (the way i filed the bug).

I cant state, it doesnt happen any different way else.

BUT it happens the way I declared!

regards
Comment 7 ign_christian 2014-07-03 16:43:10 UTC
(In reply to comment #2)
> 4. See that cell M5 change to =G5-J6-K5
> 
> Raising importance since its regression in same 4.2 branch (confirmed by
> Faisal Menawer in previous comment) and dataloss.

Also broken in: 
- 4.2.4.2, but M5 change to =G5-J7-K5
- 4.2.0.0.beta1, but M5 change to =G5-J4-K5
- 4.3.0.2, same result (M5) as 4.2.5.2

Clarification: regression against 4.1.6.2
Comment 8 Karl 2014-07-05 12:07:47 UTC
still alive in 4.3.0.2
Comment 9 Joel Madero 2014-07-06 02:12:32 UTC
ba096f438393091574da98fe7b8e6b05182a8971 is the first bad commit
commit ba096f438393091574da98fe7b8e6b05182a8971
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Thu Oct 17 20:00:21 2013 +0000

    source-hash-8499e78ca03c792f4fa2650e02b519094ba0baa8
    
    commit 8499e78ca03c792f4fa2650e02b519094ba0baa8
    Author:     Caolán McNamara <caolanm@redhat.com>
    AuthorDate: Thu Jul 25 16:01:13 2013 +0100
    Commit:     Caolán McNamara <caolanm@redhat.com>
    CommitDate: Thu Jul 25 16:08:01 2013 +0100
    
        Related: fdo#61544 convert language page from box to grid
    
        grid compress better than boxes if there isn't enough available space
    
        Change-Id: I35b433b89a29159a33fc9edb646e46b371747a57

:100644 100644 28f5d06d73a1be6ffa14981fa5c85369334b42f3 69df816431adccb1d94d7239031fa72b51b69fd9 M	ccache.log
:100644 100644 e90dd416081e52bf1f529e5cc252b740762fb67f fb3eed5f2df90e38291b7693863d22a51ae5f909 M	commitmsg
:100644 100644 f3412ea896c81e0e5e7c7c5b20da51801f5732d1 b37aff13469762597fe8e71b9eec6543077c6320 M	dev-install.log
:100644 100644 20c900e22a8115c31e67f895acbe3ec11c432314 a6d96513f1e560f38ad6b20e13ae9c5ddb619132 M	make.log
:040000 040000 956ae0b2d085e2de7f912e234fe22cb51b2e3f29 14c94892e549a813ae539489d88273f18ad79631 M	opt


# bad: [423a84c4f7068853974887d98442bc2a2d0cc91b] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect start 'latest' 'oldest'
# good: [e02439a3d6297a1f5334fa558ddec5ef4212c574] source-hash-6b8393474974d2af7a2cb3c47b3d5c081b550bdb
git bisect good e02439a3d6297a1f5334fa558ddec5ef4212c574
# bad: [4850941efe43ae800be5c76e1102ab80ac2c085d] source-hash-980a6e552502f02f12c15bfb1c9f8e6269499f4b
git bisect bad 4850941efe43ae800be5c76e1102ab80ac2c085d
# skip: [a043626b542eb8314218d7439534dce2fc325304] source-hash-9379a922c07df3cdb7d567cc88dfaaa39ead3681
git bisect skip a043626b542eb8314218d7439534dce2fc325304
# skip: [aba65c3e4c0df07e4909aeefb758cdb688242bf6] source-hash-827524abfb4b577d08276fde40929a9adfb7ff1a
git bisect skip aba65c3e4c0df07e4909aeefb758cdb688242bf6
# bad: [c81a8a0dcfc1ed095a80e4485c89dd0fcaf73f31] source-hash-c69ed33628ec0b7abf6296539cf280d6c4265930
git bisect bad c81a8a0dcfc1ed095a80e4485c89dd0fcaf73f31
# bad: [1d4980621741d3050a5fe61b247c157d769988f2] source-hash-89d01a7d8028ddb765e02c116d202a2435894217
git bisect bad 1d4980621741d3050a5fe61b247c157d769988f2
# bad: [ba096f438393091574da98fe7b8e6b05182a8971] source-hash-8499e78ca03c792f4fa2650e02b519094ba0baa8
git bisect bad ba096f438393091574da98fe7b8e6b05182a8971
# good: [9daa289e178460daaafa4b3911031df5b8736218] source-hash-704292996a3731a61339b1a4a5c90c9403aa095f
git bisect good 9daa289e178460daaafa4b3911031df5b8736218
# good: [34eab3946c46bb7273ba4ca395db9c4421dd232f] source-hash-e962805b31074d6b6a2ed0db6452769448337553
git bisect good 34eab3946c46bb7273ba4ca395db9c4421dd232f
# good: [a8577b9049e085140768f97f7d4ff555a8a447cb] source-hash-98ded3e42011b060368899018c07cbd32e7993f1
git bisect good a8577b9049e085140768f97f7d4ff555a8a447cb
# good: [da4ad98ef394c644bb0aa80161ff599330862e7c] source-hash-570fe620e9d573cfc9fc260e6518563c6a6c1a3c
git bisect good da4ad98ef394c644bb0aa80161ff599330862e7c
# good: [2d9baecf3ce2ea1ec8bea3e842eed595061eeef6] source-hash-ff51a2b64571a8d72ff4d8a8181d17cf98c42e69
git bisect good 2d9baecf3ce2ea1ec8bea3e842eed595061eeef6
# first bad commit: [ba096f438393091574da98fe7b8e6b05182a8971] source-hash-8499e78ca03c792f4fa2650e02b519094ba0baa8
Comment 10 Karl 2014-07-21 12:05:52 UTC
IN LO 4.3.0.3

the "wrong" index is doubbled.
Comment 11 Karl 2014-07-21 12:11:10 UTC
instead of failure J5 is changed to J6,

J5 is changed to J7
Comment 12 Kohei Yoshida 2014-07-30 12:02:16 UTC
Look me look into this.
Comment 13 Kohei Yoshida 2014-07-30 15:14:48 UTC
Fixed on master, and backports to 4.2 and 4.3 are on the way.
Comment 14 Commit Notification 2014-07-30 16:02:25 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d0125712494ac0be512aa5e3fd7315e0cab2b323

fdo#80501: Write test for this first.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2014-07-30 16:02:43 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b2ee0235e88dc4da715b5766295ed88f27974fbd

fdo#80501: Ensure that we notify each listener only once.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2014-07-30 22:57:59 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ef32f401f27c394617df55114e912ffab3e6307a&h=libreoffice-4-3

fdo#80501: Ensure that we notify each listener only once.


It will be available in LibreOffice 4.3.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2014-08-13 08:51:26 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5f9e7ee1cc330f3b08596db0d13ad01e4dea7880&h=libreoffice-4-2

fdo#80501: Ensure that we notify each listener only once.


It will be available in LibreOffice 4.2.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 18 Karl 2014-08-16 04:21:47 UTC
SEEMS TO BE SOLVED in LO 4.3.1.1

(repeated the steps in bug.file)

regards karl
Comment 19 Robinson Tryon (qubit) 2015-12-17 08:24:21 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]