Bug 80536 - UI: Menu option for 'Edit File' toolbar entry
Summary: UI: Menu option for 'Edit File' toolbar entry
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: Jorendc
QA Contact:
URL:
Whiteboard: target:4.4.0
Keywords:
Depends on:
Blocks: Main-Menu
  Show dependency treegraph
 
Reported: 2014-06-25 20:51 UTC by Yousuf Philips (jay)
Modified: 2017-10-22 01:29 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) 2014-06-25 20:51:38 UTC
In the standard menu bar, you have the 'Edit File' button which turns edit mode on or read-only mode on, but there isnt a menu item for this functionality that i could find, as i believe it should be under the 'View' menu item. Tested on 4.2.5, 4.3.0 and master and confirmed its not available in 3.3.0.
Comment 1 Yousuf Philips (jay) 2014-06-26 05:03:38 UTC
After further consideration from bug 80538 comment 3, as there is a 'Edit' menu, it maybe more suitable to have it in that menu.
Comment 2 Yousuf Philips (jay) 2014-06-28 00:28:09 UTC
Quote by Mirek2 from bug 80538 comment 11 : "... and have an entry in the menubar as well (perhaps with a keyboard shortcut for quick access)"
Comment 3 Yousuf Philips (jay) 2014-07-10 22:41:09 UTC
I propose it be added to the bottom of the 'Edit' menu underneath a separator. Mirek2 suggested a shortcut key, so i'm suggesting ctrl+shift+e.
Comment 4 Jorendc 2014-07-10 23:24:08 UTC
Patch under review: https://gerrit.libreoffice.org/#/c/10211/
Assigning a shortcut result in odd behavior. You can go to 'non-editable mode', but you can't go back. That's the reason why I didn't add it yet.
Comment 5 Commit Notification 2014-07-21 08:26:08 UTC
Joren De Cuyper committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2420e776f728aee6171a8afe199ff84907152c39

fdo#80536 UI: Menu entry for 'Edit File' -> 'Edit Mode'



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Yousuf Philips (jay) 2014-07-21 21:06:57 UTC
Glad to see this has arrived in 4.4. Joren can you push a similar one into 4.3 but only with the xml modifications part, as the name change part will require translators to do more work and 4.3 is releasing soon.
Comment 7 Jorendc 2014-07-21 21:09:42 UTC
(In reply to comment #6)
> Glad to see this has arrived in 4.4. Joren can you push a similar one into
> 4.3 but only with the xml modifications part, as the name change part will
> require translators to do more work and 4.3 is releasing soon.

Hi Jay,

No I can't because there is a UI freeze. Due the fact a menu entry is part of the UI I may not push it.
Also 4.3.0.3 is the last RC before pushing. If no blockers are found in this RC3 build, it'll be released as the official 4.3.0 version (probably this week).
We should wait until 4.4 :-)

Kind regards,
Joren
Comment 8 Commit Notification 2014-09-21 13:09:55 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f5b24e71828fc6eb095fdd7167bdc8043525563d

fdo#80536 Add a shortcut to "Edit Mode" menu entry



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Adolfo Jayme 2014-10-05 02:30:20 UTC
I hate the vague wording: a casual user can’t immediatelly tell what “Edit Mode” does. Why isn’t it worded “Read-Only Mode” or something similar?
Comment 10 Yousuf Philips (jay) 2014-10-05 08:54:53 UTC
I do also prefer 'Read-Only Mode' over 'Edit Mode' for the menu item, but are you comfortable with that on the toolbar button toolip, as the two have the same label associated with them.
Comment 11 Mike §chinagl 2014-12-20 21:53:25 UTC
This bug fix comes with LibreOffice 4.4 (release notes https://wiki.documentfoundation.org/ReleaseNotes/4.4) 


LibreOffice will now display an infobar to indicate visibly when a document is being opened in read-only mode. This infobar replaces the “Edit file” icon in the main toolbar, as its labeling and usage patterns proved confusing for users. Activation and deactivation of read-only mode is also available from within the menu Edit ▸ Edit Mode or through the keyboard shortcut Ctrl+⇧ Shift+M.  

See a graphic of the work:
https://wiki.documentfoundation.org/File:Read-only_infobar.png
Comment 12 Milan Bouchet-Valat 2015-01-30 12:53:20 UTC
I've just discovered this feature in the Release Notes, and I must say it's a great improvement. Thanks you for this!