Bug Hunting Session
Bug 80670 - left arrow moves to previous cell when trying to edit
Summary: left arrow moves to previous cell when trying to edit
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: ux-advise (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-06-29 10:04 UTC by Todd
Modified: 2014-11-26 19:14 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Todd 2014-06-29 10:04:16 UTC
Hi All,

I am putting this down as an enhancement as I do not know if you guys did this on purpose or it is a bug and I want to be respectful of your time.

LibreOffice_4.2.5_Linux_x86-64_rpm.tar.gz

When I am in Calcm on a particular cell, inputting text and I see a misspelling, if I try to left arrow back to correct the typo, pressing left arrow sends me to the previous cell to the left.  Very annoying as left arrow in Writer just move the cursor one letter to the left.  And I write a lot in Writer -- it is a hand eye coordination thing.

Now, if I mouse to the typo, the left and the right arrows work as expected, even when I right arrow to the end of the text.  The left arrow will still move one letter to the left.  This "annoyance" only happens when your are inputting text for the first time.

To reproduce, 

1) open a new spreadsheet
2) go to cell A2.
3) input "now is the timne tfor al"
4) press the left arrow to try to correct the typos. You will wind up in cell A1
5) now mouse to the typos in A2. The left arrow will work as expected, even when you right arrow to the end of the line.

This drives me nuts!  Would you please correct it.

Many thanks,
-T
Comment 1 Cor Nouws 2014-06-29 11:08:20 UTC
Hi Todd,

In that situation you first need to hit F2.
Has always been like that and is necessary to allow normal use of the key board, where lef, right, tab etc. go to another cell.

Only idea maybe is to make an exception for the arrow key that goes back in the text that one types..

Gonna ask that at UX advise :)

Thanks for asking,
regards,
Cor
Comment 2 Jean-Baptiste Faure 2014-06-29 14:37:41 UTC
This behavior depends on the Calc configuration. To get the behavior you want you only have to do the following:
1/ menu Tools > Options > LibreOffice Calc > General
2/ uncheck "Press Enter to move selection"
3/ check "Press Enter to switch to edit mode"

Closing as WorksForMe

Best regards. JBF
Comment 3 Cor Nouws 2014-06-29 21:30:53 UTC
(In reply to comment #2)
> This behavior depends on the Calc configuration. To get the behavior you
> want you only have to do the following:
> 1/ menu Tools > Options > LibreOffice Calc > General
> 2/ uncheck "Press Enter to move selection"
> 3/ check "Press Enter to switch to edit mode"


For me that makes no difference JBF:
- place cursor on cell
- type fxoo
- arrow left (to go to x)
 > cell is left and text fxoo entered..
Independent from the setting you are pointing to...
Comment 4 Jean-Baptiste Faure 2014-06-30 04:02:53 UTC
(In reply to comment #3)
[...]
> For me that makes no difference JBF:
> - place cursor on cell
> - type fxoo
> - arrow left (to go to x)
>  > cell is left and text fxoo entered..
It works if you are in edit mode: type enter before left arrow or before typing the string in the cell.

The current behavior allows the user to fill several cells very fast without having to enter the edit mode. If the Enter key is configured to enter the edit mode you only have to hit this key to be able to navigate inside the cell with the arrow keys.

Best regards. JBF
Comment 5 Todd 2014-06-30 21:54:40 UTC
(In reply to comment #2)
> This behavior depends on the Calc configuration. To get the behavior you
> want you only have to do the following:
> 1/ menu Tools > Options > LibreOffice Calc > General
> 2/ uncheck "Press Enter to move selection"
> 3/ check "Press Enter to switch to edit mode"
> 
> Closing as WorksForMe
> 
> Best regards. JBF

Hi JBF,

  The "Enter" key and the "left arrow" key are two different keys.  This problem (bug) report is not related to the "enter" key.

  <shift><Tab> is, by overwhelming convention, the key(s) to press to go backwards one cell.  All other programs that I know of use the left arrow to go back one character to the left, including Libre Office Writer.

  Anyone trying to go backwards to correct a misspelling will go out of their minds with this issue.  Leaving this bug in place will only frustrate the user.  Users expect things to be intuitive and follow convention.  Users do not expect to have to mouse click in the line somewhere before the left arrow starts acting like a left arrow and not <shift><Tab>.

  Please fix this.

Many thanks,
-T
Comment 6 Jean-Baptiste Faure 2014-07-02 04:09:19 UTC
Restore NEEDINFO status instead of REOPENED because this bug report has never been confirmed.
For me there is no bug here.
Comment 7 Todd 2014-07-02 16:22:42 UTC
(In reply to comment #6)
> Restore NEEDINFO status instead of REOPENED because this bug report has
> never been confirmed.
> For me there is no bug here.

"Drives the user crazy" is probably not a bug, but would definitely come under an "enhancement request".

What NEEDINFO do you need?
Comment 8 Buovjaga 2014-11-25 08:46:35 UTC
Back to UNCONFIRMED.
Comment 9 V Stuart Foote 2014-11-25 14:20:11 UTC
No, confirm the correct normal behavior as in comment 2 and comment 3--user must exit from data entry mode and enter data edit mode.

During data entry the default keyboard cursor movement (L,R,U,D) is to reposition cell focus.

Simply put, an edit cursor is not available until one toggles from data **entry** mode into data **edit** mode using the <F2> key--or the <Enter> key if that option is set from Tools -> Options.

Stateful data entry is the norm for all spreadsheet programs I'm familiar with: AOO and OOo, Gnumeric, MS Excel, IBM Symphony. Have to check Apple's Numbers, but think there as well.

Will add to UX-advise/Design meeting agenda, but will recommend close wontfix--as this is a request for non-normative behavior.
Comment 10 Yousuf Philips (jay) (retired) 2014-11-26 17:30:35 UTC
I checked Excel 2010, WPS Spreadsheet, and Gnumeric and they acted in this same behaviour for quick addition of data.

Calligra Sheets goes into edit mode when you start typing data, so all the arrows do not work for changing cells and you press enter to finish the editing.

Quattro Pro acts the way the reporter wishes it to work, in that the left and right keys move backwards and forwards so that you can do editing and when the cursor reaches before or after the first or last character, pressing left or right again exits the cell.
Comment 11 Yousuf Philips (jay) (retired) 2014-11-26 17:57:33 UTC
iplaw confirmed that iWork Numbers works the same as LibO, except if you are in the first column of a sheet, where left does move the cursor back.
Comment 12 V Stuart Foote 2014-11-26 19:14:29 UTC
Per decision at UX-Advise and Design team mtg 2014-11-24 -- Resolved Wontfix