Bug 80671 - FILESAVE: MediaWiki exported footnotes appear in superscript tags
Summary: FILESAVE: MediaWiki exported footnotes appear in superscript tags
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: low minor
Assignee: Julien Nabet
URL:
Whiteboard: target:6.0.0 target:5.4.0.1 target:5.3.5
Keywords:
Depends on:
Blocks: MediaWiki
  Show dependency treegraph
 
Reported: 2014-06-29 10:10 UTC by steven
Modified: 2017-06-21 08:12 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Source Doc (31.00 KB, application/msword)
2014-07-06 13:35 UTC, steven
Details

Note You need to log in before you can comment on or make changes to this bug.
Description steven 2014-06-29 10:10:10 UTC
Except the numbering, footnote texts of WikiMedia is not <sup>**</sup>

The filter can not distinguish footnote numbering and footnote text.
Comment 1 Yousuf Philips (jay) 2014-07-06 03:16:13 UTC
Hello Steven,

I exported a footnote from 4.2.5 in Linux Mint using MediaWiki and here is the output i got.

-----------------------

Test 1<ref name="ftn0">Test 1</ref>

----
<references/>

-----------------------

If you have a document which shows the '<sup>**</sup>' result you mentioned, please supply it to us for testing.
Comment 2 steven 2014-07-06 13:35:53 UTC
Created attachment 102325 [details]
Source Doc

Hi Jay,

Thank you for your reply.

Please check attachment Doc., when I use Writer to open a Word (doc), then export to MediaWiki, footnote texts show "<sup>**</sup>".

Note: Docx no such issue.
Comment 3 Yousuf Philips (jay) 2014-07-06 18:18:12 UTC
Hello Steven,

I outputted your sample document as MediaWiki and here is the result.

-----------------------

== Test ==
This chapter focuses on '''claims,''' arguably the most important part of a patent. A patent claim is a precision-drafted, single-sentence definition of the patent owner’s right to exclude others.<ref name="ftn1"><sup>[1] Se''e'' Chapter 1 (“Foundations of the U.S. Patent System”), ''supra'', for further discussion of the nature of the exclusive right conveyed by a patent.</sup></ref> Every U.S. utility patent must conclude with one or more claims that particularly point out and distinctly claim the subject matter which the applicant regards as his invention.<ref name="ftn2"><sup>[2] 35 U.S.C. §112(b) (eff. Sept. 16, 2012).</sup></ref>




----
<references/>

-----------------------

Please paste what your output looks like. Please also let us know which linux distro you are running and which UI (user interface) language you are running in.
Comment 4 steven 2014-07-07 01:08:31 UTC
Hi Jay,

Thank you so much.

Only no "<sup>**</sup>" in the outputted footnote text, i.e.:

== Test ==
This chapter focuses on '''claims,''' arguably the most important part of a
patent. A patent claim is a precision-drafted, single-sentence definition of
the patent owner’s right to exclude others.<ref name="ftn1">[1] Se''e''
Chapter 1 (“Foundations of the U.S. Patent System”), ''supra'', for further
discussion of the nature of the exclusive right conveyed by a
patent.</ref> Every U.S. utility patent must conclude with one or more
claims that particularly point out and distinctly claim the subject matter
which the applicant regards as his invention.<ref name="ftn2">[2] 35
U.S.C. §112(b) (eff. Sept. 16, 2012).</ref>

Steven
Comment 5 Yousuf Philips (jay) 2014-07-07 01:55:39 UTC
Hi Steven,

Thanks for pointing that out. Yes superscript tags shouldnt be used in footnotes. Confirmed in 4.2.5 and master.
Comment 6 QA Administrators 2015-07-18 17:42:48 UTC Comment hidden (obsolete)
Comment 7 QA Administrators 2016-09-20 10:18:05 UTC Comment hidden (obsolete)
Comment 8 Julien Nabet 2017-06-11 19:59:25 UTC
I sent this patch to review for master:
https://gerrit.libreoffice.org/#/c/38666/
Comment 9 Commit Notification 2017-06-11 21:06:20 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6a24160894e91c007d4a2f8ef193eed670909ea5

tdf#80671: mediawiki, no superscript tags allowed in footnotes

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2017-06-12 07:04:00 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c7cfdaa7a43dbee4a2257d99a34a167ba9dcd1db&h=libreoffice-5-4

tdf#80671: mediawiki, no superscript tags allowed in footnotes

It will be available in 5.4.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2017-06-21 07:58:09 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1684ef2146dce6c132e3472b38b932d99f22b41c&h=libreoffice-5-3

tdf#80671: mediawiki, no superscript tags allowed in footnotes

It will be available in 5.3.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.