Bug Hunting Session
Bug 80742 - RTF import: All standard headings have base text outline level
Summary: RTF import: All standard headings have base text outline level
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:4.4.0 target:4.3.1
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-01 04:37 UTC by Alistair Leslie-Hughes
Modified: 2014-08-04 12:54 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Sample Document (893.97 KB, text/rft)
2014-07-01 04:37 UTC, Alistair Leslie-Hughes
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alistair Leslie-Hughes 2014-07-01 04:37:09 UTC
Created attachment 102046 [details]
Sample Document

The attached document displayed the TOC in previous versions but no longer is displayed.
Comment 1 Jorendc 2014-07-03 20:56:30 UTC
I can reproduce on Mac OSX 10.9 with LibreOffice 4.2.5.2

Looks fixed to me in LibreOffice Version: 4.4.0.0.alpha0+
Build ID: 4f90623dba6a211e7b4c9e98def91605627c5072
TinderBox: MacOSX-x86@49-TDF, Branch:master, Time: 2014-07-02_00:09:26

Also fixed in Version: 4.3.0.2
Build ID: 14ed55896fdfcb93ff437b85c4f3e1923d2b1409

So, lets mark it as RESOLVED WORKSFORME because we don't know what patch fixed this issue.

Kind regards,
Joren
Comment 2 Urmas 2014-07-05 18:23:15 UTC
Confirmed in master.
All standard headings have base text outline level.
Comment 3 Miklos Vajna 2014-08-02 13:02:42 UTC
Yes, because \outlinelevel is ignored in the tokenizer. I'll take care of this.
Comment 4 Commit Notification 2014-08-02 19:55:14 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c3657be928732f1b3b3b238f625de304a90a1ae1

fdo#80742 RTF filter: import RTF_OUTLINELEVEL



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Miklos Vajna 2014-08-04 12:38:48 UTC
libreoffice-4-3 backport: https://gerrit.libreoffice.org/10727
Comment 6 Commit Notification 2014-08-04 12:54:37 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6ce5eaf63f2bcc3f61abd20bbf84751c3ba4741e&h=libreoffice-4-3

fdo#80742 RTF filter: import RTF_OUTLINELEVEL


It will be available in LibreOffice 4.3.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.