Bug Hunting Session
Bug 80874 - EDITING: calc crashes on sort
Summary: EDITING: calc crashes on sort
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: All All
: high critical
Assignee: Deena Francis (ldcs.co.in)
URL:
Whiteboard: target:4.4.0 target:4.3.2 target:4.2.7
Keywords: haveBacktrace, possibleRegression
: 83249 83707 84400 84430 85205 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-07-03 21:18 UTC by Norbert Scheibner
Modified: 2015-12-15 22:12 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:


Attachments
Calc crashes while sorting by "Sortierhilfe", "Ort" and "Straße". (69.85 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-07-03 21:18 UTC, Norbert Scheibner
Details
backtrace log (21.88 KB, text/x-log)
2014-07-17 09:40 UTC, Jorendc
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Norbert Scheibner 2014-07-03 21:18:29 UTC
Created attachment 102220 [details]
Calc crashes while sorting by "Sortierhilfe", "Ort" and "Straße".

I know there are several reported bugs concerning sort. This could be another one.

I couldn't yet find out the correct circumstances under which calc crashes, but I can repeat the crash every time. I don't know if it depends on the formulas, the formatting or whatever.

Thats a actual file I use.
I sort the table by "Sortierhilfe", "Ort" and "Straße" to trigger the crash.   

So far I tested 4.2.5 an d 4.3.0.rc1

In 4.2.4 this file produced bug 74432.
Comment 1 Jorendc 2014-07-03 21:30:02 UTC
Reproducible, tested using Mac OSX 10.9 with LibreOffice Version: 4.4.0.0.alpha0+ Build ID: 4f90623dba6a211e7b4c9e98def91605627c5072
TinderBox: MacOSX-x86@49-TDF, Branch:master, Time: 2014-07-02_00:09:26

Kind regards,
Joren
Comment 2 Kevin Suo 2014-07-09 08:12:32 UTC
Hi Norbert,

Could you confirm whether this bug reproduce with 4.2.5.2? Someone reported another bug 81084, which is very similar description as yours, but that bug reporter reproduce with 4.2.5.2.

Thanks!
Comment 3 Norbert Scheibner 2014-07-09 14:11:06 UTC
Confirmed.
Comment 4 Kevin Suo 2014-07-17 09:34:44 UTC
Still crash with:
Version: 4.3.1.0.0+
Build ID: 5536b127a105123de6f64dcf8f53dfa277faef3c
TinderBox: Win-x86@42, Branch:libreoffice-4-3, Time: 2014-07-16_10:15:31
Windows XP SP3.
Comment 5 Jorendc 2014-07-17 09:40:10 UTC
Reproducible, tested using Linux Mint 17 x64 with LibreOffice Version: 4.4.0.0.alpha0+ Build ID: f4a2f1e647354efb75be8c90384d6cd3e5f9b9bd

I'll attach a backtrace (--enable-debug build).

Kind regards,
Joren
Comment 6 Jorendc 2014-07-17 09:40:25 UTC
Created attachment 102975 [details]
backtrace log
Comment 7 Björn Michaelsen 2014-08-21 12:21:11 UTC Comment hidden (obsolete)
Comment 8 Deena Francis (ldcs.co.in) 2014-08-24 20:18:42 UTC
I have submitted a patch to gerrit for review that seems to resolve this bug.
https://gerrit.libreoffice.org/#/c/11102/
Comment 9 Eike Rathke 2014-08-27 11:29:46 UTC
For completeness:

Deena Francis committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c25ac84688b596b9990d382d550f0514161b78c2

Resolves fdo#81084 fdo#81696 fdo#80874 fdo#81010 : sort causes crash



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Eike Rathke 2014-08-27 11:48:22 UTC
Deena Francis committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=719dd447ec1ab5ed0085b4f41cfd8e76fa835106&h=libreoffice-4-3

Resolves fdo#81084 fdo#81696 fdo#80874 fdo#81010 : sort causes crash


It will be available in LibreOffice 4.3.2.


It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3a04813fbf9824ae6cf651bab0c3f55cf36ea8fa&h=libreoffice-4-2

Resolves fdo#81084 fdo#81696 fdo#80874 fdo#81010 : sort causes crash


It will be available in LibreOffice 4.2.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 raal 2014-08-30 06:05:41 UTC
*** Bug 83249 has been marked as a duplicate of this bug. ***
Comment 12 Ken Biondi 2014-09-06 23:00:05 UTC
I verified this fix in the following three versions:


Version: 4.4.0.0.alpha0+
Build ID: 040a59e513b6435fb39bfecad9a54b3283216d0e
TinderBox: Win-x86@42, Branch:master, Time: 2014-09-04_23:21:24

Version: 4.2.7.0.0+
Build ID: fef72d750ea29dd3368f2e5f3099bb81e22ab07c
TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2014-09-05_17:30:54

Version: 4.3.2.0.0+
Build ID: 233e6a62d12d2d67089f1934777ac41c9fc88238
TinderBox: Win-x86@42, Branch:libreoffice-4-3, Time: 2014-09-05_11:10:36

I tested using WIN 8 x86_64.
Comment 13 Matthew Francis 2014-09-15 03:37:10 UTC
*** Bug 83707 has been marked as a duplicate of this bug. ***
Comment 14 Matthew Francis 2014-09-28 02:25:20 UTC
*** Bug 84400 has been marked as a duplicate of this bug. ***
Comment 15 raal 2014-09-28 19:26:09 UTC
*** Bug 84430 has been marked as a duplicate of this bug. ***
Comment 16 m.a.riosv 2014-10-19 22:55:58 UTC
*** Bug 85205 has been marked as a duplicate of this bug. ***
Comment 17 Robinson Tryon (qubit) 2015-12-15 22:12:58 UTC Comment hidden (obsolete)