Bug Hunting Session
Bug 80927 - Win: crash with Quickstarter enabled
Summary: Win: crash with Quickstarter enabled
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.3.0.0.beta1
Hardware: All Windows (All)
: highest critical
Assignee: Not Assigned
URL:
Whiteboard: BSA target:4.3.3 target:4.4.0
Keywords: bisected
: 80466 81905 82026 82381 82578 82810 83189 (view as bug list)
Depends on:
Blocks: mab4.3
  Show dependency treegraph
 
Reported: 2014-07-04 19:25 UTC by koenig.ralph
Modified: 2014-10-31 07:26 UTC (History)
23 users (show)

See Also:
Crash report or crash signature:


Attachments
WinDBG Result of LibO 4.3.0.4 beeing unresponsive with Quickstart enabled (267 bytes, text/plain)
2014-09-30 07:55 UTC, bugzilla2
Details
WinDBG Result of LibO 4.3.0.4 beeing unresponsive with Quickstart enabled (9.19 KB, text/plain)
2014-09-30 08:19 UTC, bugzilla2
Details
WinDBG Result of LibO 4.3.0.4 beeing unresponsive with Quickstart enabled (13.28 KB, text/plain)
2014-09-30 08:58 UTC, bugzilla2
Details
WinDBG Result of LibO 4.3.0.4 beeing unresponsive with Quickstart enabled (16.79 KB, text/plain)
2014-09-30 09:50 UTC, bugzilla2
Details

Note You need to log in before you can comment on or make changes to this bug.
Description koenig.ralph 2014-07-04 19:25:24 UTC
Problem description: 

Windows XP Pro SP3, LibreOffice 4.3.0.1 AND 4.3.0.2

Despite of updating an existing version (4.2.5.2) or a clean install, LibreOffice works normally until I enable Quickstarter. With Quickstarter enabled – no matter if I try to open a document or simply try to start LibreOffice Start Center – the software crashes with no visible error message. Instead, it pops-up an empty frame which can only be dismissed via Windows Task Manager.
Disabling Quickstarter allows LibreOffice to start again normally.

Steps to reproduce:
1. Start LibreOffice
2. Enable Quickstarter and close Libreoffice leaving Quickstarter running
3. Start LibreOffice again

Current behavior: LibreOffice runs only if Quickstarter is disabled

Expected behavior: LibreOffice running with Quickstarter enabled

              
Operating System: Windows XP
Version: 4.3.0.2 rc
Last worked in: 4.2.5.2 release
Comment 1 tommy27 2014-07-05 05:22:09 UTC
hi, a few questions:
1- did you experience the same issue in 4.3.0.1 as well?
2- which exact steps you do to activate quickstarter?
3- how did you disable quickstarter after the crash?
Comment 2 koenig.ralph 2014-07-05 09:40:44 UTC
Hi Tommy27,

1 - I did experience de same issue in version 4.3.0.1.

2 - To activate Quickstarter (because the option to activate during installation is ignored by the software):

  2.1 - Tools > Options > LibreOffice > Memory > Load LibreOffice during system start-up

3 - To disable I used the hardest way, I uninstalled the software and deleted all remaining traces by hand (folders, files and registry keys I was able to find) and then installed again. Probably I could simply erase the shortcut in my "Startup" folder, but I preferred do perform a clean install.
Comment 3 tommy27 2014-07-06 08:46:07 UTC
I do not reproduce it with LibO 4.3.0.2 under Win7x64
is there any other WinXP user who can test?
Comment 4 Claude 2014-07-08 15:32:41 UTC
I did experienced it with 4.3.0.2 in Windows 8.1 (64) environment.  Had to uninstall the software and start over with a clean setup.  I am not sure if I was able to have quickstarter installed with 4.3.0.1, but I´m pretty sure I had trouble with it, and may be I disabled it.  It definitely doesn.t work in the current release 4.3.0.2.  The same happens on a machine running Windows 7.

I use the spanish localized versión of LibreOffice.

By the way, if a new release is updated, the install option button does not have any effect on activating quickstarter.  It has to be setup from the Tools | options | Memory menú as koenig.ralph explains. 

This is happening since a long time ago, perhaps from versión 3.  On the other hand, a completely clean installation allows the activation of quickstarter right from the install options.
Comment 5 Kevin Suo 2014-07-09 08:58:13 UTC
Hi, I reproduce with Win XP SP3, LibreOffice 4.3.0.2.
Steps:
1. Enable Quickstarter (tools-options-memory-Load LibreOffice during system start-up)
2. Close libreoffice by clicking the "X" button. (program still running at backgound)
3. Start libreoffice again.
> It freezes at the start-up logo screen.

If you kill the libreoffice related process from system monitor, then LibreOffice can start up again, but if you close again you can not start it another time (you have to kill the process again to make it able to start.)

With this bug, quickstarter do not work at all.

Set to NEW.
Comment 6 Kevin Suo 2014-07-09 09:00:01 UTC
QuickStarter worked for me on windows in the previous versions, so REGRESSION.
Bibisectrequest.
Comment 7 tommy27 2014-07-09 09:01:58 UTC
do you have chance to test it over a Win7 machine?
Comment 8 Kevin Suo 2014-07-09 09:18:27 UTC
Tested and reproduced with LibreOffice 4.3.0.beta2, Windows 7 X86.
It's even worse, killing the process or resetting user profile do not work. The only way to make it start up again is to reisntall.
Comment 9 Kevin Suo 2014-07-09 09:21:37 UTC
Important info:
I have Apache OpenOffice installed along with libreoffice in my Win Xp machine;
and I have libreoffice 4.3.0.beta2 and 4.2.4.2 install in parrel in my Win7 machine.

Based on the following description on the release note page:
>For Windows users that have Apache OpenOffice installed, we advise uninstalling that beforehand. The two programs register the same file type associations and will conflict when the Quickstart feature is installed and enabled.

I think the crash has sth to do with the above (AOO and Parrel install)
Comment 10 tommy27 2014-07-09 09:24:06 UTC
good hint. i did not reproduce that issue on Win7x64 and I have no AOO installed.
Comment 11 Kevin Suo 2014-07-09 10:16:28 UTC
Oh wait...
I uninstalled other versions and only installed 4.3.0.2 on my win7 machine, still freezes....

@tommy27, will you try to start "LibreOffice" (rather than Writer, Calc, etc..) when you enabled quickstarter?
Comment 12 tommy27 2014-07-09 17:33:54 UTC
Hi, I ticked "Tools > Options > LibreOffice > Memory > Load LibreOffice during
 system start-up"

then closed LibO and relaunched it from the desktop icon shortcut.

no crash under Win7x64 with version 4.3.0.2 Build ID: 14ed55896fdfcb93ff437b85c4f3e1923d2b1409
Comment 13 Kiss-Kálmán Dániel 2014-07-14 08:09:11 UTC
Hi

on my win8.1 (64 bit) machine libre is working even quickstart is turned on, but it won't really start. I can't see it on my windows quicklanch bar even if I started writer. But I can use writer, calc, ...

But on my win8.1 32 bit if I turn quicklach on it freezes. write, calc won't start.

ps: you don't need to reinstall it again to use libre if you got that error, simply rename quickstart.exe
Comment 14 Kiss-Kálmán Dániel 2014-07-14 08:11:01 UTC
forgot to mention: 4.3.0.1 and 4.3.0.2
Comment 15 Joel Madero 2014-07-16 02:41:33 UTC
Removing BibisectRequest as this seems to be Windows only - if it's confirmed in Linux please add BibisectRequest again (CamelCase).
Comment 16 Kiss-Kálmán Dániel 2014-07-16 12:25:27 UTC
hi

can't reproduce the error on my linux 32 bit
Comment 17 Kiss-Kálmán Dániel 2014-07-17 09:50:55 UTC
4.3.0.2: the error still exists both on 32 and 64 bit win8.1
Comment 18 Kiss-Kálmán Dániel 2014-07-17 10:21:23 UTC
4.3.0.3: the error still exists both on 32 and 64 bit win8.1
Comment 19 Kiss-Kálmán Dániel 2014-07-27 16:50:28 UTC
libreoffice 4.3.x craches without AOO installed. Enabling QuickStart is enough to make libre crash.
Comment 20 Kiss-Kálmán Dániel 2014-07-28 07:37:13 UTC
4.3.0.4: the error still exists both on 32 and 64 bit win8.1
Comment 21 ign_christian 2014-07-30 08:31:08 UTC
*** Bug 81905 has been marked as a duplicate of this bug. ***
Comment 22 Scott 2014-07-30 18:44:10 UTC
Having Same issue:

32-bit System the problem causes LO to crash constantly when starting soffice.exe which is what runs when quickstart.exe is run. Can intermittently get soffice.exe and swriter.exe etc to run. 

64-bit System the problem is that I can run soffice.exe seemingly no problem but the quickstart utility doesn't show in the system tray.

Neither of these allows quickstart utility to run in the system tray.

Going back to 4.2.5 for now as these issues make 4.3 unusable.
Comment 23 Kiss-Kálmán Dániel 2014-07-30 19:41:11 UTC
"the version field of the bug should show the earliest version manifesting the bug"
Comment 24 Kiss-Kálmán Dániel 2014-07-30 20:12:24 UTC
4.3.0.0.beta1 is earlier but I'm too tired of changing it again....
Comment 25 Brian 2014-07-31 03:23:08 UTC
I am seeing the same behaviour with the release version 4.3.
Running Windows 8.1 x64
Comment 26 Kevin Suo 2014-07-31 09:55:36 UTC
One interesting thing I observed in WinXP, 4.3.0.4:

1. Enable quick starter;
2. Start "LibreOffice Writer/Calc/Impress...";

-> Freeze at libreoffice logo.

3. Kill all "soffice" related processes;
4. Start "LibreOffice" (Rather than "Writer/Calc/Impress)

-> The start center opens successfully. And you can start a component from start center with no problem now.

5. Now start any component from sytem application menu

-> Component started successfully.

(With this workaround, you dont need to reinstall libreoffice anymore, as discussed in comment 5.)

(Bad thing is that, there is no quick start systray shown at all the above steps.)
Comment 27 Chris Chambers 2014-08-01 04:37:27 UTC
Problem also exists on my Win 8.1 Update 1 system (with 4.3.0.4)
Comment 28 Kiss-Kálmán Dániel 2014-08-08 05:12:16 UTC
4.3.1.1: the error still exists both on 32 and 64 bit win8.1
Comment 29 Marcus 2014-08-08 06:07:45 UTC
Just another confirmation here: LibreOffice with enabled quickstart constantly crashes on Win 8.1 x64 with German locale.

Wasn't able to resolve this yet, but will report, if Kevin Suo's Workaround for XP works in 8.1, too.

As long as this isn't fixed, I propose hiding the quickstart option or marking it "experimental", so unexperienced users don't run into this problem.
Comment 30 Kiss-Kálmán Dániel 2014-08-08 07:54:58 UTC
If you rename or delete the quickstart.exe the option disappears from Memory menu.
Just like in the portable version
Comment 31 m.a.riosv 2014-08-09 10:16:38 UTC
*** Bug 82381 has been marked as a duplicate of this bug. ***
Comment 32 fanfan54 2014-08-10 07:49:56 UTC
(In reply to comment #31)
> *** Bug 82381 has been marked as a duplicate of this bug. ***

I confirm that LibreOffice works when the "Quickstarter" case is not checked at the installation setup.
Comment 33 Gibey 2014-08-11 17:53:10 UTC
Confirm crash with Quickstarter enabled on W7 SP1 with LO 4.3.0.4
Comment 34 sophie 2014-08-14 12:07:25 UTC
*** Bug 82578 has been marked as a duplicate of this bug. ***
Comment 35 sophie 2014-08-14 13:36:23 UTC
*** Bug 82026 has been marked as a duplicate of this bug. ***
Comment 36 Michael Meeks 2014-08-15 06:23:16 UTC
IIRC Andras was looking at something like this, but - he's on vacation until Monday I think ...
Comment 37 Andras Timar 2014-08-15 14:26:29 UTC
(In reply to comment #36)
> IIRC Andras was looking at something like this, but - he's on vacation until
> Monday I think ...

We have 2 patches in gerrit, I have no idea why they haven't been integrated.

https://gerrit.libreoffice.org/10669
https://gerrit.libreoffice.org/10817
Comment 38 Preben Hedegaard 2014-08-24 19:35:36 UTC
I can reproduce this bug in 4.3.0.4 Win7 x64.

It was not present from the time of installation, started after some time.

Now i can reproduce it on almost every start of both Quickstarter and single apps like writer.

On startup the program freezes for 6-8 minutes, and almost all other programs also freezes, in this period, not even CTRL+ALT+DELETE can't open the Windows joblist, until LibreOffice decies to un-freeze.
Comment 39 Preben Hedegaard 2014-08-24 22:18:29 UTC
(In reply to comment #38)
> I can reproduce this bug in 4.3.0.4 Win7 x64.
> 
> It was not present from the time of installation, started after some time.
> 
> Now i can reproduce it on almost every start of both Quickstarter and single
> apps like writer.
> 
> On startup the program freezes for 6-8 minutes, and almost all other
> programs also freezes, in this period, not even CTRL+ALT+DELETE can't open
> the Windows joblist, until LibreOffice decies to un-freeze.

UPDATE
I uninstalled 4.3.0.4 and then installed 4.3.1.1, that fixed the bug for me
Comment 40 Kiss-Kálmán Dániel 2014-08-25 07:17:36 UTC
(In reply to comment #39)
> (In reply to comment #38)
> > I can reproduce this bug in 4.3.0.4 Win7 x64.
> > 
> > It was not present from the time of installation, started after some time.
> > 
> > Now i can reproduce it on almost every start of both Quickstarter and single
> > apps like writer.
> > 
> > On startup the program freezes for 6-8 minutes, and almost all other
> > programs also freezes, in this period, not even CTRL+ALT+DELETE can't open
> > the Windows joblist, until LibreOffice decies to un-freeze.
> 
> UPDATE
> I uninstalled 4.3.0.4 and then installed 4.3.1.1, that fixed the bug for me

lucky you ;)

I tried but not for me ;(

can you see the icon on the systemtray?
Comment 41 Michael Meeks 2014-08-25 10:31:37 UTC
If someone can reproduce this with a debug build - it'd be fantastic to have a stack trace of where it has hung. Windbg should be able to get that for us.

Hacks to disable the quick-starter are all very well, but that's a useful feature, and we should get to the root cause here ASAP.
Comment 42 Kiss-Kálmán Dániel 2014-08-25 10:59:00 UTC
(In reply to comment #41)
> If someone can reproduce this with a debug build - it'd be fantastic to have
> a stack trace of where it has hung. Windbg should be able to get that for us.
> 
> Hacks to disable the quick-starter are all very well, but that's a useful
> feature, and we should get to the root cause here ASAP.

where can I find a "debug build"?
Comment 43 Kiss-Kálmán Dániel 2014-08-25 11:01:48 UTC
(In reply to comment #42)
> (In reply to comment #41)
> > If someone can reproduce this with a debug build - it'd be fantastic to have
> > a stack trace of where it has hung. Windbg should be able to get that for us.
> > 
> > Hacks to disable the quick-starter are all very well, but that's a useful
> > feature, and we should get to the root cause here ASAP.
> 
> where can I find a "debug build"?

https://wiki.documentfoundation.org/How_to_get_a_backtrace_with_WinDbg is what you mean?
Comment 44 Commit Notification 2014-08-25 11:06:03 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e10e1b06cbbf337e8277063651b6e48011df5fd4&h=libreoffice-4-3

fdo#80927 - quickstart causing trouble on windows, disable it


It will be available in LibreOffice 4.3.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 45 Marcus 2014-08-25 12:21:38 UTC
Kevin Suo's method killing the processes didn't work for me on Win 8.1 x64 so I had to rename quickstart.exe to make LO work again.

@Michael:
I would also like to help tracking down the original cause of the failing quickstarter to help return to functioning status.

As far as I can see, though, to get a stack trace using WinDbg I will need to run LibreOffice before I can select it to be tracked by WinDbg - since the crash appears during start-up, I'm not sure if this can work.
Is there any way to have WinDbg monitor a file/process during start-up?
Comment 46 Kiss-Kálmán Dániel 2014-08-25 13:21:58 UTC
 libo-43~2014-08-25_08.45.25 got the error. waiting the next build, thanks all the effort.
Comment 47 Commit Notification 2014-08-26 04:04:18 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-4-3-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2d32d70f646e04c28d44fabd9e77d56a812d2aec&h=libreoffice-4-3-1

fdo#80927 - quickstart causing trouble on windows, disable it


It will be available already in LibreOffice 4.3.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 48 Kiss-Kálmán Dániel 2014-08-26 12:50:17 UTC
just downloaded 2014-08-26_10.56.01
there is no quickstart.exe  and no option at all to turn it on (tools/option/memory)
Comment 49 tommy27 2014-08-26 12:57:23 UTC
yes, the quickstart option has been disabled in 4.3.1.

I don't know if that was a temporary measure until devs find a fix to enable it again or if the quickstart option has been definitively dropped off.
Comment 50 Kiss-Kálmán Dániel 2014-08-27 18:02:58 UTC
2014-08-27_08.14.09: quickstarter.exe is still missing
Comment 51 Joel Madero 2014-08-27 18:07:40 UTC
Yes - it is disabled until we resolve the crash - this was done on purpose
Comment 52 Andras Timar 2014-08-28 14:30:48 UTC
*** Bug 83189 has been marked as a duplicate of this bug. ***
Comment 53 Kiss-Kálmán Dániel 2014-08-28 14:50:57 UTC
2014-08-28_10.53.34: quickstarter.exe is still missing
Comment 51: "this was done on purpose"
Comment 54 gitzu 2014-08-28 23:53:03 UTC
LO 3.4.1.2 is so fast than I really don't miss quickstarter.
Congratulations guys...
Comment 55 bugzilla2 2014-09-29 10:44:04 UTC
Quickstart.exe still missing in 4.3.2 :(

Please don't even think about discontinuing the quickstarter completely, as it really speeds up opening LO dramatically. All those, who try to tell you, that it's not needed anymore due to superfetch (windows Vista and higher) are wrong. Just take a stopwatch and try it, before telling such things!

For me not having quickstart.exe is a complete showstopper, will revert back to 4.2.6_secfix.
Comment 56 Kiss-Kálmán Dániel 2014-09-29 11:02:48 UTC
Completely agree. We user atom PC-s, and we r missing quickstart. Now it take 3-4x more times to start libre. Hope see QS soon.
Comment 57 Michael Meeks 2014-09-29 11:37:24 UTC
Anyone that can get a stack trace of the quickstarter crash, with debugging symbols - would make a large contribution to having the bug fixed =)

Endless comments of the form "this feature is really important to me" combined with no activity at all around solving it are extremely counter-productive.
Comment 58 bugzilla2 2014-09-29 11:41:58 UTC
(In reply to comment #57)
> Anyone that can get a stack trace of the quickstarter crash, with debugging
> symbols - would make a large contribution to having the bug fixed =)

How can I make it crash, when its not available??? Any way to get the quickstarter back? Its not available at install. I already tried the Quickstart.exe of 4.2.6_Secfix, but this doesn't seem to work.
Comment 59 Joel Madero 2014-09-29 13:10:07 UTC
You can go back to the latest version that has the crash and then debug it. 

http://downloadarchive.documentfoundation.org/libreoffice/old/
Comment 60 Joel Madero 2014-09-29 13:13:30 UTC
(In reply to comment #55)
> Quickstart.exe still missing in 4.3.2 :(
> 
> Please don't even think about discontinuing the quickstarter completely, as
> it really speeds up opening LO dramatically. All those, who try to tell you,
> that it's not needed anymore due to superfetch (windows Vista and higher)
> are wrong. Just take a stopwatch and try it, before telling such things!
> 
> For me not having quickstart.exe is a complete showstopper, will revert back
> to 4.2.6_secfix.

As for comments like this - they really don't add anything to the bug report. If it's a show stopper please consider: (1) submitting a patch, (2) finding someone that you know to submit a patch, or (3) wait for a VOLUNTEER to accept fixing the issue. This is a community, saying "this is a showstopper" doesn't inspire anyone to give their time literally for free. For people who use these kinds of words, I truly hope that you join one of our teams (not necessarily dev team) and contribute back to the community that gives tens of thousands of hours at no charge.

If you're interested in QA (where we need more people quite bad) please contact me directly - it'll get you much further than going on bug reports and calling them "showstoppers"
Comment 61 bugzilla2 2014-09-30 07:55:25 UTC
Created attachment 107102 [details]
WinDBG Result of LibO 4.3.0.4 beeing unresponsive with Quickstart enabled
Comment 62 bugzilla2 2014-09-30 08:07:38 UTC
Good Morning :)
@Michael Meeks, Joel Madero and everyone else who felt me being "rude" or disrespectful yesterday: I'm very sorry, that my posts were received that way, that was not my intention. I absolutely have the highest respect of any LibO contributor and the spare-time many of them bring into the project.

As requested by Michael Meeks, I just uploadet a WinDbg Result (don't know if this is what's called a stack trace?). I hope a developer can see more information in it then me, because to me it seems its missing any vital information. Problem is, that actually LibO is NOT crashing, but unresponsive. It uses almost no CPU Cycles, so I guess its waiting for something that's not happening.

I also have memory dumps of soffice.bin (214MB) and soffice.exe (35MB) that were made with the hanging LibO. If this is of help to a developer, I can upload it to my ftp and share the URL with a developer over PM (don't want to make full memory-dumps public, due to privacy).
Comment 63 bugzilla2 2014-09-30 08:19:06 UTC
Created attachment 107105 [details]
WinDBG Result of LibO 4.3.0.4 beeing unresponsive with Quickstart enabled

WinDBG Result of LibO 4.3.0.4 beeing unresponsive with Quickstart enabled.
Comment 64 Michael Meeks 2014-09-30 08:48:25 UTC
Hi there; thanks so much for the trace :-)

> As requested by Michael Meeks, I just uploadet a WinDbg Result (don't know
> if this is what's called a stack trace?). I hope a developer can see
> more information in it then me, because to me it seems its missing any
> vital information.

So - this is tantelising =) you attached the debugger, got to the point that you could ask for a stack trace, and then continued ;-) you need to type:

~* k

At least I think so by reading: http://briolidz.wordpress.com/2013/11/17/windbg-some-debugging-commands/

Thanks !
Comment 65 bugzilla2 2014-09-30 08:58:55 UTC
Created attachment 107109 [details]
WinDBG Result of LibO 4.3.0.4 beeing unresponsive with Quickstart enabled

Hehe... I knew I wasn't done right. Thanks Michael for pointing me to the right command. File is updated...
Any more things I can read from WinDbg? Its still running ;)
Comment 66 bugzilla2 2014-09-30 09:50:21 UTC
Created attachment 107111 [details]
WinDBG Result of LibO 4.3.0.4 beeing unresponsive with Quickstart enabled

Another run. Forgot the symbol-server on the previous one :/
Comment 67 Joel Madero 2014-09-30 14:08:22 UTC
@buzilla2 - thanks for the kind words. I tend to default to what I said just because we literally hear it every day. If you go through the few thousand bugs, at least 1 in 10 have someone screaming "this is a blocker! Fix it now!" or some such thing and . .  . as you can imagine, it can become tiring/unmotivating/etc . . . reading it every day.

BTW the offer still stands for you to join QA ;) We could use people with your skills (people who can follow instructions, do debugs, and write polite messages). Let me know if you have literally any free time and I'll help onboard you.

That being said - thanks so much for going the extra step and helping us narrow down the problem. Moving this back to NEW

@Michael - should we somehow get those large files from bugzilla2?
Comment 68 bugzilla2 2014-09-30 14:17:32 UTC
> BTW the offer still stands for you to join QA ;) We could use people with
> your skills (people who can follow instructions, do debugs, and write polite
> messages). Let me know if you have literally any free time and I'll help
> onboard you.

@Joel Madero: Have you received my mail yesterday?
Comment 69 Andras Timar 2014-09-30 14:21:52 UTC
I started to work on this, I have everything I need (Windows, debugger, reproduced problem, etc.). Let's see, if I can get anywhere with it...
Comment 70 Joel Madero 2014-09-30 14:24:28 UTC
Thanks Andras - good luck :)
Comment 71 Andras Timar 2014-10-01 19:28:21 UTC
So far, I bisected the problem, and it went wrong at:

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a384b21cc40818bf3c918951a086a30b5d9d8022

sfx: Use constructor feature for ShutdownIcon.

At that time there were a lot commits like this, they looked like a mechanical conversions to me. Maybe this one contains a trivial error, that went in unnoticed. Maybe Stephan or Matus can see it quickly.

Before this commit the quickstart icon appeared in systray, after this it did not, I only saw soffice.bin and soffice.exe in task manager. I think it is the root of the problem, quickstart component is not initialized properly.
Comment 72 Matúš Kukan 2014-10-02 14:22:22 UTC
(In reply to Andras Timar from comment #71)
> So far, I bisected the problem, and it went wrong at:
> 
> http://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=a384b21cc40818bf3c918951a086a30b5d9d8022

Oh - great catch Andras, thanks!

So, yes, it's wrong and somehow got unnoticed.
I've tried to fix it in:
https://gerrit.libreoffice.org/#/c/11766
(ignore that CR: -1)

Could someone please verify if this works?
Then we could try to fix that unit test.
Comment 73 Andras Timar 2014-10-02 14:32:56 UTC
Matus, thanks for your patch! Now the QuickStart icon appears on the systray, the only problem with it that I get a crash dialog and LibreOffice restart, when I want to exit from it (right click on the systray icon, and select exit from the popup menu).
Comment 74 Andras Timar 2014-10-02 14:44:37 UTC
Maybe the crash is not related (and I'm testing libreoffice-4-3 not master).

(9ffbc.9eabc): C++ EH exception - code e06d7363 (first chance)
(9ffbc.9eabc): Access violation - code c0000005 (first chance)
First chance exceptions are reported before any exception handling.
This exception may be expected and handled.
vcllo!Timer::ImplTimerCallbackProc+0x5d:
693c001d 8b4a0c          mov     ecx,dword ptr [edx+0Ch] ds:002b:dddddde9=????????

    // find timer where the timer handler needs to be called
    pTimerData = pSVData->mpFirstTimerData;
    while ( pTimerData )
    {
        // If the timer is not new, was not deleted, and if it is not in the timeout handler, then
        // call the handler as soon as the time is up.
        if ( (pTimerData->mnTimerUpdate < pSVData->mnTimerUpdate) &&
/* CRASH HERE ->*/   !pTimerData->mbDelete && !pTimerData->mbInTimeout )
        {
            // time has expired
Comment 75 Andras Timar 2014-10-02 14:47:52 UTC
*** Bug 82810 has been marked as a duplicate of this bug. ***
Comment 76 Stephan Bergmann 2014-10-02 14:56:04 UTC
(In reply to Andras Timar from comment #74)
> Maybe the crash is not related (and I'm testing libreoffice-4-3 not master).

it most likely is, see my comment to <https://gerrit.libreoffice.org/#/c/11766/1>
Comment 77 Adolfo Jayme 2014-10-09 06:53:41 UTC
Matúš Kukan has committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=98bb53a5609f8651b0841e8326d7aa53fd56ab3b

fdo#80927: css.office.Quickstart should be single-instance service.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 78 Andras Timar 2014-10-09 08:33:47 UTC
*** Bug 80466 has been marked as a duplicate of this bug. ***
Comment 79 Kiss-Kálmán Dániel 2014-10-09 20:37:57 UTC
4.3.3.1 quickstart is working 

thanks Matúš and András and everyone
Comment 80 Andras Timar 2014-10-09 20:40:55 UTC
(In reply to Kiss-Kálmán Dániel from comment #79)
> 4.3.3.1 quickstart is working 
> 
> thanks Matúš and András and everyone

Credit is due to Stephan Bergmann in the first place. :)
Comment 81 bugzilla2 2014-10-10 08:54:38 UTC
Just testet in 4.3.4 DevBuild: Quickstart starts and exits correctly, and also any other Quickstart function seems to work perfectly :)

Many thanks to everyone involved in fixing this :)
Comment 82 tommy27 2014-10-10 11:06:17 UTC
great to hear that. 
this bug is a nice example of good workflow and teamwork between users, QA and developers. thumbs up for everybody!!!

I set status to VERIFIED.
Comment 83 Massimo 2014-10-31 06:00:48 UTC
Is this fixed in 4.3.3 or should I wait for 4.3.4? I am still on 4.2 branch because of this bug.
Comment 84 tommy27 2014-10-31 06:06:50 UTC
(In reply to Massimo from comment #83)
> Is this fixed in 4.3.3 or should I wait for 4.3.4? I am still on 4.2 branch
> because of this bug.

see the Whiteboard field: target:4.3.3 target:4.4.0

it means that the fix is already implemented in versions 4.3.3 and 4.4.0 so you can safely upgrade to 4.3.3
Comment 85 Massimo 2014-10-31 07:26:12 UTC
(In reply to tommy27 from comment #84)
> see the Whiteboard field: target:4.3.3 target:4.4.0
> 
> it means that the fix is already implemented in versions 4.3.3 and 4.4.0 so
> you can safely upgrade to 4.3.3

Thanks, it works perfectly!