Download it now!
Bug 80985 - FILESAVE: Saved DOCX File will Open in MSO 2010 with Calibri rather than Times New Roman And Style Properties are Lost (Locale: zh-CN)
Summary: FILESAVE: Saved DOCX File will Open in MSO 2010 with Calibri rather than Time...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.2 rc
Hardware: x86 (IA32) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard: interoperability
Keywords: filter:docx, regression
Depends on:
Blocks:
 
Reported: 2014-07-07 02:51 UTC by Kevin Suo
Modified: 2019-09-06 08:44 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
test docx file (19.51 KB, application/vnd.ms-word.document)
2014-07-07 02:51 UTC, Kevin Suo
Details
The test file when resaved with LibreOffice (10.28 KB, application/vnd.ms-word.document.12)
2014-07-07 02:53 UTC, Kevin Suo
Details
Screenshot: the re-saved file opened in MSO 2010 (82.33 KB, image/png)
2014-07-07 02:56 UTC, Kevin Suo
Details
New docx file created with LibreOffice (4.21 KB, application/vnd.ms-word.document.12)
2014-07-07 03:09 UTC, Kevin Suo
Details
Screenshot: the re-saved file opened in MSO 2010 (61.04 KB, image/png)
2014-07-07 06:59 UTC, Kevin Suo
Details
What it looks like for me with Win7 MSO 2013 (56.52 KB, image/png)
2014-07-07 07:11 UTC, Yousuf Philips (jay) (retired)
Details
Attachment 102339 open with MSO 2013 (25.99 KB, image/jpeg)
2014-07-07 07:19 UTC, Kevin Suo
Details
attachment 102338 saved with libreoffice 4.0.3 (Works OK) (5.86 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-07-07 08:18 UTC, Kevin Suo
Details
A test file with more style properties (underline, bold, italic...) (22.07 KB, application/vnd.ms-word.document.12)
2014-07-07 08:48 UTC, Kevin Suo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Suo 2014-07-07 02:51:16 UTC
Created attachment 102338 [details]
test docx file

During my daily work, I recieve many DOCX documents created by MSO. For most of these document, when I edit them with LibreOffice, when open again in MSO 2010 the fonts are changed.

Because the original file people send to me are not for public, I made the attached test file by deleting the original text and replaced with the test text.

Steps to reproduce:
1. Open the attached test file with Microsoft Office 2010, observe that the font is Times New Roman.
2. Open the test file with LibreOffice, ovserve that the font is also displayed as Times New Roman.
3. Hit an ENTER in the test file to make it modified, then save as "Times-libreoffice.docx".
4. Reopen the resaved file with MSO 2010. Observe that the font has changed to "Calibri (Western Body Text), and the font sizes becomes smaller.
5. Ropen the resaved file with LibreOffice, the font remains Times un-changed.

Expected Result:
Font family and size do not change at step 4.

This is really annoying, as it makes me impossible to interoperate with other people who uses MSO 2010.
Comment 1 Kevin Suo 2014-07-07 02:53:07 UTC
Created attachment 102339 [details]
The test file when resaved with LibreOffice
Comment 2 Kevin Suo 2014-07-07 02:56:53 UTC
Created attachment 102340 [details]
Screenshot: the re-saved file opened in MSO 2010

Screenshot showing how the resaved file looks like in MSO 2010
Comment 3 Kevin Suo 2014-07-07 03:08:38 UTC
Another easy steps to reproduce:
1. New Writer, type in some text;
2. Set the "Default Style": Western fonts to "Times New Roman 16pt".
3. Save as DOCX, then reopen with MSO 2010.

Currenty behaviour:
Font changed to Calibri 10.5 pt.
Comment 4 Kevin Suo 2014-07-07 03:09:40 UTC
Created attachment 102341 [details]
New docx file created with LibreOffice
Comment 5 Kevin Suo 2014-07-07 03:10:48 UTC
OS: Windows XP SP3,
LibreOffice 4.3.0.2, Build ID: 14ed55896fdfcb93ff437b85c4f3e1923d2b1409
Comment 6 Yousuf Philips (jay) (retired) 2014-07-07 03:38:36 UTC
Hey Suo,

I opened Times-libreoffice.docx in office 2007 SP3, 2010 SP2 and 2013 SP1 and they all showed fine as Times New Roman.
Comment 7 Kevin Suo 2014-07-07 06:45:01 UTC
@Jay Philips,
I installed the Office 2010 Service Pack 2, so now my MSO version is 14.0.7015.1000.

Unfortunately, when open attachment 102339 [details] the font is still Calibri 10pt.
Comment 8 Yousuf Philips (jay) (retired) 2014-07-07 06:53:44 UTC
Hey Suo,

Well maybe this is a Windows XP only glitch, but in attachment 102340 [details], i see Times New Roman in the font drop down.
Comment 9 Dominik 2014-07-07 06:56:05 UTC
windows 7, office 2010: the font displayed is times
Comment 10 Kevin Suo 2014-07-07 06:59:37 UTC
Created attachment 102347 [details]
Screenshot: the re-saved file opened in MSO 2010

(In reply to comment #8)

> but in attachment 102340 [details], i see Times New Roman in the font drop down.

Yes it worth mentioning. 
In MSO font shows Times New Roman in the drop down when I put cousor within a paragraph which has no content.
But when I put cousor within the paragraph with text, it shows Calibri.

See the new screenshot.
Comment 11 Dominik 2014-07-07 07:10:11 UTC
(In reply to comment #9)
> windows 7, office 2010: the font displayed is times

i've stepped the cursor throught all of the lines and in each line the font-dropdown showed times new roman
Comment 12 Yousuf Philips (jay) (retired) 2014-07-07 07:11:31 UTC
Created attachment 102349 [details]
What it looks like for me with Win7 MSO 2013
Comment 13 Yousuf Philips (jay) (retired) 2014-07-07 07:15:52 UTC
Dominik mentioned that times new roman should be easily distinguishable from calibri and from attachment 102340 [details], i can see that its not times new roman. :)
Comment 14 Kevin Suo 2014-07-07 07:19:28 UTC
Created attachment 102350 [details]
Attachment 102339 [details] open with MSO 2013

Someone in our Chinese QQ Chatroom can also confirm this with MSO 2013.
So this is not a MSO-2010-only issue.
Comment 15 Tom Bu 2014-07-07 07:21:26 UTC
I have been able to confirm this bug on Microsoft Word 2013 (15.0.4623.1000) x64 zh-CN provided with my Office 365 subscription.

Note: Apache OpenOffice 4.1.0 with JRE 8u5 enabled will behave exactly the same as LibreOffice 4.3.0.1
Comment 16 Tom Bu 2014-07-07 07:22:04 UTC Comment hidden (obsolete)
Comment 17 Tom Bu 2014-07-07 07:22:34 UTC Comment hidden (obsolete)
Comment 18 Tom Bu 2014-07-07 07:23:37 UTC
Sorry but it seems I commited the same thing 3 times
Comment 19 Kevin Suo 2014-07-07 08:18:42 UTC
Created attachment 102354 [details]
attachment 102338 [details] saved with libreoffice 4.0.3 (Works OK)

I do not reproduce with: 4.0.3 release.
The first version I can reproduce: 4.1.0.2 rc.

It's a regression. Revised Version accordingly.
Comment 20 Kevin Suo 2014-07-07 08:48:30 UTC
Created attachment 102356 [details]
A test file with more style properties (underline, bold, italic...)

It's even worse...
All "style" properties for the text are lost when reopen with MSO. (Direct formating are retained)
It's related to the MSO "style" and LibreOffice "style".

Steps:
Edit and resave this attached docx file with LibreOffice, 
Then reopen with MSO 2010 or 2013.

All style properties are lost, only the text are retaied and fall back to MSO default.
Comment 21 QA Administrators 2015-07-18 17:44:09 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-07-18
Comment 22 Luke 2015-07-25 02:48:18 UTC
Kevin, 
Why is this marked regression? What version of LO or AOO did this work correctly with?
Comment 23 Kevin Suo 2015-07-25 03:45:10 UTC
(In reply to Luke from comment #22)
See my comment in Comment 19.
It works fine in version 4.0.3 release.
The first version this bug appears (based on my test) is 4.1.0.2 rc.

By the way, this bug still exists in
Version: 5.0.0.3
Build ID: f79b5ba13f5e6cbad23f8038060e556217e66632
Locale: zh-CN (zh_CN)
Comment 24 Luke 2015-07-26 07:08:03 UTC
I cannot reproduce this with Locale: en-US (en_US)

We need to check other locales to see if this is specific to zh-CN.
Comment 25 Timur 2016-02-18 16:16:28 UTC
I also cannot reproduce with en-US LO and MSO.

Kevin, please change the title to sth. like "FILESAVE: Saved DOCX file will reopen in Chinese MSO with Calibri rather than Times New Roman"
Comment 26 Kevin Suo 2016-03-25 09:32:17 UTC
Seems fixed by commit (but I am not sure):
https://cgit.freedesktop.org/libreoffice/core/commit/?id=78284714b73a8307174c596295894e8f3951e09a
(The commit was meant to fix bug 96817 - but did not fix 96817 and that bug was reopened)

Do not reproduce in
Version: 5.1.2.1 (x64)
Build ID: 2603b69c5ec5981bb5f053f8ebfd1f3de00a4c29
CPU Threads: 2; OS Version: Windows 6.19; UI Render: default; 
Locale: zh-CN (zh_CN)

Mark this bug as WORKSFORME for now.