Bug Hunting Session
Bug 81009 - FORMATTING: Hatch lines as Watermark
Summary: FORMATTING: Hatch lines as Watermark
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: ux-advise (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-07 16:07 UTC by Ramon Tavarez
Modified: 2016-08-05 10:58 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ramon Tavarez 2014-07-07 16:07:14 UTC
Feature description: Hatch lines as Watermark

Steps to reproduce:
1. Define vertical and / or horizontal lines spacing
2. Define an angle for orientation
3. Define type of line
4. Define Color of line

Current behavior:  Not Available

Expected behavior: Use a hatch composed by lines as a watermark for documents

              
Operating System: All
Version: 4.4.0.0.alpha0+ Master
Comment 1 Joel Madero 2014-07-20 05:29:49 UTC
Can you provide a use case for this ? While we try to incorporate as many enhancement requests as possible, if the use case isn't functional for many users, adding to the code is just hard to justify.

Please provide a use case and then mark the bug as UNCONFIRMED. Thanks
Comment 2 Ramon Tavarez 2014-07-21 15:33:58 UTC
It can be used as background in technical reports that require simple
graphs, as details or dimensions, and which do not oblige the user to use a
CAD tool.

This enhancement could include a regular and scaling background that allows
a user to perform the graphics with the drawing of LibO tools or even by
hand after printing.

*Ramón E. Tavárez B.*


On Sun, Jul 20, 2014 at 1:29 AM, <bugzilla-daemon@freedesktop.org> wrote:

>  Joel Madero <jmadero.dev@gmail.com> changed bug 81009
> <https://bugs.freedesktop.org/show_bug.cgi?id=81009>
>  What Removed Added  Status UNCONFIRMED NEEDINFO  CC
> jmadero.dev@gmail.com  Ever confirmed   1
>
>  *Comment # 1 <https://bugs.freedesktop.org/show_bug.cgi?id=81009#c1> on
> bug 81009 <https://bugs.freedesktop.org/show_bug.cgi?id=81009> from Joel
> Madero <jmadero.dev@gmail.com> *
>
> Can you provide a use case for this ? While we try to incorporate as many
> enhancement requests as possible, if the use case isn't functional for many
> users, adding to the code is just hard to justify.
>
> Please provide a use case and then mark the bug as UNCONFIRMED. Thanks
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>
Comment 3 Buovjaga 2014-11-26 09:28:08 UTC
Should be UNCONFIRMED.
Comment 4 Robinson Tryon (qubit) 2014-12-22 03:24:13 UTC
One for UX.
Comment 5 Regina Henschel 2014-12-22 13:03:44 UTC
In all documents but spreadsheets you can fill the background with "hatching". For spreadsheets (and the other kind of documents too) you can use a tiny bitmap and tile it over the background. In addition you can create an image and use it in color mode "watermark". I do not see any benefit of an additional tool.

Ramon Tavarez, please go to forum or mailing list and discuss the ways currently already available. It is not clear from your description, what are the current shortcomings.
Comment 6 Heiko Tietze 2016-08-05 10:58:45 UTC
As Regina said go to Page > Background and select one of the predefined hatching (talking about Writer). So it WORKSFORME as designed.

(PS: this UI will be significantly improved in 5.3)