Download it now!
Bug 81044 - Importing XLS with HTML content puts an UTF-8 BOM in cell A1
Summary: Importing XLS with HTML content puts an UTF-8 BOM in cell A1
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: Other All
: medium normal
Assignee: David Tardon
URL:
Whiteboard: target:4.4.0 target:4.3.2
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-08 11:45 UTC by Gergely Rácz
Modified: 2014-08-12 08:26 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
UTF-8 BOM appears in cell A1 (123.19 KB, application/zip)
2014-07-08 11:45 UTC, Gergely Rácz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gergely Rácz 2014-07-08 11:45:22 UTC
Created attachment 102432 [details]
UTF-8 BOM appears in cell A1

I have a generated .xls file with HTML content (see attached file: test_gracz.xls).

Environment:
- OS: win7
- LibO: 4.2.5.2

Steps to reproduce:
1. Open the attached file (test_gracz.xls)
2. Choose one of the option (it is irrelevant) from the "Import option" pop up window.

Result:
Few random character is generated in cell A1.

Expected result:
LibO should import the file correctly.
Comment 1 Commit Notification 2014-07-10 14:37:19 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5eb408a3bb8df204452f0b931a254dad5f0cf35b

fdo#81044 detect UTF-8 BOM too



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 2 Julien Nabet 2014-08-04 20:10:40 UTC
*** Bug 77656 has been marked as a duplicate of this bug. ***
Comment 3 Commit Notification 2014-08-12 08:26:10 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=26a0f8b04f7d5ba8ee7e5f68e8379d152b03a2c7&h=libreoffice-4-3

fdo#81044 detect UTF-8 BOM too


It will be available in LibreOffice 4.3.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.