Download it now!
Bug 81111 - LODev 4.4 Calc crashes when you click on fx button
Summary: LODev 4.4 Calc crashes when you click on fx button
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: x86 (IA32) All
: medium critical
Assignee: Maxim Monastirsky
URL:
Whiteboard: target:4.4.0
Keywords: regression
Depends on:
Blocks:
 
Reported: 2014-07-09 14:29 UTC by Jacques Guilleron
Modified: 2015-03-05 15:14 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
linux backtrace (595 bytes, application/zip)
2014-07-16 15:50 UTC, Yousuf Philips (jay) (retired)
Details
backtrace run from 4.4 debug version (2.64 KB, text/plain)
2014-07-16 16:04 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jacques Guilleron 2014-07-09 14:29:09 UTC
Hi all,

Open a new spreadsheet
Click on fx button
Calc crashes with the following message :

LibreOfficeDev 4.4 – Fatal Error

file:///C:/Program%20Files%20(x86)/LibreOfficeDev%204/program/…/share/
config/soffice.cfg/formula/ui/formuladialog.ui


LO 4.4.0.0.alpha0+
Build ID: 714866927951e2b3ec858349449c9dfe181b1542
TinderBox: Win-x86@39, Branch:master, Time: 2014-07-06_00:19:58
Windows 7 Home Premium

regards,

Jacques
Comment 1 Jorendc 2014-07-16 11:41:19 UTC
Tested using Linux Mint 17 x64 with LibreOffice Version: 4.4.0.0.alpha0+
Build ID: 5bd241b99b76ae7f4b3c1d4f2bcbaf7c487bb339

I can not reproduce this behavior.
@Jacques: you mind retesting using a newer build of LibreOffice 4.4?

Kind regards,
Joren
Comment 2 Jacques Guilleron 2014-07-16 13:44:47 UTC
Hello Joren,

Happens also 
with LO 4.4.0.0.alpha0+
Build ID: b023565d4f064cd0312e8c1fcc23a9f552112935
TinderBox: Win-x86@39, Branch:master, Time: 2014-07-10_01:55:29

and LO 4.4.0.0.alpha0+
Build ID: abc28ffc04067eb24840fbf564c311aaee10f84d
TinderBox: Win-x86@39, Branch:master, Time: 2014-07-15_07:18:40

All versions installed on a fresh profile under Windoàws 7 Home Premium

regards,

Jacques
Comment 3 sophie 2014-07-16 15:12:36 UTC
Hi, confirmed and also when calling function wizard with Insert > Function. 
Version: 4.4.0.0.alpha0+
Build ID: 3fdd4f069d5436cf39708004af7fda8175fbc4c2
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2014-07-09_02:51:53 Sophie
Comment 4 Jorendc 2014-07-16 15:43:51 UTC
This is probably an UI issue.
Dialog is converted by http://cgit.freedesktop.org/libreoffice/core/commit/?id=0cf14968aacfbf2e51f884242a1c243a645cb7fc
Not sure what is happening or missing, but looks like it affects only tinderbox builds.

Marking as NEW due the fact Sophie did confirm it.

Kind regards,
Joren
Comment 5 Yousuf Philips (jay) (retired) 2014-07-16 15:50:58 UTC
Created attachment 102926 [details]
linux backtrace

Confirmed on master in Linux Mint. Same version as sophie.
Comment 6 Yousuf Philips (jay) (retired) 2014-07-16 15:51:38 UTC
Confirmed it doesnt happen in 4.3.1.
Comment 7 Jorendc 2014-07-16 15:53:18 UTC
Comment on attachment 102926 [details]
linux backtrace

Sadly this is an invalid backtrace
Comment 8 Yousuf Philips (jay) (retired) 2014-07-16 16:04:01 UTC
Created attachment 102927 [details]
backtrace run from 4.4 debug version
Comment 9 Jorendc 2014-07-16 16:08:05 UTC
Comment on attachment 102927 [details]
backtrace run from 4.4 debug version

:( still no valid backtrace. I'm currently building with --enable-debug .
I hope I can confirm the bug and if so pull a crashlog out of it.
Comment 10 Yousuf Philips (jay) (retired) 2014-07-16 16:40:31 UTC
From some more investigation, i think its not crashing, but it simply exits. I also was checking the path and there is no formula folder underneath ./share/
config/soffice.cfg and i couldnt find any formuladialog.ui in the subdirectories. This is the same in 4.3.
Comment 11 Jacques Guilleron 2014-07-16 16:56:09 UTC
Some complements :
 
First version of LO 4.4 was already affected. 
Verified with LO 4.4.0.0.alpha0+
Build ID: 4776da791f69fa14104f054923be25618c297398
TinderBox: Win-x86@39, Branch:master, Time: 2014-07-02_05:48:59

No problem for LO 4.2.7.0.0+
Build ID: 92216be6ce13990b8ea6b6264c656d2bc1746401
TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2014-07-14_16:21:42

with hope this help,

Jacques
Comment 12 Maxim Monastirsky 2014-07-16 21:14:44 UTC
(In reply to comment #4)
> Dialog is converted by
> http://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=0cf14968aacfbf2e51f884242a1c243a645cb7fc
> Not sure what is happening or missing
This commit is missing the scp2 stuff, so the formuladialog.ui file is copied to instdir but not to the msi/deb/rpm/whatever package.
Comment 13 Maxim Monastirsky 2014-07-17 09:09:39 UTC
I submitted the patch to gerrit, so someone who is more familiar with scp2 could review this.

https://gerrit.libreoffice.org/10365/
Comment 14 Commit Notification 2014-07-17 10:07:25 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b875362cd576b29aee4da899335b8d8f6c74d192

fdo#81111 Package formula ui files



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 15 Jacques Guilleron 2014-07-18 12:54:07 UTC
Works as expected with LO 4.4.0.0.alpha0+
Build ID: eddd7646d672ea9b0561dacb09da224d098e531e
TinderBox: Win-x86@39, Branch:master, Time: 2014-07-18_06:42:50
under Windows 7 Home Premium.
Thank you Maxim,

regards,

jacques