Bug 81293 - The dialog “manage names” forgets size and column width settings
Summary: The dialog “manage names” forgets size and column width settings
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: target:7.4.0
Keywords:
Depends on:
Blocks: Dialog Cell-Name
  Show dependency treegraph
 
Reported: 2014-07-13 13:46 UTC by Albrecht Müller
Modified: 2022-08-09 16:53 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file to show the effect. (74.42 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-07-13 13:46 UTC, Albrecht Müller
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Albrecht Müller 2014-07-13 13:46:01 UTC
Created attachment 102701 [details]
Example file to show the effect.

How to reproduce:
Press CTRL+F3 to open the “manage names” dialog box. Change the size of the  dialog or the width of some columns. Close the dialog. Press CTRL+F3 again. The appearance of the dialog is the same as when it was opened the first time.

Expected behaviour:
When opening the dialog again, its appearance should be the same as when it was closed. Maybe these settings should become part of the spreadsheet as the appropriate size settings depend on the specific names used in the document and thus should persist over closing and reopening Calc.

Reason: The default size may be inadequate for working with the names in the document. Partly due to other problems (e.g. content of input line disappears, see bug 81291) opening and closing this dialog can occur quite often, and it is quite annoying that each time you open the dialog you have to rearrange columns and dialog size before you can do anything useful.
Comment 1 Jean-Baptiste Faure 2014-07-19 21:12:34 UTC
Valid enhancement request. Set status to NEW.

Best regards. JBF
Comment 2 russell 2018-03-28 04:10:38 UTC
This bug report might be related to this enhancement request. They both deal
with sizing/resizing the Manage Names dialog.

UI: dialog Manage Names loses set individual size when Range Options is chosen
https://bugs.documentfoundation.org/show_bug.cgi?id=99991
Comment 3 BogdanB 2021-12-03 14:44:13 UTC
The same. Retested in
Version: 7.3.0.0.beta1+ (x64) / LibreOffice Community
Build ID: 8c137ff0e201c2d0ecd1bb567496dbed8e5eced7
CPU threads: 4; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: ro-RO (ro_RO); UI: en-US
Calc: threaded
Comment 4 Commit Notification 2022-06-08 06:41:35 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/bf29483599c67cebfe0c3e06d063d3ae233b28dc

tdf#81293 dialog “manage names” forgets size and column width settings

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 BogdanB 2022-08-09 16:53:16 UTC
Solved.
Verified with
Version: 7.4.0.1.0+ / LibreOffice Community
Build ID: 4b4773183e92be941b24fffdfd16a554c6a35439
CPU threads: 16; OS: Linux 5.15; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded