Bug Hunting Session
Bug 81423 - FILESAVE: Links to external pictures broken after export to PDF
Summary: FILESAVE: Links to external pictures broken after export to PDF
Status: RESOLVED DUPLICATE of bug 80849
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: x86 (IA32) Linux (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-16 10:19 UTC by marc.bristiel
Modified: 2015-03-05 16:32 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
A tar archive containing files to show the bug (230.00 KB, application/x-tar)
2014-07-16 23:19 UTC, marc.bristiel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description marc.bristiel 2014-07-16 10:19:48 UTC
Problem description: for a presentation (odp), after doing an export to PDF, if you save again the odp file, links to external pictures are broken.

The probleme is that, in the content.xml file, a link wich was, for example :

<draw:image xlink:href="../images/exemple.xpm"
xlink:type="simple" xlink:show="embed" xlink:actuate="onLoad">
<text:p/></draw:image>

is replaaced by :

<draw:image xlink:href="../images/exemple.xpm%3FrequestedName=exemple"
xlink:type="simple" xlink:show="embed" xlink:actuate="onLoad">
<text:p/></draw:image>


The "%3FrequestedName=exemple" added to the name of the file seems to prevent the program to find the file.


Steps to reproduce:
1. Lauch a new presentation
2. Save the odp file by "save as ..."
3. Insert a picture "as a link" and, yes, preserve the link.
4. Save the file.
5. Export as PDF to somewhere.
6. Move the picture.
7. Save the odp file.
8. Close Libreoffice.
9. Open the odp file again.
10. See what happens.

Current behavior: links to external pictures are broken an then file doesn't open correctly anymore.

Expected behavior: links should work and file show the linked images.

              
Operating System: Ubuntu
Version: 4.2.5.2 release
Comment 1 ign_christian 2014-07-16 15:32:20 UTC
Not reproducible under LO 4.2.5.2 - Ubuntu 12.04 x86

Tried several times with an .svg image, no problem with the odp after filesave. Link also still preserved in content.xml.

Perhaps only with .xpm image?
Comment 2 marc.bristiel 2014-07-16 15:49:45 UTC
Additional tests: the bug is present with jpg, xpm, and png files, but not with svg files.
Comment 3 ign_christian 2014-07-16 16:12:10 UTC
Em..still can't reproduce with .png

Have you tried resetting user profile?
Comment 4 marc.bristiel 2014-07-16 23:08:45 UTC
I have tested on some other computers, one under Ubuntu 14.04, the other one in a Virtualbox hosting Ubuntu 12.04.
Each time I purged ~/.config/libreoffice (~/.libreoffice not present) .

The bug is present in all cases.

I forgot to mention before that those test have been made with fr and oc languages packages.
Comment 5 marc.bristiel 2014-07-16 23:19:58 UTC
Created attachment 102948 [details]
A tar archive containing files to show the bug

This archive contains a folder with the files showing the bug.

* file1.odp : the final file
* file1_after_pdf_export.odp : the same as file1.odp, containing the corrupted link
* file1_before_pdf_export.odp : the file uncorrupted, before the PDF export and file change
* file1.pdf : the result of pdf export ...
* libreoffice-banner.png : the picture !
Comment 6 ign_christian 2014-07-18 08:25:50 UTC
(In reply to comment #4)
> I forgot to mention before that those test have been made with fr and oc
> languages packages.
Perhaps it could be the trigger since I'm using standard English package. 
Could you try an en-US package or change the languange to English?

And 1 more thing Marc..please see Bug 80849 which is derived from Bug 46447. Looks like content.xml modified (somewhat) the same way as this bug report.

Could you try turning off autosave as suggested here in the following link?
https://bugs.freedesktop.org/show_bug.cgi?id=46447#c85

Possibly your report is a dupe to Bug 80849
Comment 7 ign_christian 2014-07-18 10:31:00 UTC
Hi Marc, please check: https://bugs.freedesktop.org/show_bug.cgi?id=80849#c2

If you agree that your problem is the same, please mark your report as duplicate to Bug 80849 since that reported before your report.
Comment 8 marc.bristiel 2014-07-18 10:47:36 UTC
Tested with only english packages, bug still present.

Yes, it seems that it is a duplicate of Bug 80849, but I reproduced it even auto-save de-activated.
Comment 9 marc.bristiel 2014-07-18 10:48:49 UTC

*** This bug has been marked as a duplicate of bug 80849 ***
Comment 10 ign_christian 2014-07-18 11:00:07 UTC
(In reply to comment #8)
> Yes, it seems that it is a duplicate of Bug 80849, but I reproduced it even
> auto-save de-activated.
Marc..perhaps it's different problem if you can reproduce with auto save deactivated.

Please reopen this bug if you find the trigger or you still can reproduce if Bug 80849 fixed.