Bug Hunting Session
Bug 81443 - EDITING: Cannot delete pages
Summary: EDITING: Cannot delete pages
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Writer-Styles-Page
  Show dependency treegraph
 
Reported: 2014-07-16 21:04 UTC by backlash6709
Modified: 2019-02-09 20:05 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of document with inserted blank page & incorrect page count (105.62 KB, image/jpeg)
2014-07-16 21:04 UTC, backlash6709
Details
Demonstration of undeletable pages (1.77 MB, video/mp4)
2014-12-10 22:13 UTC, Mike
Details

Note You need to log in before you can comment on or make changes to this bug.
Description backlash6709 2014-07-16 21:04:41 UTC
Created attachment 102943 [details]
Screenshot of document with inserted blank page & incorrect page count

Problem description: The application inserted a page on it's own. I tried to delete the page it inserted before my document but the page won't delete. It also won't backspace so I can delete anything before the beginning of my document. I want the 1st blank page the software inserted to be deleted. 

I addition, it shows 3 pages as the total page count but with the inserted blank page the total pages is 2 not 3


              
Operating System: Windows (other)
Version: 4.2.5.2 release
Comment 1 tommy27 2014-07-17 04:41:07 UTC
thanks 4 screenshot but we need the original file to reproduce and debug.
please upload it here clicking on "add ad attachment"
Comment 2 Jorendc 2014-07-17 09:46:50 UTC
On your screenshot I do see a blue-line above the second page, which indicates there is a page-break between page 1 and 2. What if you hover-over this blue line (page-break) and delete it using the popup-context menu?

Kind regards,
Joren
Comment 3 Mike 2014-12-10 22:12:11 UTC
This is a reproducible problem for me.

1. In Draw, make a page-sized rectangle and anchor it to the page.
3. Open a new Writer doc and use manual breaks to make it three-page doc.
3. Copy the Draw object from the first doc to the second's page 3.
4. Switch the Writer view to 2 rows/2 columns.
5. Move the Draw object right as if to make it a fourth page. You'd never do this, of course, but this is a simulation of where my Draw object arbitrarily pastes itself sometimes. That's a different problem!
6. Try to delete pages 2 and 3. You can't.
7. Delete the hidden graphic and everything is okay.

In step 6, pages 2 and 3 are still "there" because the anchored object forces page 3 to exist. But I find this problematic. First, because it's not what I expect. I expect that if I anchor something to, say, page 5, it'll subsequently get re-anchored to page 4 if I delete page 1, 2, 3, or 4.

Second, sometimes get hidden, and so you can't see it to delete it. I wrestled with this earlier for a good half hour because the object was totally invisible. I found it accidentally clicking in the blank space in the row/column view. This has happened to me a few times before, but I just discovered the reason today.

I'll attach a <1 min video to demonstrate the problem.
Comment 4 Mike 2014-12-10 22:13:59 UTC
Created attachment 110701 [details]
Demonstration of undeletable pages
Comment 5 Mike 2014-12-10 22:15:12 UTC
Comment on attachment 110701 [details]
Demonstration of undeletable pages

I forgot to mention that this is in LO 4.3.4.1.
Comment 6 Mike 2014-12-10 22:16:20 UTC
I accidentally said "Draw" in step 1. I meant "Writer".
Comment 7 tommy27 2014-12-11 07:21:22 UTC
(In reply to Mike from comment #3)
> This is a reproducible problem for me.
> 
> ...

Ok, status NEW since there's an independent confirmation.
Comment 8 tommy27 2016-04-16 07:25:25 UTC Comment hidden (obsolete)
Comment 9 QA Administrators 2017-05-22 13:26:58 UTC Comment hidden (obsolete)
Comment 10 Roman Kuznetsov 2019-02-09 20:05:53 UTC
It's not a bug for me as for description as for Comment 3

1. I see on the screenshot a page break and I can assume that page style has active option "Page layout": Only left. In this case Writer adds empty page before first page itself. It needs just set up page style right.

2. Comment 3 isn't a bug too. Because drawn items with anchoring to page can't be deletes uses keyboard. It's expected behavior (and it's another problem in general). You can to delete drawn items uses Delete key only if it will be anchoring "As symbol"

ps: and we don't have the example file for testing...

Status-> NOTABUG