Download it now!
Bug 81496 - FORMATTING: Crash in Format Page
Summary: FORMATTING: Crash in Format Page
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard: BSA target:4.4.0
Keywords: haveBacktrace
: 81756 82974 84075 (view as bug list)
Depends on:
Blocks: mab4.4
  Show dependency treegraph
 
Reported: 2014-07-18 13:26 UTC by Owen Genat (retired)
Modified: 2014-10-16 08:12 UTC (History)
12 users (show)

See Also:
Crash report or crash signature:


Attachments
Non-debug backtrace for v4.4.0.0alpha+ 2014-07-09. (16.87 KB, text/x-log)
2014-07-18 13:26 UTC, Owen Genat (retired)
Details
bt console from master sources (10.99 KB, text/plain)
2014-07-20 10:23 UTC, Julien Nabet
Details
full bt (43.46 KB, text/plain)
2014-07-20 10:25 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Genat (retired) 2014-07-18 13:26:43 UTC
Created attachment 103041 [details]
Non-debug backtrace for v4.4.0.0alpha+ 2014-07-09.

Problem description: Attachment 97485 [details] from bug 77548 causes Calc to crash when I attempt to edit the page style PageStyle_Ark1 using the current alpha build (x86_64 deb v4.4.0.0 from 2014-07-09).

Steps to reproduce:
1. Open XLS.
2. Select Styles & formatting panel in the sidebar.
3. Select Page Styles.
4. Right-click on PageStyle_Ark1 page style entry > Modify...

Current behavior:
Calc crashes.

Expected behavior:
Page style dialog is displayed.

Works under Debian 7 x86_64 v4.3.0.2 Build ID: 14ed55896fdfcb93ff437b85c4f3e1923d2b1409. 
Crashes under Crunchbang 11 x86_64 v4.4.0.0.alpha0+ Build ID: 3fdd4f069d5436cf39708004af7fda8175fbc4c2 (2014-07-09).
Operating System: Debian
Version: 4.4.0.0.alpha0+ Master
Comment 1 Julien Nabet 2014-07-20 10:23:56 UTC
Created attachment 103133 [details]
bt console from master sources

On pc Debian x86-64 with master sources updated today, I could reproduce the problem.
Comment 2 Julien Nabet 2014-07-20 10:25:19 UTC
Created attachment 103134 [details]
full bt

Just if it can help to have even more information in bt.
Comment 3 Julien Nabet 2014-07-20 10:27:56 UTC
Kohei/Markus/Eike/Miklos: Calc/xls conversion pb, any idea?
Comment 4 Eike Rathke 2014-07-21 10:44:56 UTC
I suspect http://cgit.freedesktop.org/libreoffice/core/commit/?id=1ca7ac128dcdf03e3749af7458beac8d2da8a708 "fdo#38513 - Accelerate non-poolable item add / remove." to be the culprit but didn't verify / revert to test.
Comment 5 Eike Rathke 2014-08-22 12:07:47 UTC
Actually not, it's since http://cgit.freedesktop.org/libreoffice/core/commit/?id=7d9bb549d498d6beed2c4050c402d09643febdfa and a general crash of Format Page.
See also bug 81756#c9
Comment 6 Eike Rathke 2014-08-22 12:08:20 UTC
*** Bug 81756 has been marked as a duplicate of this bug. ***
Comment 7 raal 2014-08-23 07:51:14 UTC
*** Bug 82974 has been marked as a duplicate of this bug. ***
Comment 8 Douglas Mencken 2014-08-23 09:31:55 UTC
It affects OS X too. Changing platform to "All".
Comment 9 Matthew Francis 2014-09-19 12:46:27 UTC
*** Bug 84075 has been marked as a duplicate of this bug. ***