Bug Hunting Session
Bug 81833 - EDITING: ProtectForm attribute in settings.xml cannot be changed in Writer.
Summary: EDITING: ProtectForm attribute in settings.xml cannot be changed in Writer.
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: Other Linux (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA target:5.2.0 target:5.1.4
Keywords:
Depends on:
Blocks: DOCX-Doc-Protection DOC-Doc-Protection
  Show dependency treegraph
 
Reported: 2014-07-28 09:45 UTC by Nikolay Amiantov
Modified: 2018-10-24 06:37 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nikolay Amiantov 2014-07-28 09:45:31 UTC
Problem description: 
In some documents (I'm working with [1]) there is a ProtectForm attribute set, which persists after saving .doc to .odt, which disables editing of any content outside of some kind of form "fields". "Design mode" doesn't work, and "Format > Sections" menu item is greyed out. Nothing else worked, and I've found a mention of this ([2],[3]) and a fix in [3] which works. This implies that there is no method (or no easily visible one) to change that flag inside of Writer.

Steps to reproduce:
1. Open a document
2. Try to edit something outside of fields
3. Try to disable this protection

Current behavior:
Editing is prohibited, and there is no visible way to disable protection without manual editing of .odt.

Expected behavior:
There is a way to do this.

[1]: http://www.brave.ru/upload/brave/anketa_visa.doc
[2]: http://nabble.documentfoundation.org/How-to-unprotect-readonly-parts-of-a-document-td4056306.html
[3]: http://comments.gmane.org/gmane.comp.documentfoundation.libreoffice.user/21694
Operating System: Linux (Other)
Version: 4.2.5.2 release
Comment 1 Nikolay Amiantov 2014-07-28 09:58:01 UTC
Even if I manage to change this flag with editing of settings.xml, there is an invisible symbols at start and end of these "fields" which cannot be removed.
Comment 2 Buovjaga 2014-11-05 12:08:34 UTC
Confirmed as an enhancement.

Win 7 64-bit Version: 4.4.0.0.alpha1+
Build ID: b7d8a58ff2698ffc6e22943f64aa97c5ea253bd9
TinderBox: Win-x86@42, Branch:master, Time: 2014-11-05_00:40:38
Comment 3 Cor Nouws 2016-04-21 20:27:59 UTC
(In reply to Nikolay Amiantov from comment #0)

> Current behavior:
> Editing is prohibited, and there is no visible way to disable protection
> without manual editing of .odt.

Since LibreOffice version ??(4.4?) there is Tools > Options > Writer > Formatting Aids .. Protected Areas.

Would that fit your needs, and can we set to Resolved?
Thanks,
Cor
Comment 4 Commit Notification 2016-04-22 13:21:18 UTC
Oliver Specht committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8d41866f76ce3909b8d1bba6d0b74c4acb91202b

tdf#81833: form protection can be modified as compatibility option

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.