Bug Hunting Session
Bug 81835 - EDITING:change default paste from MSWord/WordPad create image to rtf
Summary: EDITING:change default paste from MSWord/WordPad create image to rtf
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: Other Windows (All)
: high major
Assignee: Andrzej Hunt
URL:
Whiteboard: target:4.4.0 target:4.3.1 target:4.2.7
Keywords: regression
Depends on:
Blocks: Paste-From-MSO
  Show dependency treegraph
 
Reported: 2014-07-28 11:15 UTC by Filippo Maguolo
Modified: 2018-09-18 19:38 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Filippo Maguolo 2014-07-28 11:15:20 UTC
Default function of paste from MSWord/WordPad creates an image, I suppose it uses now "Metafile GDI" instead of "Formatted text [RTF]".

This change was probably introduced with the bug id 77140.
Comment 1 Marc Wuillemin 2014-07-28 13:51:23 UTC
Can confirm on the following versions:
- Windows 7 64bit, LibO 4.2.5.2
- Windows 8.1 64bit, LibO 4.3.0.2
Comment 2 Michael Stahl (CIB) 2014-08-04 19:59:31 UTC
this commit puts various image types above RTF,
which is looking rather supsicious:

http://cgit.freedesktop.org/libreoffice/core/commit/?id=538c13f3d1756f2d105115f64ab1bc0b7426eebc
Comment 3 Commit Notification 2014-08-05 17:23:21 UTC
Andrzej Hunt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a96a7ce51aa98fb9ee97ea3803e2b7e648611008

fdo#81835 Don't prefer GDI Metafiles to RTF/HTML



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2014-08-06 14:02:29 UTC
Andrzej Hunt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=95cad2e05fe7b5b93dff0fecfbeb44bcab44ab81

Revert "fdo#81835 Don't prefer GDI Metafiles to RTF/HTML"



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2014-08-06 14:02:44 UTC
Andrzej Hunt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=46e03df0a7471a887e7cf403765b4de3582d9a1e

fdo#81835 Don't prefer GDI Metafiles to RTF/HTML -- correctly.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2014-08-06 14:22:22 UTC
Andrzej Hunt committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3040f24281a2a26ebc63bb4606a16fed2e597c4d&h=libreoffice-4-3

fdo#81835 Don't prefer GDI Metafiles to RTF/HTML -- correctly.


It will be available in LibreOffice 4.3.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2014-08-06 14:24:05 UTC
Andrzej Hunt committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0650c251422b8b4f2485a33d0d5e39955981bf2d&h=libreoffice-4-2

fdo#81835 Don't prefer GDI Metafiles to RTF/HTML -- correctly.


It will be available in LibreOffice 4.2.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Luke 2016-05-27 16:48:58 UTC
The fix for this bug actually broke text and image copying from non-browser apps(such as Word, Outlook, and PDF-Xchange) to Writer. Now only text is copied and images are lost. See Bug 35176
Comment 9 Timur 2017-01-04 11:26:43 UTC
*** Bug 84275 has been marked as a duplicate of this bug. ***