Bug 81893 - FILEOPEN: RTF doesnt retain table alignment
Summary: FILEOPEN: RTF doesnt retain table alignment
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: Other All
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: target:4.4.0 target:4.3.1
Keywords: filter:rtf, regression
Depends on:
Blocks: RTF-Tables
  Show dependency treegraph
 
Reported: 2014-07-30 03:52 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-10-05 22:08 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
LibO 4.3.1 VS Word 2010 (156.90 KB, image/png)
2014-07-30 03:52 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-07-30 03:52:49 UTC
Created attachment 103667 [details]
LibO 4.3.1 VS Word 2010

After converting < http://www.microsoft.com/investor/reports/ar13/docs/2013_Annual_Report.docx > into an RTF file in word 2010, opening the RTF file in LibO 4.3.1 results in the incorrect import of a table alignment on page 8.

Steps:
1) Open attachment 103664 [details]
2) Scroll to page 2

Expected: table to be aligned center rather than left

This is a regression as it didnt happen in 3.3.0. Last tested version that had the issue is 3.6.7.
Comment 1 Michael Stahl (CIB) 2014-07-30 14:00:10 UTC
alignment is Center, spacing is 2.29 cm left / right in OOo 3.4 beta
alignment is From Left, spacing is 4.59 cm left / 0 right since 3.5.0

(LO 3.4.6 is ... very broken)

it's the new RTF filter...
Comment 2 Michael Stahl (CIB) 2014-08-01 09:07:00 UTC
fixed on master
Comment 3 Commit Notification 2014-08-01 09:08:28 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=008d1187a9f3b36d6cbf31742632d237afecf1bd

fdo#81893: writerfilter: RTF import: \qc before \page was lost



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2014-08-01 16:18:11 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=22688ede28db14e5947cf73e85fcd2156e26ec5e&h=libreoffice-4-3

fdo#81893: writerfilter: RTF import: \qc before \page was lost


It will be available in LibreOffice 4.3.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Michael Stahl (CIB) 2014-08-04 11:06:14 UTC
oops - it looks like i mixed up the issue ids in the commit message - see bug 81893 for the commit that fixes this bug
Comment 6 Robinson Tryon (qubit) 2015-12-17 12:38:50 UTC Comment hidden (obsolete)