Download it now!
Bug 81994 - Copying a Graph from Excel to Impress causes data loss once printed.
Summary: Copying a Graph from Excel to Impress causes data loss once printed.
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: PDF-Export Print
  Show dependency treegraph
 
Reported: 2014-08-01 06:58 UTC by fornar
Modified: 2018-07-31 15:06 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Graph imported from excel (33.16 KB, application/vnd.oasis.opendocument.presentation)
2014-08-01 06:58 UTC, fornar
Details
Exported to pdf showing missing data (264.70 KB, application/pdf)
2014-08-01 07:10 UTC, fornar
Details
"Export as PDF" result with LO 4.3.0.4 (433.45 KB, application/pdf)
2014-08-01 09:31 UTC, ign_christian
Details
Execel document with sample graph (18.01 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2014-08-03 23:13 UTC, fornar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description fornar 2014-08-01 06:58:00 UTC
Created attachment 103793 [details]
Graph imported from excel

The issue is when i try and copy a graph created in Excel to LO Impress data is missing once printed. 
It initial looks fine as data has been copied across and can be viewable on the screen.

The issue arises when you then go to print or export to pdf the presentation. Basically all the data on the graph is missing.


I have also tried a Paste special as a Bitmap. This works better as when printed the data is retained. The only issue with the document then is the image is missing the bottom and right outline borders.
Comment 1 fornar 2014-08-01 07:10:16 UTC
Created attachment 103794 [details]
Exported to pdf showing missing data
Comment 2 ign_christian 2014-08-01 09:31:47 UTC
Created attachment 103802 [details]
"Export as PDF" result with LO 4.3.0.4

Bottom border is too thin, right border is almost not appeared. If using cups pdf printer, the results is much better.

Tested on LO 4.3.0.4 - Ubuntu 12.04 x86
Comment 3 fornar 2014-08-03 23:10:32 UTC
My setup was Excel 2013 to LO which was done on a Windows 7 64bit machine.

LO used was 4.3.0.4, i also downloaded and tested on LO 4.4.0.0 alpha0+ with the same results.

Have attached my original xlsx file that i copied the graph from to LO.
Comment 4 fornar 2014-08-03 23:13:54 UTC
Created attachment 103951 [details]
Execel document with sample graph
Comment 5 Janine 2014-08-25 22:38:09 UTC
The issue is when i try and copy a graph created in Excel to LO Impress data is missing once printed. 
It initial looks fine as data has been copied across and can be viewable on the screen.

The issue arises when you then go to print or export to pdf the presentation. Basically all the data on the graph is missing.
Comment 6 Rene' Fiby 2014-08-25 22:54:30 UTC
I am happy to use LibreOffice only, unfortunately the rest of the world has not caught up yet, hence this is a problem. A fix to this bug would be very much appreciated. Go you good thing, LibreOffice team.
Comment 7 raal 2014-10-21 11:43:40 UTC
I can confirm with LO 4.3.2, windows 7.
Comment 8 tommy27 2016-04-16 07:27:21 UTC Comment hidden (obsolete)
Comment 9 QA Administrators 2017-05-22 13:24:08 UTC Comment hidden (obsolete)
Comment 10 Timur 2018-07-31 15:06:42 UTC
Works with 5.4 and 6.2+. Please follow your bugs.