Bug Hunting Session
Bug 82035 - librevenge-based import filters do not work on OS X
Summary: librevenge-based import filters do not work on OS X
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: David Tardon
URL:
Whiteboard: target:4.4.0 target:4.3.1
Keywords:
: 82204 82291 83254 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-08-02 01:36 UTC by pinertech
Modified: 2014-08-29 16:31 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pinertech 2014-08-02 01:36:57 UTC
Using the 64-bit version of LibreOffice 4.3 (release) on OS X 10.9.4 results in broken importing for files tested such as WordPerfect .wpd and Microsoft Publisher .pub. Garbage characters are displayed instead of interpreting and rendering them properly. Highly likely to affect other import filters and other files, so not attaching files due to copyright issues with their sources. Problem also seemed to exist on RC2 and RC3 as well.

Using the 64-bit version of LibreOffice 4.2.5 (release) on same setup and files works fine, with files being imported and rendered properly.
Comment 1 Jorendc 2014-08-03 08:58:41 UTC
Probably a duplicate of bug 81113

@bug reporter: you mind retesting using one of this versions: http://dev-builds.libreoffice.org/daily/libreoffice-4-3/

*** This bug has been marked as a duplicate of bug 81113 ***
Comment 2 Maxim Monastirsky 2014-08-03 10:43:51 UTC
(In reply to comment #1)
> Probably a duplicate of bug 81113
@Joren: Sorry but it doesn't look like a dup of bug 81113. That bug shouldn't affect files with a correct extension (which is what the reporter claimed to use), and also it won't end as garbage characters, but as a "General Error".

Anyway I'm not able to reproduce this with 4.3 release under Fedora 20.
Comment 3 Jorendc 2014-08-03 11:14:16 UTC
(In reply to comment #2)
> (In reply to comment #1)
> > Probably a duplicate of bug 81113
> @Joren: Sorry but it doesn't look like a dup of bug 81113. That bug
> shouldn't affect files with a correct extension (which is what the reporter
> claimed to use), and also it won't end as garbage characters, but as a
> "General Error".

Oh okay, my bad. Lets deduplicate it then. Thanks for your comment Maxim.
Comment 4 pinertech 2014-08-03 18:40:42 UTC
Just to clarify, when I say "garbage characters", it appears that LibreOffice is just displaying raw file internals instead of being processed through an appropriate and available import filter.

Test results (OS X 10.9.4) - .wpd and .pub sample test files

1. Nightly build ("current")
Version: 4.3.1.0.0+
Build ID: d2dd174ac05d7c2844c5e60169128e2a02d4311b
TinderBox: MacOSX-x86@49-TDF, Branch:libreoffice-4-3, Time: 2014-08-02_20:39:45

Result: Garbage characters. Note that the nightly build appears to be a 32-bit version, though so far, there have been no differences between 32 and 64 bit versions in regards to this bug.

2. LibreOffice 4.3.0 x86 32-bit version, release

Result: Garbage characters. Same result as x86 64-bit reported before.
Comment 5 pinertech 2014-08-03 19:04:02 UTC
I found the WordPerfect test file posted at http://resource.dopus.com/viewtopic.php?p=61641 as the Quick View Plus sample file (see wrdprfct.zip)

I am not attaching directly because copyright allowances for distribution are unknown to me for this file.
Comment 6 Maxim Monastirsky 2014-08-03 19:07:56 UTC
(In reply to comment #5)
> I found the WordPerfect test file posted at
> http://resource.dopus.com/viewtopic.php?p=61641 as the Quick View Plus
> sample file (see wrdprfct.zip)
Thanks for the test file, however this file opens perfectly for me with 4.3 release under Fedora 20.
Comment 7 David Tardon 2014-08-04 07:43:36 UTC
Alonso has confirmed this and has also found out the reason.
Comment 8 Commit Notification 2014-08-04 12:04:51 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6cf40d263e33dd6934005af8319ae6fc8a386592

fdo#82035 fix loader paths



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2014-08-04 13:01:31 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0c4a1ecc7c46f67325bfb888a8db503abb4255b8&h=libreoffice-4-3

fdo#82035 fix loader paths


It will be available in LibreOffice 4.3.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 pinertech 2014-08-05 14:58:37 UTC
Mostly fixed, but problem with graphics being black and white in WordPerfect filter. See below.

TESTED:
libreoffice-4-3~2014-08-05_07.27.10_LibreOfficeDev_4.3.1.0.0_MacOS_x86.dmg

Microsoft Publisher .pub - WORKS fine with test file

WordPerfect .wpd - file is imported and displayed but the color graphics in the test file (see previous comment for file link) display BLACK AND WHITE.
Comment 11 Maxim Monastirsky 2014-08-05 18:20:24 UTC
(In reply to comment #10)
> but problem with graphics being black and white in WordPerfect
> filter.
Please open a new bug for it. It's very hard to keep track of several issues in one bug. Thanks!
Comment 12 Maxim Monastirsky 2014-08-05 18:20:44 UTC
*** Bug 82204 has been marked as a duplicate of this bug. ***
Comment 13 Maxim Monastirsky 2014-08-07 12:58:27 UTC
*** Bug 82291 has been marked as a duplicate of this bug. ***
Comment 14 Urmas 2014-08-29 16:31:29 UTC
*** Bug 83254 has been marked as a duplicate of this bug. ***