Bug 82041 - FORMATTING: Request: Undo the change of default template for heading level 3 and 4
Summary: FORMATTING: Request: Undo the change of default template for heading level 3 ...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: ux-advise (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: Other All
: low enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA target:4.5.0 target:4.4.0.2
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-02 06:09 UTC by Holger Jakobs
Modified: 2015-01-06 17:07 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
fdo82041 patch to revert assignement of Gray to headline 3 and headline 4 (963 bytes, text/plain)
2014-12-24 02:14 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Holger Jakobs 2014-08-02 06:09:22 UTC
Problem description: 
Up to 4.1.6 all text was black. Without any reason, the default color is gray for heading level 3 and 4. This should be undone!


Steps to reproduce:
1. format a paragraph as heading level 3 or 4

Current behavior:
text is gray

Expected behavior:
text is black

I had already filed it as a bug (81996) , but it was classified as "not a bug". So I re-introduce it as a feature request.

Since there is no specific reason for headings 3 and 4 to be different in color from headings 1, 2, 5, 6, 6, 7, 8, 9, 10, I still regard this as some kind of error - call it bug or not.


              
Operating System: All
Version: 4.2.5.2 release
Comment 1 Yousuf Philips (jay) (retired) 2014-08-02 06:25:56 UTC
Hi Holger,

Unfortunately this is unlikely to be changed back, as previously stated in bug 81996 and a workaround was provided to you to fix it in your case. If you are unhappy with this discussion, then you are more than welcome to stay with 4.1.

*** This bug has been marked as a duplicate of bug 81996 ***
Comment 2 Holger Jakobs 2014-08-02 07:14:16 UTC
Hi Jay,

It's not about *me*, it's about an unwanted and unloved change.

I know how to change formatting, style sheets and document templates.

It's about ordinary users who are surprised by a sudden change of text color on two arbitrary heading levels.

Who introduced the "new" default style? What reasons had they to change? Have users been asked whether they approve of it? Or is there a small group of people who like to change things on a whim?

Actually, only the creator of a bug report or feature request should be able to tell whether it's resolved or closed. Otherwise, the status should be "disputed" or similar. If the customer isn't satisfied, the problem is NOT solved.

Regards,
Holger
Comment 3 Yousuf Philips (jay) (retired) 2014-08-02 08:33:43 UTC
Hi Holger,

I have reset the status to unconfirmed and have asked others to chime in on this issue to answer your questions.
Comment 4 A (Andy) 2014-08-02 10:25:40 UTC
My personal thoughts:

I think such changes are always a matter of taste.  Some will like them others not.  I personally would also not expect them as grey, because beside Heading Level 3 and 4 all others stayed black.  I am not sure what was the reason for changing it, but maybe one wanted to differentiate them more, because mostly you will use the first one to four or five heading levels and then you have the advantage to differentiate them better.  Therefore, I could see some advantages from this (the longer I think about it the more) and as Sophie wrote in 81996 if one don't like it then it can be changed.  I think this a good solution to have the freedom to change it, because unfortunately one will never reach a solution which fits all tastes.  

In some way it is a little bit similar to the new MSO design.  In the beginning most of my friends disagreed with this change, asked why this change was made and wanted the old back, but now most of them like it and don't want back to the old one.  But of course not all have the same taste and like it the same way.
  
In case of greater changes you can of course maybe think of a poll.  But we all want to have improvements in the LO design (there is already much progress as one can see in the last releases, but of course we (I) want more) and therefore we need a pragmatic way not to "block" all UI changes, to encourage UI changes and let some freedom if issues are for instance discussed with other members, users and programmers.  I find it more important to get more improvements and to encourage programmers to take care of the UI and in case of greater changes discuss it with others and in this respect we have at LO also a Design/UX team and then do it.  Especially if you still have the freedom to change it on your personal installation then we should do it or give it a try.  If later comes out then most don't like a change, then another solution could be found.  LO is a living software evolving, changing, developing and improving itself.  Therefore, I think an evolutionary solution would be found.

That's why, even I would currently probably prefer the black one, I can live with this solution (and also the workaround) and maybe as with the MSO design I will like it in the future that much that I don't want to come back the old one.  Thus, I would also suggest to close this bug report, even if I understand that Holger sees it as a bug.  And Holger, if you or others are interested in Design and UI issues I would also encourage you to join the LO Design/UX team to help LO to get better and better.  More help is needed and is welcomed and therefore any additional contributor is very much appreciated.  Thank you very much in advance and Holger, also thank you and others for your interest and effort and your raising of UI questions.  

I thank all who help LO to get better and better.
Comment 5 A (Andy) 2014-08-02 10:31:23 UTC
Small typing correction in the 3rd paragraph: ... If later comes out then most  ... -> ... If later comes out that most ...
Comment 6 Jean-Baptiste Faure 2014-08-04 10:19:18 UTC
For me it is a bug because:
1/ there no reason why headings 3 and 4 should have a different color than other headings
2/ other headings do not have black or gray color but automatic
2/ gray and automatic colors are not consistent.

Workaround: use your own default template: https://help.libreoffice.org/Writer/Changing_the_Default_Template

Best regards. JBF
Comment 7 Owen Genat (retired) 2014-09-13 15:26:35 UTC
(In reply to comment #6)
> For me it is a bug because:
> 1/ there no reason why headings 3 and 4 should have a different color than
> other headings

I agree. I am not change averse, but this particular change seems unwarranted and unjustifiable.
Comment 8 Yousuf Philips (jay) (retired) 2014-09-13 15:58:38 UTC
(In reply to comment #7)
> I agree. I am not change averse, but this particular change seems
> unwarranted and unjustifiable.

Its even worse when it affects html documents (bug 81297) and that bug has been set as NOTABUG.
Comment 9 Jean-Baptiste Faure 2014-09-13 16:24:42 UTC
Set as enhancement because of bug 81297 closed as notabug.
Status set to NEW because it is a valid enhancement.

I think that font color must be set to automatic for each predefined style; not black, not gray, automatic.

UX-advise requested.

Best regards. JBF
Comment 10 Francisco 2014-09-13 20:18:28 UTC
There were a lot of discussions in the Design list about a new default template. 

http://nabble.documentfoundation.org/Default-Writer-Template-td4076271.html

http://nabble.documentfoundation.org/Default-LO-Style-td4061081.html
Comment 11 Owen Genat (retired) 2014-09-14 06:54:08 UTC
(In reply to comment #9)
> I think that font color must be set to automatic for each predefined style;
> not black, not gray, automatic.

Again, I agree. I have no problem with additional designs in terms of optional templates that are either shipped with LO or provided via the templates website, but the /default/ should always be as plain as possible. LO is a multi-platform, multi-locale product, which means defaults need to be very simple and as unobtrusive / adaptable as possible.

(In reply to comment #10)
> There were a lot of discussions in the Design list about a new default
> template. 

The majority of the discussion seems to have been about typeface, size, spacing, margins, etc. I must say I am dismayed by some of the typographic misconceptions in that pair of threads. The only references that I can find to the use of "gray" are:

> Changes:
> - Grayscale headings 

> Also think we should test the grayscale range in headings on
> a low grade laser printer, 40% gray may be difficult to read
> in such a printout. 

> I've changed headings starting from Heading 6, I used gray color and 
> I hope that works with black-and-white printers. 

> I really like what Google Docs does:
> it uses gray for the later titles, so that they stand out. 

I do not feel that constitutes extensive discussion, in relation to changing the tone (black to grey) of only some heading levels. I had a look at all the available proposed templates and they vary so much it is disheartening. No clear versioning, file naming, or an indication of what has generally changed (i.e., font size from A pt to B pt for H1), or even details about behind the scenes changes (i.e., linking of a style or auto-update settings, changing a size from a point size to equivalent percentage size). 

This all makes for a difficult design process. I can kind of see why the Design team has retreated to Redmine. At least some of these issues will be more manageable, though I remained concerned it may not address the process.
Comment 12 Robinson Tryon (qubit) 2014-12-23 22:09:11 UTC
Whiteboard: Remove 'needQAAdvice' once bug is NEW/RESOLVED.
Comment 13 V Stuart Foote 2014-12-24 02:14:27 UTC
Created attachment 111253 [details]
fdo82041 patch to revert assignement of Gray to headline 3 and headline 4

Ahmed's Oct 2013 work with the Design team on revising the default template for Writer was very welcome, and while visually appealing the choice of a hard coded Gray color assignment for heading 3 and heading 4 (as opposed to allowing it to use Automatic) has become an annoyance as that color is picked up for <h3> and <h4> Heading formats in Writer HTML renderings. 

Seems simplest to go ahead and remove the color assignments of Gray to headline 3 and headline 4, leaving it with no color assignment and free to take on Automatic assignments.  

The poolfmt.cxx was refactored, and the formatting code for default writer document style is now found in DocumentStylePoolManager.cxx

Attached patch should suffice, if somebody with permissions wants to post it.

-=ref=-
http://nabble.documentfoundation.org/Default-LO-Style-tc4061081.html
http://nabble.documentfoundation.org/Default-Writer-Template-tc4076271.html

http://opengrok.libreoffice.org/xref/core/sw/source/core/doc/poolfmt.cxx?r=5cf62a6ab450c25eb07a1ec08c857f17f674ef67
Comment 14 Commit Notification 2014-12-24 16:16:44 UTC
V Stuart Foote committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=889f4705b90147d5653b08491579c51a7aca12be

fdo#82041 restore heading 3 and 4 color to automatic

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 15 Adolfo Jayme 2014-12-28 19:43:02 UTC
Comment on attachment 111253 [details]
fdo82041 patch to revert assignement of Gray to headline 3 and headline 4

Any reason you don’t use Gerrit, where developers can review it?
Comment 16 Yousuf Philips (jay) (retired) 2014-12-28 20:14:35 UTC
It was submitted to gerrit.

4.5 - https://gerrit.libreoffice.org/#/c/13642/
4.4 - https://gerrit.libreoffice.org/#/c/13643/ (waiting approval)
Comment 17 Commit Notification 2015-01-06 17:07:39 UTC
V Stuart Foote committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=aa474a538315c20128d0853bac97bfa3e66a2c12&h=libreoffice-4-4

fdo#82041 restore heading 3 and 4 color to automatic (4.4)

It will be available in 4.4.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.