Bug 82113 - FILEOPEN: EMF+ EmfPlusRecordTypeDrawDriverString Text in EMF not displayed
Summary: FILEOPEN: EMF+ EmfPlusRecordTypeDrawDriverString Text in EMF not displayed
Status: RESOLVED DUPLICATE of bug 121648
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: Other All
: medium normal
Assignee: Bartosz
URL:
Whiteboard:
Keywords: notBibisectable, regression
Depends on:
Blocks: EMF-WMF
  Show dependency treegraph
 
Reported: 2014-08-04 02:54 UTC by Yousuf Philips (jay) (retired)
Modified: 2019-01-09 13:18 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
3.3 PDF Showing No Vertical Text (30.17 KB, application/pdf)
2015-12-16 15:59 UTC, Joel Madero
Details
3.3-3.5.7-3.6-master compare in Windows - PDF (44.32 KB, image/jpeg)
2015-12-21 12:27 UTC, Timur
Details
EMF+ Image extracted from document (13.12 KB, image/wmf)
2017-05-08 23:42 UTC, Bartosz
Details
Image with increased size of image to see where letters are drawn (13.12 KB, image/x-wmf)
2017-11-29 00:28 UTC, Bartosz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-08-04 02:54:33 UTC
When testing any of the 3 files in attachment 103764 [details] from bug 81978 in Linux Mint, the OLE vertical table on the left doesnt have any text in it in LibO.

Word 2013 VS Libo 4.3.1 - attachment 103969 [details]

Tested in 3.6.7, 4.1.6, 4.2.7, 4.3.1 and master.
Comment 1 Marina Latini (CIB) 2014-08-04 08:39:34 UTC
Confirmed on Ubuntu 14.04 x86_64:
* Version: 4.4.0.0.alpha0+
* Build ID: 8cb75e905cef50a2d8a423443d3dcef5f1899027
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2014-07-30_04:47:13

status -> new
block -> bug 81234 (meta bug for rtf filter)
Comment 2 Marina Latini (CIB) 2014-08-04 08:42:34 UTC Comment hidden (obsolete)
Comment 3 Miklos Vajna 2014-09-11 14:34:39 UTC
This is an EMF+ bug, if soffice is started with EMF_PLUS_DISABLE=1, then the text is there. All 3 files in that zip file have the same embedded EMF+ metafile, that's why they are all affected. -> Removing rtf_filter from whiteboard.
Comment 4 Yousuf Philips (jay) (retired) 2014-09-11 16:34:38 UTC Comment hidden (obsolete)
Comment 5 Timur 2014-11-27 18:03:19 UTC Comment hidden (obsolete)
Comment 6 Timur 2015-02-12 10:58:30 UTC Comment hidden (obsolete)
Comment 7 Timur 2015-02-12 11:14:29 UTC Comment hidden (obsolete)
Comment 8 Yousuf Philips (jay) (retired) 2015-02-12 19:41:12 UTC Comment hidden (obsolete)
Comment 9 Chris Sherlock (Collabora) 2015-02-13 01:53:45 UTC
There are different code paths in place, one where it is working, the other where it isn't. 

There's a workaround (not really a very good one) so it seems to me that this is still an issue that needs to be worked on.
Comment 10 Timur 2015-02-13 08:40:54 UTC Comment hidden (obsolete)
Comment 11 Robinson Tryon (qubit) 2015-03-05 17:07:47 UTC Comment hidden (no-value)
Comment 12 Robinson Tryon (qubit) 2015-12-14 05:32:45 UTC Comment hidden (no-value, obsolete)
Comment 13 Joel Madero 2015-12-16 15:53:54 UTC Comment hidden (obsolete)
Comment 14 Joel Madero 2015-12-16 15:59:17 UTC
Created attachment 121349 [details]
3.3 PDF Showing No Vertical Text
Comment 15 Timur 2015-12-21 12:27:37 UTC
Created attachment 121472 [details]
3.3-3.5.7-3.6-master compare in Windows - PDF

(In reply to Joel Madero from comment #13)
> (In reply to Timur from comment #6)
> > Reproduces on Windows, starting from 3.6. 3.5.7 was OK so regresison. I
> > change OS: Linux to All. 
> 
> I just tested 3.3 and the problem is still there...are you sure it's working
> in 3.5.7? I'll attach a pdf of what I see in 3.3.
That's the case with me in Windows, as attached.
Comment 16 Bartosz 2017-05-08 23:42:20 UTC
Created attachment 133174 [details]
EMF+ Image extracted from document
Comment 17 Timur 2017-08-24 17:34:58 UTC
Repro with 6.0+.
Comment 18 Bartosz 2017-11-29 00:28:02 UTC
Created attachment 138052 [details]
Image with increased size of image to see where letters are drawn
Comment 19 Xisco Faulí 2018-02-28 10:05:27 UTC Comment hidden (obsolete)
Comment 20 Buovjaga 2018-06-28 13:13:02 UTC
We can't bibisect this as the oldest commit from 43all Linux repo does not display the graphic.
Thus, there seems to be a difference between Win & Linux (in line with the previous comments)
Comment 21 Bartosz 2019-01-09 13:18:56 UTC

*** This bug has been marked as a duplicate of bug 121648 ***