Bug Hunting Session
Bug 82119 - EDITING: Extremly slow response when autospellscheck is on
Summary: EDITING: Extremly slow response when autospellscheck is on
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: perf
: 93873 (view as bug list)
Depends on:
Blocks: Spell-Checking
  Show dependency treegraph
 
Reported: 2014-08-04 07:28 UTC by jose.velez
Modified: 2018-12-05 13:13 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
A presentation with 200 pages and multiple simple figures (738.22 KB, application/vnd.oasis.opendocument.presentation)
2014-08-04 07:28 UTC, jose.velez
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jose.velez 2014-08-04 07:28:16 UTC
Created attachment 103973 [details]
A presentation with 200 pages and multiple simple figures

Problem description: 

If you load a presentation with 200 pages and multiple simple figures the response is very slow. If you disconnect autospellscheck the response is good enough.

In Mac the problem is worst, because you can not deactivate autospellscheck due to the extremly slow responsive.

Steps to reproduce:
1. Load the attached document.
2. Try to edit the texts or try to change to other slide.
3. Disconnect autospellscheck and try again.

Current behaviour:

Very different speed with autospellscheck (very slow) and without it (normal).

Expected behaviour:

Same speed with autospellscheck and without it.
              
Operating System: Ubuntu
Version: 4.3.0.4 release
Comment 1 Jean-Baptiste Faure 2014-08-05 19:52:37 UTC
Reproducible with LibreOffice 4.3.1.0.0+ build at home under Ubuntu 14.04 x86-64.
I am using this Spanish dictionary: http://extensions.libreoffice.org/extension-center/spanish-dictionaries/pscreleasefolder.2012-04-18.1033472248/0.7/espana

Best regards. JBF
Comment 2 QA Administrators 2015-09-04 02:48:51 UTC Comment hidden (obsolete)
Comment 3 jose.velez 2016-02-16 18:56:24 UTC
The bug is still present in Libreoffice 5.0 and 5.1 on Linux.
Comment 4 Jean-Baptiste Faure 2016-02-17 05:58:03 UTC
Same problem with the current master.
That said, did you try with a presentation in which the option "Autofit Text" is off (right-click menu of the text bloc) ? No clue both are linked, but who know?
Computing the correct font size each time you edit a text bloc takes time.

Best regards. JBF
Comment 5 jose.velez 2016-02-18 17:53:35 UTC
I think that autofit is not linked to the problem. 

I think that the problem is linked to lots of graphics objects and tables with syntax errors. 

In the presentation that I attached there are a many circles (nodes) and cells in tables with sentences like "KNN".

I think that the problem would be solved if libreoffice doesn't analyse the syntax in slides that are not visible.
Comment 6 Keith Curtis 2016-03-05 03:57:10 UTC
*** Bug 93873 has been marked as a duplicate of this bug. ***
Comment 7 jose.velez 2018-02-23 10:50:13 UTC
The problem persists in LibreOffice 6
Comment 8 Telesto 2018-03-23 16:09:11 UTC
No repro with
Version: 6.1.0.0.alpha0+
Build ID: dd4f1b1bd31daf080dc0420524712dc244e539b5
CPU threads: 4; OS: Windows 6.3; UI render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-03-20_23:26:38
Locale: en-US (nl_NL); Calc: CL
Comment 9 Timur 2018-03-23 17:36:58 UTC
In Windows, I couldn't load this file with previous x86 LO, but I can with 5.3.8 and it's slow there. So I set OS to "All"
But master x86 and x64, after somewhat slow load, no repro, scroll fine, both Win and Lin. Looks like a recent improvement. 

@Jose: please test with master 6.1 daily, https://dev-builds.libreoffice.org/daily/master/ or https://libreoffice.soluzioniopen.com/.
If repro again, please set back to New and explain.
Comment 10 jose.velez 2018-10-12 08:55:46 UTC
It's seems resolved in 6.1 :-)