Bug Hunting Session
Bug 82149 - Help viewer shows missing icons as "vnd.sun.*" placeholders rather than taking icons from parent icon themes and links.txt
Summary: Help viewer shows missing icons as "vnd.sun.*" placeholders rather than takin...
Status: CLOSED DUPLICATE of bug 75637
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
: 88086 94889 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-08-04 19:14 UTC by email.seRiffle
Modified: 2015-10-24 20:13 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments
shows multiple missing icons on one help page (78.15 KB, image/png)
2014-08-22 18:36 UTC, email.seRiffle
Details
cannot access text string that maps to icon image (15.36 KB, image/png)
2014-08-22 18:38 UTC, email.seRiffle
Details
shows build info for version of LibreOffice (26.23 KB, image/png)
2014-08-22 18:39 UTC, email.seRiffle
Details
screenshot of missing icons (160.30 KB, image/png)
2014-08-25 16:31 UTC, penttila
Details
Problem also in V4.3.1.2_installed today (27.99 KB, image/png)
2014-08-30 02:45 UTC, email.seRiffle
Details
actual missing icon screenshot (46.83 KB, image/png)
2014-08-30 02:46 UTC, email.seRiffle
Details

Note You need to log in before you can comment on or make changes to this bug.
Description email.seRiffle 2014-08-04 19:14:24 UTC
Probably related to RelatedBug 75637 
Note the help corresponding to  Stable 4.2.5.2 release, has been installed;
I am running JRE 1.7.0_51

Changing to from Tools.Options  Galaxy or Tango, as suggested in above Bug, does not work.

Example of a page that fails, as above, is:  "Shortcut Keys for Spreadsheets"
Example2: Help topic  "Spreadwheets.Functions Types and Operators.FunctionWizard"



Note: Adding a RClick operation,  on icons on help page, would at least give a clue, as to where icon is expected to be...

while at it, making the icons "scaleable" is of questionable use... a simple popup, like wikipedia, would be a better "enlarge" option..
Comment 1 Joel Madero 2014-08-06 01:16:42 UTC
@email - please provide explicit steps for how to see the problem along with what you expect and what you observe. In this case probably a screenshot would be helpful also. Keep in mind that we have thousands of bugs we try to keep up with triage work and it's always best if you can help us by making clear reproducible steps.

Also for the second request - please report separately. 1 report should equal 1 issue/request. 

Marking as NEEDINFO - once you provide easy reproducible steps and a screenshot please mark as UNCONFIRMED. Thanks
Comment 2 email.seRiffle 2014-08-22 18:36:55 UTC
Created attachment 105119 [details]
shows multiple missing icons on one help page

there are two more png images; will try to attach, them at later time, since aparently, bugzilla does not accept multiple attachments of PNG's;

One, *_02.png
    shows ability to select on "icon"Placeholder, but cannot access the text string "vnd.sun.sta.....", to see what it trying to reference;

*_03.png
    shows the build# of LibreOffice, from the writer.main menu
Comment 3 email.seRiffle 2014-08-22 18:38:16 UTC
Created attachment 105120 [details]
cannot access text string that maps to icon image
Comment 4 email.seRiffle 2014-08-22 18:39:44 UTC
Created attachment 105121 [details]
shows build info for version of LibreOffice

Unfortunately, help has not corresponding build info or "help" menu ite,
Comment 5 email.seRiffle 2014-08-22 18:43:06 UTC
responding with additional info requested.

Note when changing from Tools.Options: Galaxy to any other, like Tango, and back, and even if close LibreOffice (& quickstarter), and restart, the same observations on help icons still prevail.
Comment 6 penttila 2014-08-25 16:31:12 UTC
Created attachment 105244 [details]
screenshot of missing icons

I can confirm this bug with the following steps:

1) Open LO Writer
2) In menu select Help icon -> LibreOffice Help F1
3) You get a help page with missing icons

LinuxMint 17 Cinnamon  (original Hungarian locales)
LO   4.2.4.2 Build id.: 420m0(Build:2)
Comment 7 email.seRiffle 2014-08-30 02:45:05 UTC
Created attachment 105446 [details]
Problem also in V4.3.1.2_installed today

installed v4.3.1.2 over prior version, noted in this bug report;
Observed same "missing icon" visually.
Comment 8 email.seRiffle 2014-08-30 02:46:32 UTC
Created attachment 105447 [details]
actual missing icon screenshot

example, is the default screen, upon 1st invoke writer.Help
Comment 9 Owen Genat (retired) 2015-02-08 22:25:31 UTC
*** Bug 88086 has been marked as a duplicate of this bug. ***
Comment 10 Jim Avera 2015-02-09 00:01:16 UTC
See bug 88086 for another example using 4.4.0.0.beta2
Comment 11 Regina Henschel 2015-05-17 11:57:26 UTC
Please look at bug 81091, workaround in comment 18, whether it solves your problem.
Comment 12 m.a.riosv 2015-10-08 22:04:12 UTC
*** Bug 94889 has been marked as a duplicate of this bug. ***
Comment 13 richard_g 2015-10-15 14:56:33 UTC
Hello.

Workaround in comment 18 at bug 81091 does not solve. When the box is checked, no icon is displayed, but when the box is unchecked, only some icons are displayed.

See the added picture on the French Open Office Forum:
https://forum.openoffice.org/fr/forum/viewtopic.php?f=13&t=48915

Tried on Libre Office 4.4.5 on Linux 64 bits, searching for "créer nouveau document" (Create new document) and selecting "nouveau" (new) in french help: almost all icons are missing, only three icons are correctly displayed at the bottom of the picture!

Richard
Comment 14 Jean-Baptiste Faure 2015-10-17 08:28:29 UTC
Not reproducible for me with LibreOffice 5.0.4.0+ built at home under Ubuntu 15.04 x86-64 if I use the Galaxy icon set. It seems that Tango icon set is not complete, and, consequently, should not be set as default icon set.

Best regards. JBF
Comment 15 richard_g 2015-10-17 09:35:08 UTC
With LibO 4.4.5 (Linux 64 bits or Vista 32 bits), I am using the Galaxy icon set, but the problem of missing icons appears with all available icon sets (Crystal, Galaxy, Hicontrast, Sifr, Tango, Oxygen)

Is is solved in 5.0.4 or further release ?

Richard
Comment 16 Regina Henschel 2015-10-17 11:32:41 UTC
If you are missing icons in the help, then copy the placeholder. Insert it into a Writer document. Open the formatting dialog of that placeholder graphic, goto the tab "Image". Copy the text from the field 'File name' in section 'Link'. Add this to your bug report. You will get something like

vnd.sun.star.zip://file:%2F%2F%2FF:%2FLO_daily%2Fshare%2Fconfig%2Fimages_tango.zip/sw/imglst/sc20171.png

In this example the link tells, that it was searched in theme 'tango', that its file name is 'sc20171.png' and the folder 'imglst' indicated, that the icon is not used directly but via a mapping list. (Which is true for this special icon.)

Doing so, it is much easier to decide, whether the icon is really totally missing in the icon theme or whether it is not shown, because the mapping via list currently does not work for the help viewer (bug #75637).
Comment 17 Jacques Guilleron 2015-10-17 15:20:56 UTC
Hi all,

With Windows 7 Home locale fr,
LO 4.1.6.2 Build ID: 40ff705089295be5be0aae9b15123f687c05b0a display all icons,
LO 4.2.0.1 Build ID: 7bf567613a536ded11709b952950c9e8f7181a4a not.
Typing "créer nouveau document" in Help search, next "Nouveau", shows help for new document with 7 missing icons.
According to the indications of Regina, i get for the first missing icon in LO 4.2.0.1:
vnd.sun.star.zip://file:%2F%2F%2FC:  …  %2FLibreOffice%25204.2.0.1%2Fshare%2Fconfig%2Fimages_tango.zip/res/sx03251.png
Looking there, this icon is missing.
By continuing, 30 images are missing: (4.2.0.1, 243 elements, 4.1.6.2, 273), this for images_tango.zip/res/, but also for the other themes.
Comment 18 richard_g 2015-10-17 17:01:59 UTC
Hello.

Missing icons in help are really missing in zip folders for all sets.

Examples: icons missing in the test "Create new document-> New" are in the range "sx03243.png" to "sx03252.png" which is missing in "galaxy.zip", missing in "oxygen.zip", missing in "crystal.zip" and missing in all other zip files.
(Tested on LibO 4.4.5 Windows version)

Could it be possible to download zip files from older versions?
Comment 19 Jacques Guilleron 2015-10-17 17:57:59 UTC
Yes. Change the four related files in LO 4.2.0.1 by the same ones from LO 4.1.6.2 works.
Displaying is good.
I didn't verify if thers's no other issue.
Comment 20 Laurent BP 2015-10-18 09:03:57 UTC
(In reply to Jacques Guilleron from comment #19)
> Yes. Change the four related files in LO 4.2.0.1 by the same ones from LO
> 4.1.6.2 works.

If replacing images_theme name.zip files from an old version prior to 4.2 fixes this bug, then it is a duplicate of bug 75637 Only some icons are missing. See comment 16 from Regina.

If all icons are missing, see bug 81091 and uncheck Tools > Options > LibreOffice > Security > Options > Block any links from documents not among the trusted locations (see Macro Security)

@email.seRiffle
If bug is still present then it is a new one. You may have select an option which disable icons in help. Remove your profile, and try to find which option makes the bug to appear.
Comment 21 Yousuf Philips (jay) (retired) 2015-10-19 19:23:23 UTC
This is an icon inheritance bug found in the help viewer. If the icon isnt found in the current icon theme's zip file, it doesnt check its parent icon theme's zip file for the icon. I noticed this same issue when checking the help while having breeze enabled and had the breeze icon designer create the necessary missing icons for common paragraphs.

While doing some more investigating, it seems that the help viewer also ignores links.txt duplications entries, so though the icon 'sw/imglst/sc20174.png' found in the "Rearranging a Document by Using the Navigator" help file [1] which was screenshot in comment 2 has a duplication entry in breeze's links.txt like this

 sw/imglst/sc20174.png cmd/sc_upsearch.png

the icon does not appear in the help. I'll let others decide the priority of this bug, but this pretty much means that the help viewer is not usable in any icon theme other than galaxy due to these two bugs. The only except to this is breeze in 5.0 which didnt utilize links.txt much.

[1] http://cgit.freedesktop.org/libreoffice/help/tree/source/text/swriter/guide/arrange_chapters.xhp
Comment 22 Maxim Monastirsky 2015-10-19 21:52:04 UTC
So help files have links like "cmd/sc_line.png", and we mass-transform it using xslt to "vnd.sun.star.zip:/path/to/images_<current-theme>.zip/cmd ... and feed that to the web view. There isn't much we can do with such logic. One possible solution is what kendy suggested in a comment in Databases::getImagesZipFileURL:

280    // FIXME instead of using a general vnd.sun.star.zip://
281    // for imgrepos, we should have some vnd.sun.star.image://

... and internally this new content provider should use the normal way of loading icons, as we do for UI elements.
Comment 23 Yousuf Philips (jay) (retired) 2015-10-20 13:02:46 UTC
Doing some more digging around and the web view in 3.3.0 and 3.6.7 would always show galaxy icons even when a different icon theme was set.

In 4.1.6, tango icons are appearing in web view and there were no placeholder images because in its images_tango.zip, we were merging all missing icons from industrial and galaxy into it.

In 4.2 we introduced links.txt resulted in some icons to be missing and in 5.0 we stopped bundling icons from parent icon themes into child icon themes zip files, which resulted in alot more icons to be missing.
Comment 24 Yousuf Philips (jay) (retired) 2015-10-20 15:38:23 UTC
(In reply to richard_g from comment #18)
> Examples: icons missing in the test "Create new document-> New" are in the
> range "sx03243.png" to "sx03252.png" which is missing in "galaxy.zip",
> missing in "oxygen.zip", missing in "crystal.zip" and missing in all other
> zip files.

Can you identify where in the help these icons are used as i searched through the help repo and couldnt find a reference to sx03243.png.

> Could it be possible to download zip files from older versions?

I found sx03243.png in 3.3.0's zip files, but not in version 3.5.7 and above, so it is possible to copy it from older versions if necessary.
Comment 25 Regina Henschel 2015-10-20 15:55:29 UTC
(In reply to Maxim Monastirsky from comment #22)
> So help files have links like "cmd/sc_line.png", and we mass-transform it
> using xslt to "vnd.sun.star.zip:/path/to/images_<current-theme>.zip/cmd ...
> and feed that to the web view. There isn't much we can do with such logic.
> One possible solution is what kendy suggested in a comment in
> Databases::getImagesZipFileURL:
> 
> 280    // FIXME instead of using a general vnd.sun.star.zip://
> 281    // for imgrepos, we should have some vnd.sun.star.image://

I disagree with that as long term solution. I think, that in a long term solution the transformation should result in a html, which can be shown with every browser and does not contain any propriety protocol. That would need to rethink, whether the images need to be zipped at all. For example in my installation the zipped images_galaxy.zip has size 2478KB and the unzipped folder 1989KB.
 
> 
> ... and internally this new content provider should use the normal way of
> loading icons, as we do for UI elements.

But the real problem is, that the images are not used directly, but via the links.txt file. This file cannot be used in the xsl transformation. My current idea is to wrap the links.txt file into a .xhp document so it can be read by the document() function in the main_transform.xsl. Perhaps use a coded form of the image-link as paragraph id. But there is nothing testing up to now.
Comment 26 Maxim Monastirsky 2015-10-20 17:58:26 UTC
(In reply to Regina Henschel from comment #25)
> But the real problem is, that the images are not used directly, but via the
> links.txt file.
links.txt is not the only problem right now. You're missing the fact that since 5.0 icon themes aren't self contained anymore, and the fallback is implemented in vcl.
Comment 27 Regina Henschel 2015-10-24 20:13:15 UTC
We had some discussion and tests on the Hackfest in Hamburg. Solving the problem in the xsl filter does not look promising. The next try should be, to fix it in core directly by improving or creating a protocol handler for use in the helpviewer.

The problem here is the same as in bug 75637, therefore I close this as duplicate.

*** This bug has been marked as a duplicate of bug 75637 ***