Bug 82211 - Manage Names pop-up re-size re-sizes wrong element
Summary: Manage Names pop-up re-size re-sizes wrong element
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Andreas Heinisch
URL:
Whiteboard: target:7.2.0
Keywords:
Depends on:
Blocks: Dialog Cell-Name
  Show dependency treegraph
 
Reported: 2014-08-05 21:29 UTC by Robert
Modified: 2021-08-13 12:19 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert 2014-08-05 21:29:54 UTC
Resizing the "Manage Names" pop-up vertically increases the space between the "Add Delete" and "OK Cancel Help" buttons with extra space, rather than the size of the list-box containing the named ranges. Also, the "double" space between the list-box and "Name" entry field could be reduced to a single space to allow more list-box data to be displayed.
Comment 1 Joel Madero 2014-08-06 02:14:58 UTC
1 issue = 1 report, please separate the second issue into a new report. Also when reporting please stick with the following format:

Enumerate steps to reproduce:
1....
2...
3...

Expected result:
Observed Result:

Attachments: Attach documents or screenshots to demonstrate where appropriate.

*We have to triage thousands of bugs, this make volunteers very happy when we can just quickly go through steps.

Next: Please always include your operating system and version of LibreOffice

That being said:
Bodhi Linux 2.4 - E17
LibreOffice 4.4 built August 7, 2014

Steps to Reproduce:
1. Open Spreadsheed
2. Left Click on down arrow in "Name Box"
3. Dialog pops up - expand vertically

Observed: Distance between buttons and list box expands
Expected: List Box itself expands

Marking as:
New
Enhancement
Medium - seems like this might benefit more people and seems very functional
Comment 2 robert 2021-04-21 08:01:32 UTC
Got an email about this bug being assigned to someone, so tried it again, and is now

Version: 7.1.2.2 (x64) / LibreOffice Community
Build ID: 8a45595d069ef5570103caea1b71cc9d82b2aae4
CPU threads: 8; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Raster; VCL: win
Locale: en-GB (en_GB); UI: en-US
Calc: threaded

working as it should work. Only still relevant part of the original bug report is the somewhat excessive(?) space between the list-box with names and the "Name:" label below it.
Comment 3 Andreas Heinisch 2021-04-21 08:05:38 UTC
The resize now works as intended, but in the space between there is a hidden label with the text "Select a named range or named formula from the list to modify its properties." which creates the space.

I have to check, if we decide to show or remove it completely.
Comment 4 Commit Notification 2021-04-24 20:34:15 UTC
Andreas Heinisch committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/7727d39f2ccc4fa802100f474d25f1c56f5ce625

tdf#82211 - Show hidden info label

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 stragu 2021-08-13 12:19:27 UTC
Verified as fixed in:

Version: 7.2.0.2 / LibreOffice Community
Build ID: 614be4f5c67816389257027dc5e56c801a547089
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
Calc: threaded