Bug 82474 - UI: enhancement request: mark as favourite style, search for styles
Summary: UI: enhancement request: mark as favourite style, search for styles
Status: RESOLVED DUPLICATE of bug 93111
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: needsUXEval
Depends on:
Blocks: Sidebar-Styles
  Show dependency treegraph
 
Reported: 2014-08-11 19:23 UTC by Patrik
Modified: 2020-09-10 12:53 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patrik 2014-08-11 19:23:17 UTC
Please provide a better way to organize styles. I always need the same bunch of styles, some are custom made, some are standard but changed, some are standard unchanged.

I already have a custom template for this, however the F11 style dialog either shows too much styles to be useful or not those I want. 

I suggest 
1) a "favorite styles" enhancement, allowing me to mark any existing style as favorite. They should be visible in the style dialog whether I used these styles or not.
2) or a search field for styles, where the existing styles get thinned out as I type (like google search with suggestions). This feature should be accessible by keyboard shortcut to be useful. 

Regards,
Patrik

*Unfortunately I seem unable to do a feature request properly as suggested, as an enhancement (bug). There is no enhancement that I can find on this website.


Operating System: All
Version: 4.4.0.0.alpha0+ Master
Comment 1 sophie 2014-08-14 15:54:25 UTC
Confirmed that a search or favorite function would be nice. Set as enhancement and New - Sophie
Comment 2 Patrik 2016-04-18 07:37:29 UTC
I wonder if nobody else thinks that the style-pane could be improved by something like this. There have been no comments, maybe there exists another feature-request with something similar?


Any way, I have now created custom versions of heading1-6 and everything that I need repeatedly, just so they show up under custom styles all together. I also use keyboard-shortcuts for styles a lot.

Switching between the numerous styles, just to get to the ones that I use regularly costs time, and I have to do it often. However, the styles I need do change, and I keep wishing for a quick way to switch between them - without having to redefine standard-styles as custom ones.

It could be kind of similar to the starring in gmail, google-docs, Thunderbird or bookmarking in Firefox - enabling me to have the styles, that I need this time ready in the format pane.
Comment 3 Heiko Tietze 2020-08-15 08:37:31 UTC
(In reply to Patrik from comment #0)
> I already have a custom template for this, however the F11 style dialog
> either shows too much styles to be useful or not those I want. 

I guess it's a) using the filter "applied styles" don't show the recommended favorites and b) the hierarchical view is bulky. However, the favorite tag is just one possible solution and before introducing something else I'd prefer the existing methods. There is first of all the "Automatic" filter, requested as default in

Bug 69551 Styles & Formatting deck is overpopulated with styles 

(Whether this is made the default or the last choice is remembered as in bug 126204 doesn't matter)

Tried to resolve bug 93111 requesting the same as duplicate but this wasn't accepted. See also my summary in bug 93111 comment 13.

To sum up, despite of being the older ticket I'd make this one a duplicate of 93111 since the discussion there has matured.
Comment 4 Thomas Lendo 2020-09-08 19:40:44 UTC
Point 1) "favorite styles" in comment 0 is a duplicate of bug 93111 (whith a longer discussion than here).

Point 2) "search field" is a new idea (or the s there another bug with only this topic?). I like the idea of a way to search fast and assign a style to content. A HUD for styles. :) Only the lost space in the styles sidebar deck is problematic. I don't see how this could be implemented in a good way outside of the sidebar.
Comment 5 Heiko Tietze 2020-09-10 12:53:01 UTC
(In reply to Thomas Lendo from comment #4)
> Point 1) "favorite styles" in comment 0 is a duplicate of bug 93111 (whith a
> longer discussion than here).

So let's make it the duplicate.

*** This bug has been marked as a duplicate of bug 93111 ***