Download it now!
Bug 82476 - Crash in presentation when media toolbar is closed
Summary: Crash in presentation when media toolbar is closed
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2014-08-11 19:35 UTC by Jean-Baptiste Faure
Modified: 2014-10-09 11:43 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
backtrace for the master (11.01 KB, text/plain)
2014-08-13 04:38 UTC, Jean-Baptiste Faure
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Baptiste Faure 2014-08-11 19:35:37 UTC
Steps to reproduce:
1/ open https://wiki.documentfoundation.org/images/c/cc/Monster_gltf_model.odp
2/ select the 3D model object
3/ click on the slide outside the object

current behavior: crash

Crash reproduced in 
Version: 4.4.0.0.alpha0+ Build ID: d79d2f0ef7a0e300a3ee4be128c625121d0c4b26
Version: 4.3.2.0.0+ Build ID: 64157c4598606b094f5783804b38cfb4c901a88a
Both versions build at home under Ubuntu 14.04 x86-64

Best regards.JBF
Comment 1 Julien Nabet 2014-08-11 20:15:13 UTC
On pc Debian x86-64 with master sources updated yesterday, I don't reproduce the crash.
I noticed this:
warn:legacy.tools:3000:1:vcl/source/gdi/bmpacc.cxx:57: Forbidden Access to empty bitmap!
warn:legacy.tools:3000:1:vcl/source/window/window.cxx:852: Window::Window(): pParent == NULL
warn:vcl.opengl:3000:1:vcl/source/opengl/OpenGLContext.cxx:337: OpenGL debug message: source: API, type: error, id: 1, severity: high with message: GL_INVALID_OPERATION in glDeleteShader

Would it be possible you retrieve a backtrace?
Also it could be useful you indicate your graphic card.

(In my case, NVIDIA Corporation GF108M [GeForce GT 525M] (rev a1))
Comment 2 Jean-Baptiste Faure 2014-08-13 04:38:57 UTC
Created attachment 104540 [details]
backtrace for the master

Here is a backtrace for the master. No debug symbol, hope this helps.
Version: 4.4.0.0.alpha0+
Build ID: e05da0d5d5399714f52e9f6df404870a381832c8
build at home on Ubuntu 14.04 x86-64

Best regards. JBF
Comment 3 Julien Nabet 2014-08-13 06:46:48 UTC
It seems linked to accessibility part.
I'll give a try with accessibility option enabled.
If you have some time, you can give a try with accessibility disabled.
Anyway, let's put this to NEW since there's a bt.
Comment 4 Julien Nabet 2014-08-14 20:59:02 UTC
Even with accessibility enabled, I don't reproduce this :-(
Perhaps someone will be luckier than me :)
Comment 5 Jean-Baptiste Faure 2014-08-14 21:29:39 UTC
(In reply to comment #3)
> It seems linked to accessibility part.
> I'll give a try with accessibility option enabled.
> If you have some time, you can give a try with accessibility disabled.

I do not know how to be sure that accessibility is disabled in Ubuntu. I unchecked all accessibility settings under "System parameters" with no change.

Best regards. JBF
Comment 6 Tamás Zolnai 2014-08-17 07:50:21 UTC
Hi Jean-Baptiste Faure,

Can you test whether you can reproduce the same problem with a movie?
Maybe it is something with the media window used by both movies and 3D
models.
Comment 7 Jean-Baptiste Faure 2014-08-17 18:06:47 UTC
(In reply to comment #6)
> Hi Jean-Baptiste Faure,
> 
> Can you test whether you can reproduce the same problem with a movie?
> Maybe it is something with the media window used by both movies and 3D
> models.

Good catch !!! I tried with the test kit in bug 45081 and got the same crash. In the terminal the error and warning messages are:
Warning: option --ffmpeg-threads no longer exists.
Warning: option --ffmpeg-threads no longer exists.
[avi @ 0x3b5f9c0] non-interleaved AVI
[avi @ 0x3bd5880] non-interleaved AVI
Fontconfig warning: FcPattern object size does not accept value "0"
Fontconfig warning: FcPattern object size does not accept value "0"
Fontconfig warning: FcPattern object size does not accept value "0"
Fontconfig warning: FcPattern object size does not accept value "0"
[mjpeg @ 0x3bb8ae0] No JPEG data found in image (same message x 56 times)

** (soffice:2556): WARNING **: Unknown event notification 38

** (soffice:2556): WARNING **: Unknown event notification 36

Best regards. JBF
Comment 8 Tamás Zolnai 2014-09-26 12:00:57 UTC
I change the subject, since from the back trace it seems the problem actually related to the media toolbar (used both by movies/sounds and by 3D models). It seems the crash happens when the toolbar is destroyed (clicking outside the object trigger closing the media toolbar)
Comment 9 Jean-Baptiste Faure 2014-09-28 19:00:40 UTC
The crash is surely related to accessibility. For the purpose of bug 70465 I had to create for me a new clean Unity session on my Ubuntu. Now, as I do not reproduce bug 70465 anymore, I do not reproduce this crash too. No crash anymore with the test kit of bug 45081.

Best regards. JBF
Comment 10 Tamás Zolnai 2014-10-09 11:13:45 UTC
(In reply to Jean-Baptiste Faure from comment #9)
> The crash is surely related to accessibility. For the purpose of bug 70465 I
> had to create for me a new clean Unity session on my Ubuntu. Now, as I do
> not reproduce bug 70465 anymore, I do not reproduce this crash too. No crash
> anymore with the test kit of bug 45081.
> 
> Best regards. JBF

So can we close this bug?
Comment 11 Jean-Baptiste Faure 2014-10-09 11:43:32 UTC
(In reply to Zolnai Tamás from comment #10)
> [...]
> So can we close this bug?

Ok, closing as worksForMe.

Best regards. JBF